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1. GstarCAD 2018 Introduction and Installation

1.1. GstarCAD 2018 Introduction

Users can visit www.gstarcad.net to download GstarCAD 2018 to your computer or server.

Design, share and visualize your CAD drawing is better with GstarCAD 2018. Best-ever core performance, best-ever
functionalities implementation and best-ever innovations are what this CAD platform offers.

This section helps you get started using GstarCAD 2018 software by explaining how to install it and providing basic information
about how to use it.

1.2. System Requirement

System Requirement

Before installing GstarCAD, please confirm whether the specifications of your PC meet the following requirements:

0S(Operating System)

Windows XP Home and Professional Edition SP2 or later

Windows Vista SP1 or later

Windows 7(32-bit, 64-bit)

Windows 8(32-bit, 64-bit)

Windows 10(32-bit, 64-bit)

CPU

1GHZ or faster, 32-bit(x86) or 64-bit(x64) processor

RAM

For 32-bit GstarCAD - 1GB(3GB recommended or higher)

For 64-hit GstarCAD - 2GB(4GB recommended or higher)

Display

1024 * 768 VGA with True Color (minimum)

Hard Disk


http://www.gstarcad.net/
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1GB free hard disk available or higher(3GB recommended or higher)
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1.3. GstarCAD 2018 Installation
GstarCAD 2018 Install Wizard will guide the user to install the software in the operating system completely and successfully.

Please follow the steps below to install GstarCAD 2018:

1. Double-click the executable file downloaded and the GstarCAD Installation dialog box will pop up, click Yes to continue.

: GstarCAD Installation

(9) Ready to install GstarCAD, do you want to continue?

Yes No

2. Then the GstarCAD Install Wizard dialog box will pop up.

GstarcAD 2018

Install to: éc:\Program Files\Gstarsoft\GstarCAD2018 @ Options

System Requirements | About Activation License Agree to User License Agreement Exit Install

3. Click User License Agreement, then the Gstarsoft Software License Agreement will pop up, you need to select Accept the
terms of the license agreement to continue, and click Next button.
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4. Click Browse | [ | button and choose the destination path where setup will install the files and then click the Options

button.

Install to:

GstarcaD 2018

Gstarsoft Software License Agreement

Gstarsoft Co.,Ltd. (“Gstarsoft™) licenses the software to you only upon the condition that you accept all of the terms in this
SOFTWARE LICENSE AGREEMENT.

ATTENTION:

Read the terms and conditions of this license agreement carefully. Use of the software is subject to the Gstarsoft’ s terms set forth
[below. Use of the software also indicates your acceptance of the license terms. If you do not accept the license terms, you should select
“Cancel” to quit the install. Within 30 days of trial using or before the license code is provided from your purchase, return the software,
the software package and all other items in the package to the location where you acquired it for a full refund. If the software ins bundled
with another product, you may return the entire unused product for a full refund.

COPYRIGHTS AND TRADEMARK

GstarCAD is developed by Gstarsoft Co.Ltd., protected by the copyright law and international treaties as described in the license
agreement source code of the GstarCAD program is copyrighted by Gstarsoft Co. Ltd..

1. GRANT OF LICENSE

1.1 License Grant

Gstarsoft grants you the non-exclusive, non-sub licensable, limited license se one license of the Software Product on a single
computer, subject to the terms and conditions of this L ement. Use" means installing, loading, running or displaying the
software. You are unable to modify the software or disable any licensing or the control features.

1.2 Stand-alone Version

You may Install and Access a copy of the Software on an individual Computer, which may not be connected to a network in a manner
that allows more than one user to Access, upload, operate, view or otherwise create or use a copy of the Software. You may not Install

° Accept the terms of the license agreement

. Do not accept the terms of the license agreement

Cancel Back Next

GstarcAD 2018

System Requirements | About Activation License | Agree to User License Agreement Exit Install

{c) Options

5. In the GstarCAD Install Wizard > Options dialog box, users can select or deselect the features according to your need. If you

3
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want to review or change any of your installation settings just click the Back button. Confirm the path and click the Install
button.

GstarcaD 2018

Select the features you want to install, and deselect the features you
do not want to install.

EXPRESS TOOLS

The GstarCAD Express Tools contain a library of productivity tools
designed to help you extend the power of your design.

VBA
After instaling VBA,VBA environment can be provided for the

secondary development through VBA interface in GstarCAD.
(It's not availalbe in 64 bit version.)

Install to: 'C:\ProgramFilles\Gstarsoft\GstarCADZOIB

Cancel Back Install

6. Then you just need to wait for a few minutes for the Overall Progress.

GstarcAD 2018

Overall progress...

System Requirements | About Activation License
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8. Then you will see the workspace selection window. Select your favorite workspace and click the Finish button to exit the
wizard. The GstarCAD wizard has successfully installed GstarCAD 2018.

GstarcAD 2018

Please select your favorite workspace:

© 2D Drafting @® GstarCAD Classic

Remark: What is different with GstarCAD 2017 is that, in GstarCAD 2018, AutoXIsTable is not a separate installation package.
That means when you finish installing GstarCAD 2018, then you finish installing AutoXIsTable.
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2. Starting up GstarCAD 2018

2.1. The User Interface
You can enjoy working at GstarCAD 2018 environment in different ways. You can display and rearrange elements like the

toolbars, display the command bar, switch between workspaces, change the interface themes and enable the status bar. The
toolbars and command bar can also be floated anywhere on the screen or docked as well.

12
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Width 41450302 Y
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Customize Quick Access Toolbar
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2.1.1. Quick Access Toolbar =1.
ave
Save As
Display the frequentl s | Plot
play . d y  |o) (25~ "4 2D Drafting - . v | undo
used tools like: New, Open, o1 Redo
Save, Undo, Redo, Save As, Plot, Plot Preview and Help. Moreover you can customize v | workspaces
it(adding more commands from the drop-down button) or showing it bellow/above the More Commands...
ribbon Show Below the Ribbon
Minimize the Ribbon

2.1.2. Workspace Switching

Switch between two workspaces (2D Drafting and GstarCAD Classic).

7= = g 20 Drafting b

Eile Edit View [Insert Fc elalelgijdh]
Insert Annotation Ell GstarCAD Classic

ce B =
I=22 B ORaX X0 I/ /2007 00~0nAR - anseDAlld |
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2.1.3. Menu Bar

The menu bar is used for selecting commands by mouse instead of inputting commands by keyboard. In it you can find the
follow menu tabs: File, Edit, View, Insert, Format, Tools, Draw, Text, Dimension, Modify, Window, Help and Express.

View  Insert

Format Tools Draw Text Dimension Application  Help  Express

Annotation 3D

Layout View

W EEECE
L2970 otanar s

Manage

g%%%gz%
== o = =

Application Help Express

£F
YL R ©
Line Polyllne Circle Arc . 0_‘ Layer o8 Text Insert QR
- - MR ] o Propertleslu ﬁlﬁlmo L| - r_1 T Code~
Modify - |

2.1.3.1. Menus and Shortcut Menus

File §L1§ View Insert Format Tools Draw Dimension Modi

You can use any of the option on the Menus from the menu bar at the top of the drawing
area. Choose one of the following methods to use a menu:- On the menu bar, click a

menu name to choose the menu or to expand a list of options.- Press Alt and the key for
the underlined letter in the menu name to open the corresponding menu item list, and
then choose menu items from it. For example, to edit the drawing file, press <Alt+E> to

open the Edit menu.

Shortcut menus provide quick access to specific commands. A shortcut menu displays
when you right click an object, status bar, the Model tab name, or a Layout tab name. The selections presented in the shortcut

menu depend on what you clicked.

2.1.3.2. Shortcuts Customize

A faster way to invoke a command is customize its shortcut. The
CUSTACC command allows you to customize, delete or modify existing
command shortcuts. To access this command go through the menu bar,
under tools, select customize and choose Shortcuts Customize. After that,
the shortcut customize window will pop up. As you can see, there is a list
of shortcuts command that you can easily modify, delete or even make a
new one over an existing one.

g CHesR

MR

Repeat GRIP_STRETCH
Recent Input

Clipboard

Erase

Move

Copy Selection
Scale

Rotate

Draw Order
Group

Deselect All
Quick Select...
QuickCalc
Find...
Properties

H

XN

= o

2 R

Temporary track point

Cut

Copy

Paste
Paste as Block

Paste Special...

Delete
Select All

BR RoHE FE 2

OLE Links...

@, Find...

Copy with Base Point

Paste to Original Coordinates

CTRL+Z
CTRL+Y

CTRL+X
CTRL+C
SHIFT+CTRL+C
CTRL+V
SHIFT+CTRL+V

CTRL+A

= 2
Mid Between 2 Points Repeat MOVE
Point Flters , Recent Input v MOVE
3D Osnap b Clipboard 3 CEESIREIES
CIRCLE
oy = |Unis OPTIONS
e S R
Apparent Intersect & Z::m TIPOFDAY
Extension (G:STARTUP)
[ Quick Select...
Center
@ QuickCalc
Quadrant )
Tangent ) |Gk
[E] Options...
Perpendicular
Parallel
Nede
Insert
Nearest
None
Osnap Settings..
r
(G Shorteuts Customize ﬂ
Name Button Source ol [LJ
Clean Screen CTRL+0 GCAD
Emdcommand Line CTRL+3 GCAD
[ Copy Clip CTRL4C GCAD
1, Copy with Base P... SHIFT4CT... GCAD
CTRL+H CTRL+H GCAD E
CTRL4R CTRL+R GCAD
#cut CTRL+X GCAD
BiDesignCenter CTRL+2 GCAD
(et CTRL+Q GCAD
2 Hyperiink... CTRLHC GCAD T
Magnifier CTRL4E GCAD
New... CTRL4N GCAD
= Open... CTRL+0D GCAD
[PiPaste CTRL+Y GCAD
]paste as Block SHIFT4CT...  GCAD
&SPiot... CTRL+P GCAD
=2 Properties CTRL+1 GCAD
QuickCalc CTRL+8 GCAD il
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If you want to create a new one, just click the New button and

-
G Customize Command

-

Command

Search Command list:  comm

Command properties
B Command
Tags

the customize command window will pop up. Then you can (24 commends ony ] e oS¢ S S50
. Command Name Command Line
search the command or select one from the command list. For Commano aLzss B o .. |
, , 5 Advorond
example, you can input “command ling” and then select the FIE COMAD L = ID_Crdne
requested command. Notice that by selecting the requested e coseton.
command, at the right side of the window, will display the
command properties. After selecting the command, press the
OK button. — —
Then the set shortcut window will pop up. You
. . p p p lu= Set Shortcuts - s g (-] Ehar o b
can input the desire keyword(s). For example, — pe———
you can set the shortcuts SHIFT+D. If you want L Do s o] || CHen
- Bzmis oy B .. SUTHCT.. oD oote
to delete a created shortcut command, invoke = o o e
the command CUSTACC and then select the | B T i
———— — — (OExit CTRL+Q GCAD

delete button from the Shortcut Customize
window.

2.1.4. The Ribbon

The ribbon consists of several panels, which are organized into each tab according to their task label. The tools and controls in

gach panel are also available in toolbars and dialog boxes.

Tab: The ribbon is structure by tabs. Every tab displays a
series of panels with its own tools (commands or thumbnails)

Home

3D

View

v

Manage  Expo

Insert Annotation ED Layout View Manage Export Help Express Appearance a x
I - | @ move T Revoe -Tim - 2 || & g rE QB o8 3 || @ Msaver - o [ 12 E'S
:L/j :—? @' !;’“ O | Do Muwiwer e - f‘ I f%d = D = @
e Pobine Qe A @ | [\ e T scate Baney & || 22 Q EEEEN: [ A L I Blae || e e
— Panel Tab Expandable panel Expandable tools button

sort  Help  Express

gasier to select or pick.

Panel: The panel shows the most used tools. Some
thumbnails has an expandable tools button that can be

expanded in a drop-down method. In addition, most of panels at home tab havean expandable panel that

show up more commands related.

Expandable Panel: The expandable panel is located at the bottom of the panel. If you click at the bottom of

the panel, more commands related will be displayed.

Home Insert Annotation 3D

Line Polyline Clr(le Arc %

Draw v

|l v A S

Standard 2 |._.| 150-25 1§A EI Q
Mcxt!m“ DI R - HW Leader || Wipeout R
e imension . eader || Wipeout Revision
- sty ";” e i) ‘é H®m Cloud
[CLYSM inset  Annotation 3D  layout  View  Manage  Export  Help  Express
/ @{("D & Move OnwoM-ﬁmw(z‘@%e@&%@é
= Ry Mwnor [ rne K
Line  Polyine Cirde  Arc e
||| [\ Extrude Ti]scate BBaAmay & d BB el EE
T T
/DD o HE
e P Gige) M g
—
| == O i e
=
(@) conenmc
oL
o™
(2} Tan Tan Radi
{5 o tan an

- é - <% panel) have an expandable tools button that can be expanded in a drop-down method. If you
— click this button, all related tools will be displayed.
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2.1.5. Appearance

You can manage the interface’s theme plus show/display toolbars, menu bar, file tabs and status bar.

r v
= ToolBar g
[ Dimension -
ByLayer H [ Draw
———— Bylayer | EEELEY [ Draw Order
Windows 7 [ Insert =
e :
Office 2007 Blue
Annotation - Properties [ ] Modfy
Office 2007 Black [ Madify 11
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Office 2007 Agua [ Style
[]OSNAP
Express Appearance ~ [_| |5 [x [~ Refedit
= Toolbars... B
L0 ] A r_.l @q @ Movtoyer oo @ 12 [E % » [| Refersnc
g x | 23 = Bylayer - M W R () Menu Bar [T Render
Text Linear | Insert w Group | Measure Paste
g ERB ety Q- = e[| [MeEG a7 | | File Tabs [ Modeing
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2.1.6. Drawing Area

Your drawings are displayed in the drawing window.

|

Bl B2 B3 i

— e -
=i ewsl F
leas Blisas | e -

W] )

2.1.7. Toolbars

Toolbars partially contain buttons that start commands. When you move your mouse or pointing device over a toolbar button,

the tooltip displays the name of the button.
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The Standard toolbar at the top of the drawing area contains commonly used commands such as Copy Pan and Zoom, as well
as Microsoft Office standard commands such as New, Open, and Save. GstarCAD 2018 classic workspace initially displays
several toolbars by default:

- Draw toolbar 7200/ @avonqm-aaADAR

- Draw order toolbar

- Change toolbar o adeBBeonilh+ /OO0 7 @

- Properties toolbar [/ ey )| Byver v [——bmer v BYcOLOR B
- Layer toolbar | EIFEEL N

- Style toolbar [ 4 [ stenda ~] [ 15025 || o[ standare -§

- Standard toolbar e eha xDhdz »- -~ HAQAQQ[ZG2E Qf

2.1.7.1. Displaying and Hiding Toolbars

GstarCAD 2018 provides many toolbars, which you can show or hide in both classic and ribbon interfaces. You can also move
and dock toolbars. To choose which toolbars to display:

1.- Execute TOOLBAR command or select the option TOOLBARS from the drop-down list under Appearance button (at top right
of the interface) to open the Toolbar dialog box.

2.- Choose the toolbars you want to hide or display by checking/unchecking the small boxes in the dialog box, then click OK.

s N
G ToolBar ﬂ

[—] Dimension A

Ep el -
DE:Order EFEEEEET
[¥] Insert =
[ Layout PR

Fvosty I8 mpepoiE & ef
] Mody I
[] Properties
e esaeBe O~ O 7 ol
[F|OSNAP
(S I-T /-~ X< 10006|L=r | ~& &f
[ Render

[ Modeling
[] Solid Editing
[~ Standard Annotation S

Felp

To make floated a horizontal docked toolbar, just click and hold the 4 Drawing2.awg

left side of it and drag around the place you need. lrr200r@eorocan - ado Al
Ha  seonda - & 15025 -

To make floated a vertical docked toolbar, just click and hold the top k PN =T Y R Y

4 DrawingZdwg x

of it and drag around. To dock any toolbar, just double-click at the left 5

side of it B

/A S500/7 O0roodB - @l A|

4 ing2.dwg X
z Aa ?kision Cloud i

To start a command from a toolbar, click a command button and respond to the prompts.

2.1.7.2. Starting Commands Using Toolbars
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2.1.8. User Coordinate System (UCS)

The icon indicates the orientation of the drawing in two dimensional space.

Mode| / Layoutl / Layout?

2.1.9.Model Space and Layout Space tabs

Click a tab to switch between the drawing of your model and a printed layout.

4 AREASUM SAMPLE FOR DEMO.dwg 4 AREASUM SAMPLE FOR DEMO.dwg

Baseball Field

Area summatory Baseball Field

Area summatory

1

14 4 » M ' Model £ Layoutl M4 v w4 Model 3 Layoutl

2.1.10. Command Window

The command bar is a dockable window in which you can type commands and view prompts and other program messages. You
can move the command bar by dragging it.

When the command bar is floating, you can drag the top or bottom of the window to change the number of lines of text it
displays. You can dock the command bar at the top or bottom of the drawing.

vdlCommand: _circle
[l Specify center point for circle or [3P/2P/Ttr/Arc/Multiple/Concentric]:
specify the radius of circle or [Diameter] <19.8752>:

Command :

1288 4132, 1058.1209, 0

Command : o

Command: _circle
Specify center point for circle or [3P/2P/Ttr/Arc/Multiple/Concentric]: (I
specify the radius of circle or [Diameter] <19.8752>: -

Command : <« [ 3
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2.1.10.1. Enter Commands on the Command Line

Type the full command on the command line and press ENTER or
SPACEBAR, or right-click your pointing device to start the command.

Some commands also have abbreviated names (aliases).

2.1.10.2. Specify Command Options

Once you have entered a command on the command line,
it displays a set of options or a dialog box. To choose a
different option, enter one of the options in the brackets
(either uppercase or lowercase letter is OK), and then
press ENTER or SPACEBAR

2.1.10.3. Execute, Repeat and Cancel Commands

Command Line x
TG, L dricer

Command: circle

\Specify center point for circle or [3F /2P /Tir/Arc/Multiple]: osnap

=>Resuming CIRCLE command.

ISpecify center point for circle or [3P/2P/Tir/Arc/Multiple]: Cancel” ||

Command: “Cancel” -

Command; SPLINE | < [ v
Command Line x
ITTTIgrig. Cree i
\Specify center poi[SPQPmrfﬁu'chuhiple] “osnap
==Resuming CIRCLE command.

\Specify center point for circle or [3P/2P./Ttr/Arc/Multiple]:"Cancel™
Command: “Cancel® [
Command: SPLINE -

\Specify first point or [Object]: O < [ 3

To execute commands, press SPACEBAR or ENTER, or right-click your pointing device when the command names has been
entered or responsive to prompts. If you want to repeat a command that you have just used, press ENTER or SPACEBAR. To

cancel a command in progress, press ESC.

2.1.10.4. Nesting a Command

To use a command inside an active command, type an apostrophe before you type the command. For example, you turn on the
object snap while you are drawing a circle, thus you can setup Object snap mode before continuing drawing.

Command: circle>Specify center point for circle or [3P/2P/Tir (tan tan radius)]: 'osnap

(Setup object snap mode as Center in Draft Settings dialog, and then

close the dialog to go on performing CIRCLE command)

G Drafting Settings @
Snap and GRid | Polar Tracking | Obiect Snap | Dyniamic Input | Magnifier | Symmets| + [

Model / Layoutl / Layout2

x Command:lcircle I
B specify center point for circle or [3P,"2P/Ttr/Ach."Iultiple/Concentr‘i:]i'osnapl

13293593, 222.7849, 0

LW S e s s

[¥] Objsct Snap On (F3) [¥] Objsct Snap Tracking On (F11)
Object Snap modes
O [C] Endpoint T [Jinsetion Select Al
A [T Midpoint b [7]Pependicular
& [¥] Center 75 [ Tangent
12 [T Node % [ Nearest
&[] Quadrant B[] Apparent intersection
> [ intersection o[ Distance from Endpoint 100
=u || Bxtension -%- [|Divide  Segmerts 2
# [ Parallsl
1 To track from an Osnap point, pause over the point while in a
% command. Atracking vector appears when you move the cursor. To
stop tracking, pause over the point again

0K Cancel Help

10
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2.1.10.5. Enter System Variables on the Command Line

Command: _circle o

System Varlables are avallable for Contronlng hOW Specify center point for circle or [3P/2P/Ttr/Arc/Multiple/Concentric]:

Specify the radius of circle or [Diameter] <19.8752>: [

certain commands work. For example, GRIDMODE jg ~ [ormend: griduede _ 2

|Enter new value for GRIDMODE <@>: 1 4 2
used to control the grid status ON or OFF.

G gead Text Window o[ [ |
2.1.10.6. Using the Prompt History Window Eat

Command: Specify opposite corner: *Cancel®

Command :

The Prompt History window displays a history of the | |coman
commands and prompts issued since you started e e
the current session of GstarCAD.

Command: *Cancel®

Command: LINE
Specify first point:
Specify next point or [Angle/Length/Undo]:

. . . Specify next peint or [Angle/Length/Undo]:
To d|3p|ay or close the Prompt H|3t0ry window Specify next point or [Angle/Length/Closed/Undo]:
Specify next point or [Angle/Length/Closed/Undo]:
press F2 Specify next peint or [Angle/Length/Closed/Undo]:

Command: CIRCLE
Specify center point for circle or [3P/2P/Ttr/Arc/Multiple/Concentric]:
Specify the radius of circle or [Diameter]: =

To view entries in the Prompt History window, just command: | o

drag the scroll bars or use the Up (1) and Down (] ) arrows to display previously used commands.

2.1.10.7. Switch Dialog Boxes and Command Line

If you enter LINETYPE on the command line, the Linetype Manager dialog box will pop up. Entering -LINETYPE on the
command line displays the equivalent command line options. The system variables below affect the display of dialog boxes as
well:

-ATTDIA controls whether INSERT uses a dialog box for attribute value entry.

-EXPERT controls whether certain warning dialog boxes are displayed.

-FILEDIA controls the display of dialog boxes used with commands that read and write files. For example, if FILEDIA is setto 1,
OPEN displays the Open Drawing As dialog box. If FILEDIA is set to 0, OPEN displays prompts on the command line. Even
when you set FILEDIA to 0, you can get a file dialog box displayed through entering a tilde (~) at the first prompt.

2.1.10.8. Dynamic Input

DAN (DIMANGULAR)
Command: *Cancel* & DAR(DIMARC)

DATALINKNOTIFY

[ pate |

"Dynamic input" box is a floating window which appears near the cross cursor. i i

It provides a convenient method for users to input commands or system ! Spmm,p,mfm,o,
variables dynamically and display the index information. When the DYNmode "7 " e

is turned on, a drop-down box will appear near the N

cross cursor. Type a command using the dynamic input, L y %

it displays a list of all the commands whose prefix T o Do nneiy

matches what you've typed plus it will displays all their
icons making easier to recognize them at glance. NGO BT
What's more, the dynamic input displays all options of a command and could select them in different methods.

11
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2.1.11.Status Bar

Display information such as the current cursor coordinates, Snap, Grid, Ortho, Polar, Osnap, Otrack and other settings. In
addition to displaying information, the status bar is a quick way to access many features. You can click status bar items to make
changes, and right click items to display short cut menus that allow you more choices. By default, the status bar is shown as
the picture below:

¥ SNAP(F3)
¥ GRID(FT)
v ORTHO(F8)
v POLAR(FL0)
v OSMAP(F3)
v OTRACK(F11)
¥ | LWEIGHT
v DYN(F12)
e ¥ MAGCTRL
v Model/Paper
v COORDS(F6) v Annotation Visibility
Y Status Toggles F| ¥ AutoScale
v Display Locking
Model glayoutl £ layoutd v DisplayIsolation
Pllcommand: *Cancel* v Performance
pdiCommand: Specify opposite corner: *Cancel® v Clean Screen(Ctrl+0)
ommand

Tray Settings...

The status bar icon also can be show as text button, right click on one of the icon

of the status bar, uncheck the "Use Icon" option, you will get another method to

1gth/Unde]: *Cang Settings...

v Uselcon

@hﬂ'-gl-"l:l"""

show the status bar.

WY GRID ORTHO (gl OSMAP [ntied [WEIGHT MAGNIFIER [Nle]elal % 1:1- ¢ B¢

2.1.12. Properties Palette

You can modify the value or properties of object(s) you wanted in each column. The Properties palette shows all properties of
the specified object. When selecting multiple objects, the Properties palette shows the command properties of the selected
objects. If none of the object is selected, the Properties palette displays the general properties of the current layer, View
properties as well as the UCS information. By default, double-click an object opens Properties palette if the Properties palette is
hidden. This operation is not available when the objects are block, hatch pattern, text, multiline, external reference or gradient

](Ill 4 BEARING DRAWING.dwg X
(et o) [ [
Color W Color 150
Layer 0
Linetype — Bylayer
Linetype scale | 1
Plot Style BYCOLOR
Lineweight — Bylayer
Hyperinkc
Type Predefined
Pattemname | ANSI31
Angle 0 — e
Scale 25
Origin X 0
Origin Y 0
Spacing 25
1SO pen width | 0.13mm
Double No
Associgtive No N -
Island detectio... Nomal
Annotative No
L ® 12
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2.2. Gustomize the Drawing Environment

In GstarCAD 2018 there are different elements of the working environment that can be customized to fit your needs.

2.2.1. Set Interface Options

In the Options dialog box, you can change many of the settings that affect the interface and drawing environment.

F bl
G Options M

Cument profile: <<Unnamed Profile>> a Current drawing: Drawing 1.dwg

| File | Display |Open and Save I Flot and Publish | User Preferences I Diraw |Se|edion set | Profiles ICloud stora | *

Window Elements Display resolution
Appearance a 1000 Arc and circle smoothness
[ Digplay scroll bars in drawing window a s Segments in @ polyline curve
[ Use large buttans for Toalbars a 05 Rendered object smoothness
[¥] Show Tool Tips a 4 Cortour lines per surface
[ Colors... ] [ Fonts... ] Display perfformance

[] Pan and zoom with raster & OLE
Layout Regen Options a Highlight raster image frame only
() Regen when switching layouts a [¥] Apply salid fill

a [ Show test boundary frame only
|| Draw true silhouettes for solids and sufaces

() Cache model tab and last layout
(@ Cache model tab and all layouts

Crosshair size

Layout elemerts
Display Layout and Model tabs 5 1J
Display printable area Fade control
Display paper background Xref display

Display paper shadow 50
[] Show Page Setup Manager for new layouts Inplace edit and annotative representations
[¥] Create viewport in new layouts 70

Aoply Help

2.2.2. Settings of Modifying Interface

Automatic Save (Open and Save tab): Save your drawing at specified time intervals. To use this option, in the Options dialog
box, Open and Save tab, select Automatic Save and enter the interval in minutes.

r b
(G Options ﬂ

Cumert profile: <<Unnamed Profile>> n Current drawing Drawing1.dwg
File Display | Open and Save | Plot and Publish I User Preferances | Diraw | Selection set I Profiles I Cloud stora| * | *
File Save File Open
Save as: 3 Number of recenthy-used files
[AutoCAD 2013 Drawing(wa) -] 7] Display ful pathin tite
Maintain visual fidelity for annotative objer Application Menu
Mairtain drawing size compatibil
@ g L 5 MNumber of recently-used files
[ Thumbnail Preview Settings ]
50 Incremental save percentage Yrefs
Demand load Xrefs:
File Safety Precautions
[Enale -
Automatic save
50 Minutes between saves & Retain changes to Xref layers

Create backup copy with each save
| Full4ime CRC validation
[ Mairtain a log file

&) ] Allow cther users to Refedit cument drawing

GRX Applications

svE File extension for temporary files Praxy images for custom objects:

Security Options... Show proxy graphics -

Display digtal signature information
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Color (Display tab): Specify the background colors used in
the layout and Model tabs and the color used for prompts
and crosshair.

Font (Display tab): Change the fonts used in the window
and in the text window. This setting does not affect the text
in your drawings.

r
& Options

Curmrert profile: <<lnnamed Profiles> |

| File

Display §Open and Save | Plot and Publish | User P

Window Elements

GstarCAD

)

Appearance

[] Display scroll bars in drawing window
[ Use large buttons for Toolbars
Show Tool Tips

[ Colors... Fonts...

J |

2.2.3. Save and Restore Profiles

Search Path (Files tab): Set the search path to find drawing
support files such as text fonts, drawings, linetypes, and
hatch patterns.

g
G Options
Current profile: <zUnnamed Profile>> n Current drawing:
l File IDlspIay I Open and Save | Plot and Publish I User Preferences I Draw I Selectior

Search paths. file names, and file locations:

% Support File Search Path

% Working Support File Search Path

E Customization Files

E Help and Miscellaneous File Names

E Text Editor, Dictionary, and Fortt File Names
E Print File, Spooler, and Prolog Section Names
E Printer Support File Path

% Automatic Save File Location

% Color Book Locations

(-] Template Settings

% Tool Palettes File Locations

% HAuthoring Palette File Locations

% Log file location

% Temporary Drawing File Location

% Temporary Extemal Reference File Location

Creating profiles for different users or projects and sharing profiles by importing and exporting profile files are enabled. By
default, your current options are stored in a profile named Default. The current profile name, as well as the current drawing

name, is displayed in the Options dialog box.

G Options =2
Curert profile: <<Unnamed Profile>> &) Curent drawing: Drawing1.dwg
File | Display | Open and Save | Piot and Publish | User Preferences | Draw | Selection set | Profiles | Cloud sioral ¢ |
Available profies
<
. »
G Add Profile =)
Pl name »
New DWG PJ workstation
Description
e pepe— =
| .|
oG
oK | [ Cancel Apply Help

[G tport poric i =5
Saven: , TOOLS (D) - @3 @
. Name Date modified Type size
< Canon iR 2318L_UFRI 2010 64 2015749956 File folder
< 151231606 File folder =
d 20167477 16:58 File folder
F 214127291612
201471274 955
014712731347
0147127111559
B 2015241519
e 201621291056
GaLMS 215/1/5 1431
= G2015LMSONLINE 2015/1,27 1344
GatarCAD. 3016/7/28 1338
GterCAD 2015 HELP 2154291709 File folder
" GtarCAD 2016 HELP 2159301050 File folder
‘H‘ GetarCAD 2017 HELP 01677121356 File folder
GtarCAD License 01510141008 File folder -
Fie name: Drawing! -
Save s type: Configuration Fie(" ARG) <) [caned ]

GstarCAD 2018 stores the profile information in the system registry and saves it as a text file (an ARG file) and also organizes
essential data and maintains changes in the registry as required.

If you make changes to your current profile during a session and you want to save those changes in the ARG file, you must
export the profile. When you export the profile with the current profile name, GstarCAD updates the ARG file with the new
settings. You can re-import the profile to update your profile settings.

14
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2.3. Customize User Interface

Drag & Drop Customization: An innovative way to customize user interface must be easy and quickly according to user needs,
so this is possible by drag and drop action, that means users can drag any command from the command list and drop it into
workspaces elements like ribbon panels and toolbars that are visible at top right corner of the CUI dialog box. Users will not
have restrictions to place anywhere or even arrange a preferred command on a panel or toolbar. Ul customization has never
been easier and flexible through Drag & Drop action.

—
(& Customize User Inte ;E;L
| @ Elements Custarizatian @ ‘whorkspace Customization | - Tlansfar‘

Customization List: 3 Panel Preview A

| [A\I Customization Files '] ﬁ "32 Iﬂ @ 22 -T- |:’.T Q;" I

=] Panels - £ R 4 2 R T
Bﬂ'l Annotate - Text |; - Standard =
Panel Dialeg Box Launcher
=-&] Rowl
-0 Multiline Text
1[0 Sub-Panel 1
E‘Autumatic Text Numheling
-] <SUDEOUT=
-[37 Annotate - Dimensigns
&7 Annotate - Leadep Properties -
-] Annotate - Tablg = (&
-[3] Annotate -
] Annotate - Afinotation Scaling E Display =l
-] Block Edite/- Manage Mame Automatic Text Mumbering [}
-] Block Editr - Tools El Appearance
ﬂ'] Block Eghtor - Parameters il Button Style Smalkadithout T ext
= Command
Command List: F-3 Command Mame Automatic Text Mumbering
Description Automatic Text Mumbering
Al Commands | auto b4 [
[ l/ I Command Dizplay Mame
Cornrnand Source Macra “COC_TCOUNT
ED Arange Frame Automaticaly EXPRESS Tags
AutoConstidin GCAD E Access
| '= Automatic Text Mumbering GLCAD
‘= Automatic Text Numbering EXFRESS
Paint Cloud Auto Update GLAD
Surface Auta Trimming GCAD
JZ4 A1 o2 Mg TF| =
Mtext
I - lStandard il I

Brief introduction of CUI dialog box:;
1. CUI dialog box: Now the CUI dialog box is divided into three tabs: Elements Customization, Workspace Customization and
Transfer tab in which the main attraction is the Elements Customization tab through its new way of customization (Drag & Drop).

15
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2. Right click menu: Context menu is available for different interface element as shown below:

E Ouick hecess Toolbars

r ; e e
¥ . Rerame F2 =-E5 Ritbon 2 Quick hecess Toolbars
1-F I3 Tabs = [ Ribben
- Restore =] Panels Tahs
=] Panels
Bl E Reset =1 hrmotate — Text
1= Hew Fanel Panel Dislog Beox Launch
- Find ..
7Bz feol Hew Row w1 New Panel
eplace. .. hrmots  Hew Row
FRI|C Eename FZ2
1 ﬁ Armots  New Sub—Panel
Delete Armotas  Hew Drop-down
) Ll Armets 444 Separator
Thplicate Elock
c Block
°F¥ Block | Delete
Elock
Block =~ CoPy
Find .. Duplicate
Replace. .. Command List:
Find. ..
All Commands Replace

3. Find command: There are several methods to quickly find out the command you want, with

these methods, you never need

to browse the command from the top of the list until the end which greatly enhance your work efficiency.

1 2
Command List:
All Commands v
Command Source

0 EXPRESS

45 EXPRESS
[T] Add Bias EXPRESS
2 Add Column EXPRESS
S.c Add Row EXPRESS

Adjust Character EXPRESS
& Align Tool EXPRESS

Angular EXPRESS
25 Arc-Aligned Text EXPRESS
% Area Sum EXPRESS
E Arrange Frame Automatically EXPRESS
“y, Arrange Tool EXPRESS
7A Antach | sader tn Annatation FXPRFGS

3 4 5

DAY

Q@O

1- Filter the command by Category: Click the button right side and select the category the
command belongs which will reduce the command search scope

2-Filter a command by entry relevant keywords: For example, input “dimension” in the filter, all
the commands contains the word “dimension” will be shown, reducing the number of
commands to browse.

Command List: R
|AII Commarids e | |dimensi0n |
Cormand Source )
1«4 change dimenzion text EXPRESS
constraint settings, dmensional GCAD
dimension GCAD B
WAy dimengion edit GCAD
dimenzion precizion GCAD
£ dimengion text edit GCAD
M dimension update EXPRESS
"9 dimension, align text, angle GCAD
I dimersian, align text, center GCAD
,.v'_.. dimension, align text, left GCAD
dimension, align text, lhome GCAD
”_v'“ dimension, align text, right GCAD
"’, dimension, aligned GCAD v

Command List:

All Commands v

GCAD Commands
ExFRESSCommand
Custam Commandz
Contral Elements

Dimenzion
Madify

16
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3- Command cleaner: If you input the keywords in the filter, the icon wiII automatically change to which is used

to clean the content in the filter, meanwhile, the following command list will return to the default state.

4- Find and replace: In Find tab input the command you want to find out and click Find Next, the command you searched will
be positioned accurately. In replace tab, you can replace one command with another command, but we suggest not change the

standard command name and description.

Command List: Find and Replace @

| All Commands v | Find | Replace

Command Find what:
Replace item
Reset Anray
Reset Array
Reset Anay
Reset Block

i, Reset Dim Text Value [ ignore gase
Reset Mapping Coordinates
Restore Viewports
Reverse
Reverse Direction
Reverse Ditectinn

revision cloud

Search string found in command ‘Revision Cloud' property
‘Command Name' at posttion 0.(1/2)

{3 Revision Cloud
[ Rauake

GCAD
Aran

v

5- Create a new command: If it is necessary to add secondary development program command to the command list, you can
set the items follow the current command settings as shown below.

Properties

»

E Command
M ame
Dezcription
Command Dizplay Mame
Macro
Tags
B Advanced
Elerment [D
B Images
Small image

Large image

Restore and reset:

If all the customization operation has been finished, but
you made some mistakes when customizing CUI or you
are not satisfied with the effect, restore and reset can
help you recover to the original settings.

Restore: Restore the backup Settings, click "Apply"
button, the data before modifying will be saved as
backup files which are used for recovery.

Reset: Recover to the initial setting when first installing
GstarCAD.

Array

ARRAY
“CC_amay

RCDATA_16_ARRRAY
RCDATA_16_ARRRAY

G Customize User Interrace W—

| % Elements Customization |@} Workspace Customization | = Transfer|

Cuztomization List:

[.-’-\II Customization Files

Em";- E Rename F2
E Restore
B Reset
o[

E Find...
..
__ Replace...

(% Double Click Actions
@ Meouse Buttons

17
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2.4, Tool Palettes

Tool palettes are tabbed areas within the Tool Palettes window. The items you add to a tool palette are

called tools. You can create a tool by dragging an object onto the tool palette. In GstarCAD, blocks and %M B
external references (xrefs) can be dragged onto the tool palette. The new tool inserted will has the same 2 o
properties into your drawing. Also you can create, delete, rename and customize panels by doing right £ %
click on it. To open the tool palettes just press CTRL+3 or Type TOOLPALETTES command. _
i Rand(
E o
Vew Optons. S =
tersene |
E———— S~

Custornize Commands...

2.5. Design Center

With Design Center, you can organize access to drawings, blocks, text styles and other drawing contents:

-Browse for drawing content on your computer or a networked drive.

-View definition tables for named objects and then insert, attach, copy and paste the definitions into the current drawing.
-Create shortcuts to drawings and folders that you access frequently.

-Add content such as xrefs, blocks to a drawing.

-Drag drawings, blocks to a tool palette for convenient access

Folders Tab: The following icons are displayed in this tab: networks and computers, computer drives, folders, drawings and

related support files, Xrefs, layouts and named objects, including blocks, layers, linetypes, text styles and dimension styles
within a drawing.

Open Drawings: A list of currently opened 5
drawings is displayed. If you click a drawing | pusees & i & =
file and then click one of the definition tables, |3 vemegeus e e B m AF
you can load the content into the content area. 5 G A s

. . . . . € Network ;
History: A list of previously opened files is (-] Corto Pane Text Stle  Linetype

. i . . - 1. Govemor of Poker
displayed. If you double-click a drawing file NetSetMan

. . PHOTOSHOP CS5 E
from the list, you can load the content into the | & for help documentation.dwg
Wl sample.dwg

Content area. windows_7_basic_black_theme_by

Favorites: If you have contents need to access quickly on a regular basis, the Design Center provides a solution to finding those.
When you select any type of content, you can right-click and choose to add it to Favorites. In favorite folder you can save
shortcuts to content on local drives, a network drives. The original file or folder doesn't move; but all shortcuts you create are
stored in the Favorites folder.

18
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2.6. Clean Screen

Now, if users want to maximize drawing space, they can press the keywords Ctrl+0 or select the icon (Clean Screen) located in
the right corner of the status bar. After executing this command, Toolbars and dockable windows (excluding the main menu bar,
command line and status bar)will automatically be cleaned. This function can provides better visibility as large as possible to
make it easier to fully understand every details of the drawing.

/u} O«

v

N S . N 1

o

Model { Layoutl

101 B - B O PR @ 2 & O] Gstarcan

2.7. Lock Ul

Lock Ul locks the position and size of toolbars and dockable windows such as Design Center, Properties palette, etc. To unlock
them temporarily, hold down CTRL key. LockUI setting is stored as a bit code using the sun of the following values:

0 Toolbars and windows not locked

1 Docked toolbars locked

2 Docked or anchored windows locked

4 Floating toolbars locked

8 Floating windows locked

19
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3. Create, Open, Save, Recover a Drawing and Manage Drawings

3.1. Create a Drawing

3.1.1. Create a New Drawing Using Default Settings

When the system variables FILEDIA and STARTUP are set to 1,
typing NEW at the command bar, it opens Startup dialog box, from
which you can use Default Setting, Template or Wizard to create a
new drawing.

You can select either imperial or metric units for the new drawing.

Imperial measurement system: The drawing uses internal default
values with default boundary is 12 x 9 inches.

Metric measurement system: The drawing uses internal default
values with default boundary is 429 x 297 millimeters.

3.1.2. Create a New Drawing Using a Setup Wizard

From the Startup dialog box, you can select "Use a Wizard" tab to
create a new drawing by the wizard. There are two wizard options
illuminated as follows:

Advanced Setup Wizard:

, ,
G coeveromes NI s

Z [0 B8R pefault settin

Default Settings

(7 Imperial{Feet and Inches)

(@) Metric

[T =1
Prompt Info
Uses the default metric settings
[ ok ] [ canca |
e
~u 3
= 0] N

Select a Wizard

Advanced Setup
Quick Setup

Wizard Description

Set the units. angle, angle measure. angle direction, and area for your new
drawing. Based on the template gcadiso.dwt.

[ Cancel

_-""-""""""""""""""——

From this option, you can set units of measurement, precision of displayed units, and grid limits. Also specify angle settings
such as units of measurement style, precision, direction, and origntation based on template gcadiso.dwt.

"G Advorced Setvp G Advanced Setup i
T"“' Soc ot of masmsemrt s T —
Al ks # Courterockwe
© Decms T
Arge Meosse 15,5000 Argle Nessre «
oo = ___l B Sl Oracten
hos G Adanced Setp ) ot
| - N f:
[ e X Seinct e ange of mmntmert o the srecanen for —
s \
¥ Ao © Decmal Degrees 2
| b
| Aetiesan ) Deg/Min/Sec =%
| N .
| Aoge Drecton - \ e e
| G Advanced Setup == Bk | [N )
4 1= — - —. 2|
[ - i
s . Setoc o deacion or migh s G Advced Setup (=X
-
oo © East N i Erter o avea you wart 18 secresert usng.
N Fll el unts. G 1o G 3
< B foge Messre Mo Ao 14125 e e 2 Wi S
Jogle Drecoan - N o ‘; —*— : brcge Masnre S o
o \ Soun 210 Aogje Denction - N\ @
s s
. - N oo > N e =
=
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G coene e orming [N el
Quick Setup Wizard: From this option, you can specify units of measurement, Z| 0D R vse template
precision of displayed units, and grid limits based on template gcadiso.dwt. e
3.1.3. Create a New Drawing Using Template —
When you need to create several drawings with the default 5*'“‘::‘“ . T __
settings, you can save time by creating a template file .. i ——
designed to create the same drawing files so that you does " By maioe
not need to specify default settings each time you start. ==
Conventions and settings commonly stored in template . —
files include: unit type and precision, title blocks, borders, =
and logos, layer names, snap, grid, and ortho settings, grid L ;
limits, dimension styles, text styles and Linetypes. — —— n—

Also when the system variables FILEDIA and STARTUP are set to 1 and 0 separately, typing NEW opens Select Template dialog
box, from which you can select the desired one or use the default template by clicking the arrowhead button next to the Open
button.

3.2. Open a Drawing

i Format Tools Draw Text Dimension Modify
Home D Mew... CTRL+M Manage Export
3.2.1. Open a Drawing New Sheet Set... = | sz g o
/ = Open.. CTRL+O b (&1 =] -
Line Layer I
. . . B  Open Sheet Set... i ver ") mlﬂ.
You can open drawing (.dwg) files, Drawing Exchange B [l cteme
Format (.dxf) files and drawing template (.dwt) Drawil  Import..
files.You can also open and check drawings that you ftach...
suspect are damaged b soe CTRL-S
p ged. [5F SaveAs... SHIFT+CTRL+S
™  Export.
- 0 File >
To open an existing drawing:  File > Open — —
Command line> OPEN Using shortcut> edcm
CTRL+0 -LE} nar:; model 2;1:/1/281”‘ ][y:; Draw... - 672 KB = T
Bomitrom |z ot | o d
[;I EBD SYNC HOUSE FL.. 2012/9/191 ICAD Draw... 680 KB
= 30 VILLE SAVOYE 2014/4/14 8 ICAD Draw... 1,144 KB
-In the dialog box, choose the type of file you want to Borsain  mmee. lonoa smta
open by Eii"p‘?i?éim?;‘j L | Koo | smea
N gl 5- ADMINI- ALOJA.. 2011/3/202.. ICAD Draw.. 23117 KB
B D T e e
EB- corte elevacio p... 2011/10/19 ICAD Draw... 6,693 KB
-Choose the folder containing the desired Bl 8" me oom amo
N 511344453999 2013/8/301... ICAD Draw... 223KB ad
file.-Choose the drawing you want to open, and then SN
. . . Fies of type: Drawing(".dwg) - Cancel
click the Open button or Double click on the drawing St

DX
Drawing Template(" dwt)

you want to open.

21




Chapter3_Create, Open, Save, Recover a Drawing and Manage Drawings

3.2.2. Multiple Open Drawings

You can open multiple drawings at one time. There are several methods for switching a drawing to another.

- Acting the drawing by clicking it or using shortcut keys of <Cirl+Tab>.
-You can change the display styles to Cascade, Title Vertically or Title Horizontally from the Window menu. You can also use
Arrange Icons to align icons if there are several minimum drawings.

File Edit View Insert Format Tools Dimension  Modify

Window

1 Close

Help  Express

ne Insert Annotation 3D Layout View Manage Export

- @f,a o - | @2 &) B 09 -, "é £7 &% 28y CloseAll
D—: [ R = e .
e Polyline Circle  Arc - X AB i/— @ Layer % 4{7} Lock Location 3
- - - IR I R A Properties J ¥’ IE Cascad
ascade
- g Tile Horizontally
ch House Sample.dwg *. bulb sample.dwg . pelan2.dwg ' 3D MODEL SAMPLE.dwg DD Tile Verticall
ile Vertically
EE Arrange Icons
1 Beach House Sample.dwg
2 bulb sample.dwg
3 pelan2.dwg
4 3D MODEL SAMPLE.dwg
Window...

3.3. Save a Drawing
3.3.1. Save a Drawing
You save drawing files for later use. You can also set up automatic saving and backup files and save only selected objects. In

addition, you can also save a drawing in a Drawing Exchange Format (.dxf) file or a drawing template (.dwt) file. If you created
your drawing using a template, saving the drawing does not alter the original template.

To save a drawing:  File > Save Command line>SAVE Using shortcut> CTRL+S
@
Home D CTRL+N Ex
Mew Sheet Set... ="=‘,= o :ﬂ‘; % Ed
u/ £ Open. CRL+0 | (B Z g 5
HN€ & Open Sheet Set... = Prn!_:itl:‘tries gRsiny [
O Clos
Drawil Import...
o Attach...
[El Save CTRL+S
& Savehs. SHIFT+CTRL+S
™ Export...
& eTransmit...
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Remark: When you save a drawing the first time, the program displays the Save Drawing As dialog box so that you can choose a

directory and type a name for the drawing.
oweam— |

G Options
3.3.2. Save Your Drawing Automatically il <<tnnamed Profi>>
| Fie | Display Open and Save | Plot and Pubiish | Use
File Save
You can specify to save drawing files automatically in order to minimize the lost data T
[AutoCAD 2013 Drewing(” dwa) -]

once a problem occurs.

Maintain visual fidelity for annotative obje:
Maintain drawing size compatibility

If you start the automatic save option, your drawing is saved at specified time |Tmbe oo Seioes ]
50 Incremental save percentage
intervals. By default, system assigned the name filename. ~ sv&for temporarily ——
ile ety Precautions
saved files, filename here refers to current drawing name. [¥] Automatic save
S0 Minutes between saves

Create backup copy with each save
[ Fulltime CRC validation
[ Maintain & log file

v File extension for temporary files

Display digital signature information

3.3.3. Save Part of a Drawing File G Wite Beck =)
o

You can use BLOCK command or WBLOCK command to create a new drawing from fsa«:m .

part of an existing drawing. You can select entities or a block definition in your (] Pecpere [ st b

current drawing and save them in a new drawing file. The description also can be .5 E-:Ef;ﬁ

saved in the new drawing. sl -

Fie name and path

=
insed unts: | Millmeter -
[ ok J[ cacel |[ b |

3.3.4. Save to a Different Type of Drawing File @

Savein Drawing and picture - @ T Er
. . Name Date Type Size Tags & | Preview:
Choose the format from Save as Type in the Save B fmsiee | mumm. e
. . . l HZVPLANTA GENER. 2011/3/201 ICAD Draw. 1:191 KB
Drawing As dialog box, you can save a drawing to [ | Emansn. mussn. co0m 0 I
- £13d chancade 2012/9/261... ICAD Draw... 60,820 KB
an earler version of the drawing format (DWG) or | 56 &l Soai: coome 122 =
- aED MODEL SAMPL... 2015/4/141 ICAD Draw. 1413 KB
drawing interchange format (DXF), or save a 120 made DAL, KA D 72D —
EED model_recover 2015/4/141 ICAD Draw. 686 KB
. . ! Lz rendering 2012/4/511... ICAD Draw... 40ke
drawing as a template file. L SNCHOWER. 200701, CADDw., 80K
aED VILLE SAVOYE 2014/4/148... ICAD Draw... 1144 KB
oy aED 2014/7/113 ICAD Draw. 5478 KB
Q_L;' aikrﬂevkaMSR 2007/7/196 ICAD Draw. 5,682 KB
. . &513-POLIDEPORTIVO... 2011/3/201... ICAD Draw. 1734 KB A
To save a different format; .
Save as type: MnCAD 2013 Drawing(" dwg) e Cancel

ﬂ Eig %33"‘5%332 Drveel i
File > Save As Command line> SAVE AS AARD D0 T2008 Do v
. SroCAD DrowmpSicard g S S
Using shortcut> SHIFT+CTRL+S eCAD Dy et )

PutoCAD 2010 DXF(™. ﬂ)d)

AutoCAD 2007(LT2007) DX

AutoCAD 2004(LT2004) DXF\ ﬂ:d)

PutoCAD 2000(LT2000) DXF(".cbd)

AutoCAD R12 DXF(".dd)
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3.35

. DWG Convert

DWGCONVERT command converts one or a bunch of selected drawing files to another dwg version available. The newly
generated file can overwrite the original one, and it can also be compressed into a self-extracting EXE file or a ZIP file to
facilitate batch format conversion of the entire project drawing.

v

L X R195 ‘ 22 ‘ 2 |

3.3.6.

Fles Tree  File Table

=-a Drawings to convert
[¥I4&) 3POLIDEPORTIVO PLANTAS dwa
V1) 43956_estnucturales dwg
] gl 54515_001.dwg
W1 d5) 1244463999 dwg
gl 1344464123 dwg
V1) 1344465690.dwg
W dal Area Table dwg
[/ ARQUITECTURACO| G Convertion Setup
V)41 arutectura defintivo

V] gl Base Support.dwg
/2 Beach House Sample g Current user: win 10

Included 11fie(s). 749 MB
Convertto 2010 fin-placs)

View Repott

Batch conversion between graphical file formats

Converts one or a bunch of selected drawing files

to an older or current dwg version available. The
newly generated file can overwrite the original file,

and it

self-extracting EXE file or a ZIP file to facilitate

can also be compressed into a

batch format conversion of the entire project

drawing.

Steps to Convert DWG files to different format

1. Click “File”>"“DWG Convert” in turn

2. Click “DWG Gonvert” dialog box >“Add File” (Near the bottom)

3. In"Select File” dialog box, you need to browse to the folder where the graphics file is to be converted.

4. Click the graphic file name, and then click “Open”.

5. In "DWG Convert” dialog box, click “Conversion Setups”. In “DWG Convert” dialog box, create a new Conversion Setup
(NEW), modify existing Conversion Setup (MODIFY) or select a previous Conversion Setup, and then click “CLOSE”.

6. In “DWG Convert” dialog box, click “CONVERT”.

7. lfthe Conversion Setups specify an EXE or ZIP file, browse to the desired destination folder, then double-click the file to
select it. If needed, input a new name for the file.

8. Click “SAVE”.
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3.3.7. Use Backup Files

GstarCAD creates a backup file with the current drawing name and a ".bak" extension to save the previous version of the current

drawing when launching "backup automatically" option.

3.3.8. Reduce the Time Required to Save a Drawing File

In order to reduce the time of saving a drawing file, you can specify the
incremental save percentage on the Open and Save tab of Options dialog
box or from the ISAVEPERCENT system variable.

The incremental save updates only the portions of the saved drawing file you
changed. Drawing files will contain a percentage of potentially wasted space
when you use incremental saves. This percentage increases after each
incremental save until it reaches the specified maximum value, and then a
full save is perform.

3.4. Recover a Drawing

3.4.1. Recover a Damaged File

& Options

Curmrent profile: <<|Jnnamed Profilex>

File Save

Save as:

[ AutoCAD 2013 Drawing(” dwg) -]

Mairtain visual fidelity for annotative objes
Maintain drawing size compatibility

[ Thumbnail Preview Settings... ]

50 Incremental save percentage

—_—
: T
& Options

Current profile: <zUnnamed Profile>>

Fi= | Display | Open and Save ] Plot and Publish | Us

File Save

Save as
You can recover some or all of data by reverting to a backup file or using commands to |As0CAD 2013 Dewngt g ’)
. . . . . . . Maintain visual fidelity for annotative objes
find and correct errors if a drawing file is damaged. A drawing file may be damaged by [P Mokt g em gty

a hardware failure, power outage and system crash. You had better create a backup file [ Thumbrai Preview Setings... |

if the drawing is important.

On the Open and Save tab of Options dialog box, you can specify the backup file are
created when you save drawings and set the proper interval time for saving. Then a
backup copy file with a ".bak" extension is created when you save the named drawing

once again. After that, a backup file is always updated while you executing the

command SAVE or SAVEAS.

You can use RECOVER command to check and attempt to open a damage file.
Then uses AUDIT command to find and correct errors.

To open a damaged file:  File > Drawing Utilities> Recover
Command line>RECOVER

O s RS
B swess SHIFTLCTRLLS:

(@ Page Setop Mamagr..
@ Ploter Manager,
@ PlotSyle Manages..

B0 Incremental save percentage

File Safety Precautions
Agtomatic save
50 Minutes between saves
Create backup copy with each save
[ Fulltime CRC validation
[ Maintain a log file

svE File extension for temporary files

Securty Options. .

Display digital signature information

| Iﬁw—l
> M@ £ Dusuing Recovery Manage-.
Date Tags 2l i Update Black lzcan
wngs 27U E ‘ B P
B-UBICACION POL.. 2011737201 1906K8 =7 |
G 201737201 2191 k8 B 1
204/6/510. 2127k e R
st 039K8
onns 45098
0150/271 1375KB Bnd Fle...
msune a3k
S| e AL A T ] toate
o In the dialog box at Files of T h the t f fil tt
e 2 an = -In the dialog box at Files of Type, choose the type of file you want to
G3DVILESAVOYE  2014/4748.. ICAD Draw. 114K
DUAAL.. ICADDmw..  SATEKE
Rl B mome oo e recover.
&3-POUDEPORTIVO... 211/A/201.. ICADDrw..  LT3KB -
Fie qame 30 model - i)
Fies of hpe: Crawng(" awg) - Cancel 25
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-Choose the directory containing the damaged file.
-Choose the damaged file you want to recover and Click the Open button or Double click on the drawing you want to open.

To check errors for a drawing file:  File > Drawing Utilities> Audit Command line> Audit

[ Mew. bud  Applicstion  Help  Express
MNew Sheet Set... g g _g % A AE - f
E Open.. MO | & & O -
£  Open Sheet Set.. - T ey |
£3 Close [ |
Import...
Attach...
B save CTRL+S
Z savess. SHIFT+CTRL+S
™ Export...
& eTransmit...
@ Send..
Cloud 13
[E Page Setup Manager...
@ Plotter Manager.
G Plot Style Manager.
) Plot Preview M 4 + M 4 Model / Layoutl /4 Layout2
& Plot.. CTRL+P m—
2 publish 3 Command: AUDIT
. [Fix any emors detected? [Yes/No] <N=Y
D Utilit M Audit ) )
Drawmg > ”‘E; E R" ! 20165 objects audited
= Drawing Properties... ecover... ) ]
9 7rep Total emors found during audit 0, fieed 0
F:\Drawing and picture\3D MODEL SAMPLE.dwg 44 Drawing Recovery Manager...
F:\Drawing and picture\pelanZ.dwg P—— Command:
F:\Drawing and picture\bulb sample.dwg

1. To choose from the opened drawing, click on File > Drawing Utilities > Audit
2. InputY or N to determine whether to recover the errors that are automatically found by GstarCAD, and then press Enter.

3.4.2. Drawing Recovery Manager

Once terminated by hardware problems, power failure or software problems, the application is capable of backup the opened
drawing file. At the next startup, the program starts "Drawing Recovery Manager" in which all of the auto-backup drawing files
that have been closed accidentally will be displayed. You can open the file of your demand by double clicking at the Backup
File list on the "Drawing Recovery", if there is any damage to the file, system attempts to recover the drawing in process of
backup.

Drawing Recovery Manager x

Skip to automatic save file local

When program or system stopped by accident, the drawing files need to recover are sorted
into the following types. -5 BLOCKS2
i [ BLOCKS 2_1_5938.5v8
B BLOCKS 2.dwg
-Recovered drawing file saved when program fails (DWG)
-Temporary saved file (sv§)
-Backup file (BAK) oo oo e

-Source drawing file (DWG) e e I

Preview: ¥
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3.5. Manage Drawings LAYOUTS SHEET SET MANAGER

SAMPLE SHEET SET
In GstarCAD the Sheet Set Manager allows you to manage the entire project ; E:E:IQ
drawing sheetsets. It can manage all the work flow from sheets creation, 3 SHEETC
4 SHEET D

printing and publishing.etc.

In Sheet Set Manager, a sheet set is an organized collection of sheets from
several drawing files and each sheet in a sheet set is a layout in a drawing
file.

Begin taking advantage of sheet set functionality for your current projects with
minimal effort by importing your current drawing layouts into a sheet set. You can easily open drawings from a central location
while you continue edit them using traditional tools.

3.5.1. Sheet Set Control

Lists menu options to create a new sheet set, open an existing sheet set, or switch between open sheet sets

M first test i@'v lg’;uav T
=

v Mfirst test

Recent C:\Users\asus\Documents\

New SheckSet. Ci\Users\asus\Documents\
C:\Users\asus\Documents\

FAGSTARCAD\PRODUCT LI

Open...
: K1 4 - Section View Overa
.8 Architectural
B Structural

| @&~)ES)

[ Mfirst test

Tree View:Displays the contents of the sheet list.

= M first test

E]@] General

- .| 1 - First Floor Plant Layout

@@] Section View . . . . L .
. 2- Plan View Layout Detfails or Preview:Displays either descriptive information or a

thumbnail preview of the currently selected item in the tree

View.

& Architectural

i Landscape Street Map
@l_] Structural //
&) Electrical .
.. & Mechanical -
& Plumbing Status: Accessible
Sheet: Landscape Street Map
Description:
Views:
[none]

File Name: 6 Landscape Street Map.dwg

Location: C:\Users\asus\Documents\GstarCAD Sheet Sets
File Size: (243,358 bytes)

Last Saved: 2014-10-31 21:43:44

Last Edited By: asus

Sheet Size: 297.0 x 210.0 27
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You can use the following actions in the tree view: S Miirsttest

=80 General |
. ) ) w1 i
e  Right-click to access shortcut menus of the operations that are relevant to the G Sectiny|  OPen

Bl2-pl Open read-only
. K4-se
currently selected item. LD e NewSheet.
L EKl6-La Import Layout as Sheet...
% ;’r‘u’::g Rename & Renumber...
&) Flectrical]  Remove Sheet
% ’;’:e":“i Publish ,
S eTransmit...
Properties...

e Double-click items to open them. This is a convenient method for opening drawing files from the Sheet List. You can also
double-click items in the tree view to expand or collapse them.

Sheet Set Manager

)
a |
& M first test b § |
&) General (@]
K3 1 - First Floor Plant Layout o E |
-8 Section View ‘I n
K7 2- Plan View Layout o g |
&7 4 - Section View Overall 25
-8 Landscape == e (
(16 - Londscape steet i) 2]
&) Architectural © (
&) structural u (
& Electrical
&) Mechanical |
&) Plumbing
|
(
|
|
|
-_—l |
=1«
il =] 27 )J

£ [
I Publish to DWF
&1 1 - First Floor Plant Layout I | | Publishto DWFx
1 &) Section View Publish to PDF
& 2- Plan View Layout | % | Pubishtoptote
&1 4 - Section View Overall | | ot e setp Ot
) ) La |
vl S e Include for Publish
& Avchitectural
R Structural Sl Edit Subset and Sheet Publih Setings..
Publish in Reverse Order
ical R Shes Include Plot Stamp
& Plumbing e Plot Stamp Settings...
e Manage Page Setups...
famows et Sheet Set Publish Options ..
Publish » Publish Dllloa Box ...
eTransmit...

Properties...

e Move the cursor over a single item to display descriptive information or a thumbnail preview of a selected sheet, view, or
drawing file.

e (@)

S M test
Q) Geneal
K01 Fint Foor Pt Layout
= R Section View
K3 2-Plan View Layout
£J 4 - Section View Overal

= e
I 3 6 - Londscape Sueet Map |

R Sructuret
R Bectical
Q) Mechancal
R Pruming Status: Locked for Edit by asus ASUS-PC

Sheet: Lindicape Street Map
Descrpton

Views:
[none]
Fide Name: 6 Landscape Steet

Cumently Open By-avus
Last Saved: 2014.10-31 214344

Sheet Size: 2970 x 2100

Scale 1300

6 Landwcape Street

e  Drag items within the tree view to reorder them.
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3.5.2. Sheet Set Manager Basic Information

Opening Sheet Set Manager
Ribbon: View tab > Palettes > Sheet Set Manager or Type: sheetset

Layout View Manage Export Application Help E»(press
\]_ L L. ]E ]L @ @ @ D . lll @ @ @ 1 | =3 Tile Horizontally ;
| Tile Vertically o
1 L' ]L' 1/_' L' ]L' Named Restore Propemes Xref Tool Sheet Set . DD Toolbars |
)| L hL' World o ereframe® Palettes Mana_ger_‘@ %Cascade l
[~ I odinate  w| visualStyles ||Model Viewports| Palettes I User Interface =
e ——————————— e ettt gttt
| Sheet Set Manager (SHEETSET)
‘ Opens the Sheet Set Manager
Sheet Set Manager X
Creating a Sheet Set e —
|

Once the Sheet Set Manager is open, select the pull down box at the
top and then click on New Sheet Set.

Recent

[ New Sheet Set... ]
Open...

Anew dialog box will pop up displaying the 4 steps in creating a Sheet
Set.

Begin
Under Begin there are two options for creating a sheet set. —
Option one
Is using “An example sheet set” that allows the use of a standard %.eghu
template to create the sheet set. HekSeROetan Createa sheet st sing
. Choose Layouts
Option two ~
Confirm (1 An example sheet set

Is using Existing drawings to start a new sheet set. We are going to
select the Existing Drawings option.
Sheet Set Details

This is where basic information like sheet set name, description, and file location can be added.

Create Sheet Set - Sheet Set Details =)

Begin Name of new sheet set:
¥ Sheet Set Details lew Sheet Set (1)

Choose Layouts

(@ Existing drawings

Description (optional):
Confirm

Store sheet set data file (.dst) here:
C:\Users\asus\Documents\GstarCAD Sheet Sets [B

Note: The sheet set data file should be stored in a location that can be
accessed by all contributors to the sheet set.

Sheet Set Properties

[ <Back ][ mMext> | [ cancel |
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Begin Select folders containing drawings. Layouts in the
drawings can be added to the sheet set.

Choose Layouts

Existing layouts can be added to the Sheet Set Detals : ]
. . Browse... Import Options...
sheet set by browsing for the proper file * Cheoc s [ )
. . Confirm AUTOLIFT 43D-5.5TON i
needed in the drawing set. Once the u‘@a ARM LOCK HANDLE. dwg
. ~-[¥|iK]] Layout3 Arm Lock Handle Assembly
layouts are selected, click Next to K1 Layout1 Handle Shaft =
. K Layout2 Lock Handle Gear
confirm. ARM PIN.dwg
VI Layout1 Arm Pin
-[71E) CARRIAGE.dwg
--[V|]] Layout1 Vertical C Profile
Layout2 Bushing
Layout3 Top Plate
Confirm
Th f i b ” . Begin Sheet Set Preview:
e confirm tab will give a summary ,
Sheet Set Details gNew Sheet Set (1) -
of the layouts to be added to the set. ety - 1 Layout3 Arm Lock Handle Assembly
. 2 Layout1 Handle Shaft
After selecting the Nexf button the new » Confirm N m———
layout will be added to the sheet set. dLayoutt Anm
5 Layout1 Vertical C Profile
E‘GLayoutZBushing
7 Layout3 Top Plate
@ 8 Layout10 Chain Block Support
Import layouts to the Sheet Set Manager
To add a new sheet from an existing drawing layout, right click the title of the sheet (foesensan ) @E)Es)
. . fses B
setand select /mport Layout as Sheet. A new pop up box will appear which allows you S pewshetsarty | S
© g . 89| 2 - Layoutl HangleShz
to browse for an existing drawing to add a layout. £13-Loyouzlod  Open
& 4 - Layoutl Armj Open read-only
5 - Layoutl Vert et
G Sl
Select drawing fles containing layouts: -& 8 - Layout10 Ch
K1 9 - Layout6 Ch Rename & Renumber...
K] 10-Layoutls i Remove Sheet
P ese oy o e epet i " - % E . t:z:x 2: Publish ,
—— s - K7 13- Layoutt3 L eTransmit...
e Dot

Tip: If the import box is not checked, the layout is already in the sheet set or the
layout is unable to be imported into the set.

4 n ] '

] prefix sheet titles with fil name
Import Checked Cancel Help
=
:

. = ]
Managing Sheet Set = New Sheet Set (1) -

£J 1 - Layout3 Arm Lock Handle Asseml|

Moving and Removing Sheets from a set e s
3 - Layout2 Lock Hagglle Ceay
- Layor rm Pin Open
Once the sheets have been added to the Sheet Set Manger, they can be B ﬁ.taioﬁCem;, .
dragged and dropped to the order needed. To remove a sheet from the e s i
. . K] 8 - Layoutl0 Chain E Import Layout as Sheet...
set, right click and select Remove Sheet. 9 Layoutls Crann Bl o
& 10 - Layoutl5 Small

0 11 - Layouts Bearing

& 12 - Layout8 Short G

i »
E 13- Layouti3 Lock | [anieh
-] 14 - Layout5 Bearing eTransmit...
K 15 - Layout7 Bearing T
K] 16 - Layout11 Squars

T
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Rename and Renumbering Sheets

To rename and renumber a sheet or a subset, right click on the
sheet needed to be changed and select Rename & Renumber.

A pop up box will show up that will allow the number, sheet title

and layout name to be changed.

Number: Sheet title:
3 Layout2 Lock Handle Gear

Rename options

Sheet title

Rename layout to match:

["]Prefix with sheet number

Layout name: Layout2 Lock Handle Gear

File name:  ARM LOCK HANDLE.dwg

Folder path:  F:\GSTARCAD\PRODUCT LINE\PLATFORM\GSTARCAD 15\all about sheet set

Rename drawing file to match:
[7] sheet titie

[l prefix with sheet number

[ <previous | [ mext> | [ ok ][ cace | [ hep ]
Adding project information to a sheet set
ot i ; ; Sheetsecbroperies :
To add project information to the sheet set, like E——
, , . Name New Shee et
project name, project number, and project gk Al G CAD ..
description, right click on the sheet set title and e
, LEdl-la Close Sheet Set E‘:‘g‘:‘::":’::emmﬁe
scroll down to the sheet set Properties. A new pop . b e
i i H lew set... Prqedm"hs
up box will display that allows the update of project o | RS
i i = :_ t: Resave All Sheets foiodt nicacne
information. 5| & Sheet Creation
£ 8-La Publish Sheet storage location C:\Users\asus\Documents\GstarCAD Sh...
. . . . . 9- La creation template
Tips: Project information in the sheet set can be Hiolt o e %
-1 Transmittal Setups...
used in object such as fields

Creating Subsets in Sheet Set Manager

Creating subsets in Sheet Set Manager is a fast way to organize and find what is
needed in a big drawing set. To create a subset, right click on the sheet set

and then to New Subset.

The Subset Properties box will pop up.
Most of the properties are basic.

Select OK.

A new subset is added to the sheet set
manager.

Tip: To move a sheet to the new subset,
simply click and drag to the desired
subset.

Subset Name

Create Folder Hierarchy
Publish Sheets in Subset
New Sheet Location
Sheet Creation Template
Prompt for Template

(_EditcustomProperties.. | [ ok | [ concel | [ Hep |

s =i
[N New Sheet Set (1) -

&1 1 - Layout3 Arm Lock H Close Sheet Set
K& 2 - Layoutl Handle Shaft
&1 3 - Layout2 Lock Handle WerEizzs.
-&J 4 - Layoutl Arm Pin
K] 5 - Layoutl Vertical C Pr Import Layout as Sheet...

| 6 - Layout2 Bushing
-§J] 7 - Layout3 Top Plate
-] 8 - Layoutl0 Chain Blocl
-] 9 - Layoutl6 Channel An
-] 10 - Layout15 Small C Pr
-] 11 - Layout6 Bearing Su
-] 12 - Layout8 Short Chan
- 13 - Layoutl3 Lock Hand

Resave All Sheets

Publish
eTransmit...

Transmittal Setups...

Properties...

New Subset (1)

No

Publish by Sheet ‘Include for Publish’ Sett...
C:\Users\ovs\Documents\GstarCAD She...
Arch D{C:\Users\ovs\AppData‘\lLocal\Gs...
No

&1l 14 - Lavout5 Bearina Support Assemt | =i =
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Publishing Sheet Sets

Sheet Set Manager makes it simple to publish a full set or only select sheets of the construction documents. There are two
ways to plot: Publish directly to the plotter/file or use the Publish dialog box.

Publish and Plot directly to the plotter/file

Right click on the sheet set, scroll to Publish, and then Publish to Plofter.

This method is used to plot and publish when the page setup is set per layout. The drawback to using this optio
n is if someone plots one of the sheets using the plot command and saved the setup to the layout, the layout w
il not publish properly. Sheetset can also be packaged and shared through e-transmit.

Sheet Set Manager

] U O Y 1

I

& New Sheet Set (1)

>

Publish to DWF
Publish to DWFx
Publish to PDF
Publish to Plotter

i 1- Layout3 Arm Lock Handle Assem| Publish using Page Setup Override

-] 2 - Layoutl Handle Shaft

-& Inclidefor Piiblish »
- 4 Open

El 5 Open read-only Edit Subset and Sheet Publish Settings...
~K 6 Publish in Reverse Order

-KJ 7 phes Include Plot Stamp

% ; Import Layout as Sheet... Plot Stamp Settings...

-7 10 Rename & Renumber... Manage Dage Setupal

% i; fiemioye shest Sheet Set Publish Options ...

E] 13 » Publish Dialog Box ...

- 14 eTransmit...

% :2 Properties...

i 17 - Layoutl4 Small Plate Hole

Publishing using Publish dialog box may not be as fast as Publishing directly to the plotter/file, but there is less

of a chance the document will come out wrong.

You are also able to use Page Setups saved in the
drawing to particular sheets or the full set.

To pull up the dialog box, right click the Sheet Set
title, scroll to Publish, and then to Publish Dialog

Box. The Publish Dialog Box will display.

Now with page setups, Publish Dialog Box can chan
ge the way the document is published. Now we hav
e the options to publish to Plotter named in Page
Setup, DWF, DWFx, and PDF.

Selecting the Sheet Set Publish Options allows the
options to change information like default output location
and naming.

o Do (=  PubishOptons komation
[tene g BB | isor crtmmema i
Publishto File Type: Muti sheet fie
u Naming: Specfy name
e Leyerirfomation: Dont nciude
DWEx Merge Cortrol: Line overwrie
e =
e O @ e S P ..
| Shest Name 30 DWF Page Setup Satus =
| i3 1 Layout3 Am Lock Hande Assemby & Defaut None> o Noerors E|
&) 2 Layout1 Handie Shaft ') <Default None> o No emors i
| 3 tavout2 Lock Honde Gear & <Defat None> - BT
| &l 4 Layout1 Am Pin =} <Detaut None> + Noemors
K 5 Layout Verical C Profle =3 <Defaut None> o Noemors
K 6 Layout2 Bushing 5 <Defauk None>  Noerors
K 7 Layout3 Top Plate & <Defauk None>  Noemors
K 8 Layout 10 Chain Block Suppot & <Defauk None> + Noemors
K 9 Layout16 Channel Angle Cut &% <Defauk None>  Noemors.
K 10 Layout 15 Small C Profile Y <Defauk None> + Noemors
Kl 11 Layout§ Bearing Suppodt Plate 1 =Y <Defau None> V Noemors
LK 12 Lavout8 Shod Channel 1 23 Defaut None> o7 No emors g
Publsh Output.
‘Selected Sheet Details. -
Source drawin..| ARM LOCK HANDLE dwg
Number of copies: Include plot st:
Drawing locat .| F\GSTARCAD\PRODUCT LINE\PLATF = fa s
Layout Name | Layout2 Lock Handle Gear T E o
Piot device _|Overde: DWFx ePiot (PS Compatble) HiREe: b bedommd +
Plotsze |21000x 296 50 Mimeters (andacape)  ©CHen =
o s []Openin viewer when done
Page setup de..| Ovemde the output device spechied by &
[ HeDews [Crwwn ][ camd | [ ew
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S5 ite Hor
[0 vite vert
B cascade

Publish Options Information
Location: C:\Users\asus\Documents\
File Type: Muttisheet fie

Q} Cument sheet set: New Sheet Set (1)

Default output location (plot to file) -]
|Location [C:\Users\asus\Documents\

Common DWF/PDF options -]
Tyoe Mutisheet file

Naming name

Name New Sheet Set (1)

|Layer informat...| Dont include

| Incomorate C...|Line overwrte

30 DWF options =]
Group by Xref._ | N/A

(o ] [come] [ e |

Tip: One of the major options | change the most is type. Multi-sheet file will place the full set in one file and the Single-sheet

file will place each sheet per file.
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4, Control the Drawing Views

4.1. Redraw and Regenerate a Drawing

As you work on a drawing, visual elements may remain after the completion of a command. You can remove these elements by

refreshing, or redrawing, the display.

To redraw (refresh) the current window display:  View > Redraw

To regenerate the current window: View > Regen

Insert Format Tools Draw

Manage
Regen
F Regen Al

Zoom

Pan

Orbit

Viewports
Named Views.
3D Views

% () Hide
% Visual Styles
\ Render

Display
&= Toolbars...
o~

Command line> REGEN

Modify Window Help Express

Command line> REDRAW

51 Model Layoutl | LayoutZ

Information about drawing entities is stored in a database as floating point values, ensuring a high level of precision.
Sometimes a drawing must be recalculated, or regenerated, from the floating point database to convert those values to the

appropriate screen coordinates.

4.2. Magnify a View (Zoom)

You can use ZOOM command to zoom in or zoom out the
drawing view to meet your need. You can change the
magnification of your drawing at any time. The cursor
changes to a magnifying glass when a zoom tool is active.
Zoom out to reduce the magnification so you can see more
of the drawing, or zoom in to increase the magnification so
you can see a portion of the drawing in greater detail.

@ Redraw
Regen
% RegenAll

Zoom
Pan

Orbit
Viewports

[& MNamed Views...

3D Views

@ Hide
Visual Styles
Render
Display

= Toolbars..

ViUl Insert Format Tools

wut

Draw Dimension Modify Window Help Express

View

2P 0L PRAROLES P

Realtime

Previous
Window
Dynamic
Scale
Center
Object
In

Out

All
Extents

Help Express

J.dwg < BEARING DRAWING.dwg LAYOUTBYPATH SAMPLEdwg <

rhgs/

BT

Remark: If you are working in a layout viewport and cannot zoom, the layout viewport may be locked. The scale and view do not

change in model space while panning or zooming in a locked layout viewport.
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4.2.1. Zooming Methods

To zoom, you can use any of the following methods:

-To define the portion of the drawing to zoom, create a window.
-To zoom in real time, use the Zoom Realtime tool on the Standard toolbar.
-If you have a mouse with a wheel, rotate the wheel to zoom in and out.

4.2.2. Zoom to Magnify a Specified Rectangular Area

You can specify a rectangular area defined by two corners to display the objects within that area as large as possibly. The
lower-left corner of the specified area becomes the lower-left corner of the new view.

To zoom in to an area using a window:  View > Zoom> Window Command line> Z0OM
-Choose View > Zoom > Window

-Select one corner of the window around the area you want to magnify.
-Specify the opposite corner of the window around the area you want to magnify.

00 Inset Format Tools Draw Dimension Modify Window Help Express File Edit View Insert Format 1ools Draw
@ Redraw sut View Manage Export Help
Regen DRAWING. dwg

% Regen All

Home  Insert Annotation 30 Layout

r
Zoom » | @), Realtime I
Pan "4 Previous I
Orbit 3 @ Window I
Viewports » | @ Dynamic
& Named Views... @ Scale 1
3D Views @ Center 1
" @, Object
(7 Hide 1
Visual Styles @
Render & 1
Display @, 1
= Toolbars.. ® 1
I
I
|

Modify Window Help Express

4.2.3. Zoom in Real Time R ——
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Realtime option zooms dynamically by moving your pointing device up or = /
H H H H 1 H & Named Views... S Scale
down. By right-clicking, you can display a shortcut menu with additional s , %
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To zoom in real time:  View > Zoom>Realtime T j‘
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3D Orbit

Command line> RTZOOM

Zoom Window

Zoom Original

Zoom Extents

-Choose View > Zoom > Realtime from the main menu. NN
-Hold the left mouse button, then drag the cursor forward to zoom in and move back to zoom out.
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Chapter 4 Control the Drawing Views

4.2 4. Displaying the Previous View of a Drawing

After you zoom in or pan to view a portion of your drawing in greater detail, you may want to zoom back out to see the entire
drawing. On the View > Zoom menu, the Previous tool lets you restore the previous view. Selecting this tool repeatedly steps
back through up to 25 successive zoomed or panned views.

4.2.5. Zooming to a Specific Scale

You can increase or decrease the magnification of your view by a precise scale factor measured relative to the overall size of
the drawing or in relation to the current display. When you change the magnification factor, the portion of the drawing located at
the center of the current viewport remains centered on the screen.

To zoom to a specific scale relative to the current display: View > Zoom>Scale Command line> ZOOM

-Choose View > Zoom > Scale from the main menu.

-0n the Zoom toolbar, click the Zoom Scale.

-Type ZOOM in the command line, choose the Scale option, and then press Enter.
-Type the scale factor, followed by an x (such as 2x).

-Press Enter.

File Edit View Insert Format Tools Draw Dimension Modify Window Help Express

view P

& Redraw
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5 Regen Al

Zoom
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Insert  Annotation 3D layout  View  Manage  Export  Help  Express
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DRAWING, dwg
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Pan

Orbit
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Window
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Scale

Viewports
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3D Views »

(7] Hide

Visual Styles »
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Object
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All
Extents

Display »
= Toolbars..

BB OO PRPRLOLE D

4 4 b » Model / Layoutl / Layout?

P P
first point as displacement>-
mmand: ZOOM

pecify comer of window, enter a scale factor (1X or nXP), or
[A1/Center/Dynamic/Extents/Previous/Scale/Window/Object] <veal time>: SCALE
Erter 2 scale factor (X or nXF). 3

4.2.6. Displaying the Entire Drawing

Z00M Extents option, displays a view that includes all of the objects in the drawing as large as possible. The view can display
the objects on layers that are turned off but do not include objects on frozen layers.

700M All option, displays all of objects within either the user-defined limits or the drawing extents, whichever view is larger.

You can use the Zoom All tool on the zoom toolbar to display an entire drawing. The Zoom Extents tool on the zoom toolbar
displays the drawing to its extents, making the image fill the display to the greatest possible magnification.
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4.3. Pan and View

You can move the drawing in any direction using the pan command. Panning shifts or slides the view of the drawing
horizontally, vertically, or diagonally. The magnification of the drawing remains the same, as does its orientation in space. The
only change is the portion of the drawing displayed. To pan, you can use any of the following methods:

-For precise panning, specify two points defining the magnitude and direction of the pan. The first point indicates the starting
point of the pan. The second point indicates the amount of pan displacement relative to the first point.-To pan in real time, use
the Pan Realtime tool on the Standard toolbar.

-If you have a mouse with a wheel, press and hold the wheel, and then move the mouse.

To pan in real time: ~ View > Pan>Realtime Command line>PAN I insert Format Jools Draw Dimension Modily Window Help Expr
@ Redraw m Manage Export Help
Regen
-Choose View > Zoom > Realtime from the main menu. T RegenAl
. . . Zoom v b aadTe
-Move the cursor in the direction you want to pan. Pan 5|, |

Orbit 3 Point

-To stop panning, press Enter, ESC or choose Exit from the shortcut menu.

Left
Right
Up

Down

Viewports 3
[& Mamed Views...

3D Views 3
7 Hide

Visual Styles 3

Render 3

To pan using a mouse with a wheel:

-Press and hold the wheel, and then move the mouse in the direction you
want to pan (The MBUTTONPAN system variable controls this feature.)

Display 3
G- Toolbars..

4.4, Display Multiple Views on Model Space

When you begin a new drawing, it is displayed in a single window. You can view the drawing in a second window, or you can
divide one window into multiple windows. You can also open and display multiple drawings.

4.4.1. Set Model Space Viewports

The viewports created on the Model tab completely fill the drawing area and do not overlap. As you make changes in one
viewport, the others are updated simultaneously. You can do the following operations at the model space viewport:

-Set Snap, Grid, and UCS icon modes; Pan; Zoom; and restore named views.

[P insert Format Jools Draw Dimension Modiy Window Help Express

-Save orientations of UCS with individual T

Regen AWING.dwg

viewports. Fh Regen
-When executing a command, you can draw Zoorn

3
Pan >
Orbit 3

>

ut View Manage Export  Help Express
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from one viewport to another. _
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-Name a viewport arrangement in order to you pomedliews B Newviewpors.
1 Viewport
can reuse it on the Model tab or insert it on a O e 2eupo
isual Styles > iewports
|ay0ut tab. Render v ewpors
) Display , | 2] Polygonal Viewport
-When you work on 3D models, is helpful £ Toolas. E Objec
Join

setting up different UCS in individual viewports.
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Chapter 4 Control the Drawing Views

4.4.2 Working with Multiple Views of a Single Drawing

You can open and work with several views of the same drawing simultaneously. After you divide a single window into multiple
windows, you can control each window separately. For example, you can zoom or pan in one window without affecting the
display in any of the other windows. As you draw, any changes you make in one window are immediately visible in the others.

And also you can switch from one window to another at any time.
To create multiple views: View > Viewports Command line> VPORTS

-Choose View> Viewports-In viewports menu, choose 1, 2, 3, or 4 viewports.

-Type h if you want the horizontal orientation, or type v if you want the vertical orientation.

To join two views:  View > Viewports> Join Command line> VPORTS

-Choose View > Viewports > Join -Click anywhere inside the window you want to keep.

-Click anywhere inside the adjacent window you want to join to the first window.
To restore a named window configuration:

-Type -VPORTS system variable at the command line and press ENTER.
-Then type Restore.
-Then type the name of the window configuration you want to restore.
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4.4.3. Working with Multiple Drawings

With the multiple document interface, you can open and work on several drawings at one time, you can copy, cut, or paste an
entity from one drawing to another. Each drawing appears in a drawing window, which has the following advantages: You can
see two or more drawings side by side, and you can easily copy entities from one drawing to another. Under the Window menu,
the following three methods that determine how drawings are arranged are provided for user's choice.
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4.5. Specify a 3D View

Apply Help

You can set a 3D view to facilitate verifying the 3D effects of the

drawing, constructing and visualizing 3D models. You can specify a new viewpoint to create new objects or modify the existing

objects.
4.5.1. Set the Viewing Direction

You view three dimensional drawings by setting the viewing direction. The viewing
direction establishes the viewing position, When you view a drawing from the
default viewpoint (0,0,1), you see a plan view of the drawing. You can change the
viewing direction to look at the drawing from a different vantage point or to work
on a three dimensional model from a different orientation.

-
G Viewpoint Presets

=)

Set Viewing Angles
(@ Absolute to WCS

270.0

() Relative to UCS

From:
XY Plane:

90.0

[ Set to Plan View ]

Lo |

Cancel ] [
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Chapter 4 Control the Drawing Views

To set a new viewing direction: ~ View >3D Views> Viewpoint Presets Command ling> DDVPOINT

-Choose View > 3D Views > Viewpoint Presets
-Set viewing angles at absolute to WCS and relative to UCS by moving the position of the needle according to your preference.
Then click OK button.

To display a plan view of the current drawing: View > 3D Views> Plan View Command linge> PLAN

-Choose View > 3D Views > Plan View from the main menu.
-It concludes three plan views: Current UCS, World UCS and Named UCS. Choose one what you want.
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4.5.2. Isometric View

Insert Format Tools Draw Dimension Modify Window Help

You can define perspective views of a S Y (T e, (T ey e

model to create realistic effects. Select ® igm"" ,

predefined standard orthographic and ot ,

isometric views by name or description. e rereeee.
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options: Top, Bottom, Front, Left, Right, e g -

and Back. In addition, you can setviews o= |5, I

from isometric options: SW (southwest) = L _
Isometric, SE (southeast) Isometric, NE o e ‘ “’
(northeast) Isometric, and NW (northwest) o w J
Isometric. x

4.5.3. Draw 2D Isometric Views

With Isometric Snap, you can create 2D objects that appear to be 3D solids.

By setting Isometric Snap on the Draft Settings dialog box and turning on Snap and Grid, you can easily align objects along one
of three isometric planes. However, although the isometric drawing looks like 3D, it is actually a 2D representation.
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4.5.4. Set Isometric Grid and Snap

By aligning along three major axes, isometric drawing simulates a 3D drawing from specified viewpoint. When the snap angle
is set to 0, the axes of the isometric plane are 30 degrees, 90 degrees and 150 degrees. With Isometric Snap on, you can work
on any of three isometric planes, each with a pair of associated axes.

-Left. The left isometric plane defined by a pair of 90- and 150-degrees axes. The snap and grips align along the 90- and
150-degree axes.

-Top. The top isometric plane defined by a pair of 30- and 150-degrees axes. The snap and grips align along the 30- and
150-degrees axes.

-Right. The right isometric plane defined by a pair of 90- and 30-degrees axes. The snap and grips align along the 90- and
30-degrees axes.

(G Drafting Settings &J
Snap and GRid | Polar Tracking I Object Snap I Dynamic Input I Magnifier I Symmetr| 4 | * 90 o
[] Snap ©n (FS) || Grid On {F7)
Snap spacing Grid style To p
o Display dotted grid in:
SIED TR 10 [7]2D model space
Snap Y spacing: 10 [ Block editor
[] Sheet Aayout
Equal X and Y spacing
Grid spacing
Snap type Grid X spacing: 1o
@ Grid snap Grid Y spacing: 0
@ Rectangular snap Major line every: 5 =
() Isometric snap e . Left
[¥] Adaptive grid ng h t
[] Allow subdivision below grid
spacing 30 o 1 5 0 o
Display grid beyond Limits
[ Follow Dynamic UCS
Felo

In addition to using ISOPLANE command to switch isometric planes, you can also use shortcut key F5 or CTRL+E. specifying
one of the three isometric planes results in Ortho and crosshairs to be aligned along the corresponding isometric axes.

For example, when Ortho is on, the points you specified align along the simulated plane you are working on. Therefore, you can
draw the top plane first, and switch to the left plane to draw another side, and then switch to the right plane to complete the

drawing.
L Ortho Mode(F8)

T N

Top plane

Left plane Right plane
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4.5.5. Change a 3D View Dynamically

You can view objects from any viewing direction by holding down mouse or other pointing devices and moving dynamically.
With dynamic viewing, you can display the effects of changing viewpoint while you change the view. You can execute move or
zoom operations as the 3D Orbit is active. When the 3D Orbit is active, you are not allowed to modify objects. GstarCAD
supports more orbit options like Free Orbit, 3D Continuous Orbit, Orbit along the X-axis, Orbit along the Y-axis, Orbit along
Z-orbit and 3D Orbit Center. Additionally users can create two new meshes through DISH and DOME commands. To close 3D
Orbit, press Enter, ESC or choose Exit from the shortcut menu.
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4.5.6. Hide Lines or Shade 3D Objects

Hides or shapes for 3D objects in the current drawing, suppresses the display of the objects (partly or entirely) that are located
behind other objects, or generates a simply shaded image displayed in the current view. You can use HIDE command to
remove the hidden lines to verify the current placement of these surfaces. Hiding background lines makes the display much
clearer, but you cannot modify hidden-line or render views.
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4.5.7. Add Simple Shading to 3D Objects

Although hiding lines can enhance the drawing and clarifies the design, shading produces a more realistic image of your model.
You can modify shaded objects as you normally would. When a shaded object is selected, the wireframe and grips appear on
top of the shading.
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4.5.8. Section Plane

SECTIONPLANE command creates a section object that acts as a cutting plane through 3D objects and saves the selected section plane as a
2D or 3D block. You can move the section object dynamically in a 3D model or in a surface area. You can use the active section to analysis
model by moving the section object in the object. Create cross-sectional views that can be saved or reused.
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4.6. Render

Rendering creates a 2D image based on a 3D scene. It
shades the scene's geometry using the lighting you've set
up, the materials you've applied, and environmental
settings such as background and fog.At a basic level, you
can use the render command to render your model
without applying any materials, adding any lights, or
setting up a scene. You cannot move or adjust this light.

— o
Render Environment ===

Fog / Depth Cue
Enatie Fog (00 -

4.6.1. Render Environment

You can use environmental features to set up atmospheric effects or background
images. You can enhance a rendered image by means of atmospheric effects like fog

and depth cueing or by adding a bitmap image as a background. Fog and depth ez

Far Fog Percentage 100
cueing are actually two extremes of the same effect: a white color is fog, and a black S vt s
color is traditional depth cueing. You can use any color in between. Cd  Cow
46.2. Light

Lighting adds the finishing touch to the scene. You can add point lights, spotlights, and distant lights and set the location and
photometric properties of each.

Point Light: A point light radiates light in all directions from I P
its location and does not target an object. ‘ :
Spotlights: A spotlight can be directed towards an object.

fniet Farmat Jooh [Qrew Dimepiion Modfy Vindow Help Epress
oW Manege  Tapodt  Help  Expre

B39 @ &« 6l
ol

I T

we Ut S Named Views.

Distant Lights: Simulates the effect of sunlight and can be ' ke
used to show how the shadows cast by a structure affect the e
surrounding area. € e S i

1 Light List

Light List: Displays a list of type and light name used in
model. Distant lights and the sun do not appear as interface
objects in the model.

4" DrawingLawg X

4.6.3. Materials

RRS)

You can add materials to objects in your drawings to provide a realistic effect. In- | - —
H H H . . Diffuse: I

the context of rendering, materials describe how an object reflects or transmits e ﬁJ

i i ; ; i Refraction indexq — 11—
light. Within a material, maps can simulate textures, bump effects, reflections, —T——

or refractions. SeHitumination: [F———

[ Diffuse map
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5. Precision Tools and the Properties of Drawings

5.1. Specify Units, Angles and Scale

Specify the units of measurement you want to use, their format, and other conventions.

5.1.1. Set the Units Format

You can set the display format of the unit that includes: scientific,
decimal, engineering, architectural and fractional notation. To enter
architectural feet and inches format, you can indicate feet using the
prime symbol ('), for example, 72'3. You do not need to specify inches
by entering quotation marks (").You can set the unit type and precision
in the Quick Setup wizard, the Advanced Setup wizard, or the Units
Control dialog box. These settings control how your coordinate, offset,
and distance entries are interpreted, and how coordinates and distances
are displayed.

To open drawing units dialog: ~ Format > Units Command

line>UNITS

5.1.2. Set Angle Conventions

You can specify the location for angle 0 and the positive direction for the
angle measurement: clockwise or counterclockwise. You can also
specify the format and the number of decimal fraction.

-Specify the measurement unit and precision: The units include grad,
radian, surveyor's unit and degree, minute and second.

-Specify where the angle measurement starts from: east, west, south,
north or others. For example, to enter a coordinate relative to the current
coordinate for a property line that is 54 feet, 7 inches long with a bearing
of 60 degrees north, 12 minutes, 6 seconds east, enter
@54'7"<n60d12'6"e.

rG Drawing Units @1
Length Angle
Type:
'] [Decimal Degrees v]
Precision: Precision:
0.0000 -] o -
[T Clockwise
Insertion scale
Units to scale inserted content:
Sample Output
1.5,2.0039, 0
3«45, 0
Lighting
Units for specifying the intensity of lighting:
[ oK ][ Cancel |[ Diection.. | [ Hep
i |
{7 Direction Control ﬁ
Base Angle
(@) East 0
) North 90
) Wast 180
il © South 270
() Other Pick / Type
|
i E& :
[ ok || cancel

-Specify the positive direction: counterclockwise or clockwise. The angle 0 can be set to any location.
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5.1.3. Setting Scale Factors

Instead of drawing to a particular scale, you draw everything full size in the
program. When you print your drawing, you can assign the scale at which

the drawing is to print. Scale, however, does affect the way a few elements
such as text, arrows, or lingtypes print in your drawing. For example, when
you draw text, you need to determine the text size so that when you print it
|ater at a particular scale, the text height is correct.

After you determine the eventual scale of your finished drawing, you can
calculate the scale factor for the drawing as a ratio of one drawing unit to
the actual scale unit represented by each drawing unit.

The following table shows some standard architectural and engineering
scale ratios and equivalent text heights required to create text that measures
1/8 inch high when you print the drawing at the specified scale.

You can use these scale factors to predetermine the size of your drawing to
make sure that it fits on a specific size paper when you print it. You control
the size of your drawing by the drawing limits. To calculate the drawing
limits to match the size of your paper, multiply the dimensions of your
paper size by your scale factor.

5.2. Drawing Limits

Standard scale ratios and equivalent text heights

Scale

116" = 1-0"
1/8" = 1'-0"
3/16" = 10"
14" = 10"
3/8" = 1-0"
1/2" = 10"
3/4" = 1-0"
1"=1-0"
11/2' = 10"
3" =1-0"

1" =10

1" =20

1" =30

1" = 40

1" = 50
1= 60

1" =100

Scale factor
192
96
64
48
32
24

120
240
360
480
600
720
1200

Text height
24"
12"
g
6
4

You can specify the drawing limits that form an invisible boundary around your drawing. You can use the drawing limits to make
sure that you do not create a drawing larger than can fit on a specific sheet of paper when printed at a specific scale.

For example, if you plan to print your drawing at 1/8" = 1'-0" (in other words, using a scale factor of 96) on a sheet of paper
measuring 36 inches x 24 inches, you can set drawing limits to 3,264 units wide (that is, 34 x 96) and 2,112 units high (22 x

96), which allows a 1-inch margin around the edges of the
printed image.

& Layer.
i Layer States Manager...

Layer tools

@ Color..
Linetype...
Lineweight...

Jg  Scalelist..

To set the drawing limits;
Command line> LIMITS

Format > Drawing limits

& TetStyle..

&, Dimension Style.

Plot Style.

-Choose Format > Drawing Limits S

-Specify the x-coordinate and y-coordinate of the upper right e

drawing limit and the lower left drawing limit. You can also click
D Rename..

Select to specify the drawing limits by selecting points in the
drawing.

005 Tools Draw Dimension Modify Window

Help

lage  Export  Help

4 by Model

Layoutl / Layout2

S [ommand: LI

1 [eset Model space limits
pecity lower left comer or [ON/OFFJ<0.0000,0 000> 34
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5.8. Grid and Grid Snap

The grid is a rectangular pattern comprised of minor
and major lines extended over the drawing area.
Displaying grids and using grids snap improve the i
performance of regenerating. When you turn Snap
mode on, the cursor adheres or snaps to the invisible
grids. Grid and snap settings are effective tools to use
in your drawing to ensure accuracy. In addition, the
cursor can be restricted to move orthogonally only or
guides can display on the screen automatically at

specified polar angle increments.

5.3.1. Change Grid and Snap Spacing

You can turn Grid and Snap on and off and specify their spacing on the Snap
and Grid tab at the Drafting Settings dialog box. Grid spacing does not have to
match snap spacing. A wide grid spacing can be used as a reference while a

Undo]

Undol

SNAP.

Er oo wooes

closer grid spacing helps you specify points accurately.

v

L.

Model  Layoutl / Layout2

x
n

Command: RECOVER
Command: UNITS

On
Off

Settings..

Command :

v | Uselcon

5.4. Use Object Snaps

Object snaps enable you to quickly select exact geometric points on existing
entities without having to know the exact coordinates of those points. With object
snaps, you can select the endpoint of a line or arc, the center point of a circle, the
intersection of any two entities, or any other geometrically significant position. You
can also use object snaps to draw entities that are tangent or perpendicular to an

existing entity.

5.4.1. Setting Object Snaps

You can set object snaps using any of the following methods:

-Choose Tools > Drafting Settings > Object Snap, and then click one of the

object snap tools.

G Drafting Settings [omzim]
Snap and GRid | Polar Tracking | Object Snap | Dynamic Input | Magrifier | Symmeti| + | *
Snap On (F9) Grid On (F7)

Snap spacing Gid style
Display dotted grd in
10
Sl [E1 2 model space
Snap Y spacing: 10 [ Block editor
[] SheetAayout
Equal X and Y spacing
Gnd spacing
Snaptype Giid X spacing 10
@ Gidsnap Gnd Y spacing 10
(® Rectangular snap Majorline every: 5
) lsometric snap Grid behavior
[¥] Adaptive grid
[ Allow subdivision below arid
spacing
Display grid beyond Limés
] Follow Dynamic UCS
ek ][ Cancel | [ Hep

[Encpoint]
[peciyneponkor |[TEEE |£27]

-G RNCCI TN  Ostiap | otrack RGO DY

‘G Drafting Settings =
Snap and GRid | Polar Tracking | Obiect Snap | Dynamic input | Magrifer | Symmetr < [»
Object Snap On (F3) [] Object Snap Tracking On (F11)
Obiect Sniap modes
O [ Endpoint & [ nsetion
2 [ Midecint b [ Pemendicular
&[] Center T [ Tangent
& [CINode X [ Nearest
& [lQuadrrt (7] Apparert ntersection
X [ intersection o [] Distance from Endpoint 100
[ Extension % [IDivide  Segments 3

oint whie in 3
ove the cursor. To
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-On the Object Snap toolbar, click one of the object snap tools.

-On the status bar, right-click on the Object Snap button to choose Settings.

-Press and hold down the Shift key while right clicking anywhere within the drawing window to display the object snap shortcut
menu, and then choose the object snap you want to set.

Additionally, you can find an option called Distance from Endpoint. This option allows snap a certain distance from any
endpoint of objects like line, arc, spline, pline, ellipse arc, mline and any other lines. As long as you pass the cursor over an
object from its endpoints, you will see a green snap point at accurate distance.

P40
. N NN \ (02} 5
e ® NNAAY =
I / SNRRHRA
ANRNY I/ |
U sy /// T !
o 50mm distance from endpoint \\\\ AAS !
D Ip EEERNN P4V e, |
s al \Y /1
a NA A |

Another option called Divide Segments allows snap the divided segment points of objects like line, arc, spline, pline, ellipse
arc, mline and any other lines. Before, if you want to find the divide point, first you need to generate the divided points object,
then snap those points to draw. Now as long as you pass the cursor over an object mentioned above, you will see a green snap
point at accurate distance.

Eeceess

=]

G Options
Current profile:
| Fie | Display | Open and Save | Plot and Pubish | User

AifoSnap Seftings

5.4.2. AutoSnap Tools

<<Unnamed Profiles> &) Curent drawing: Drawing1 dwg

—
| Bra | Setection set | Profiies | Cloud storal + [ »

The automatic snap tool is a visual aid tool for snapping that help
you see and use object snaps more efficiently. When any object

Marker
Magnet
Display AutoSnap tooltip

["] Display AutoSnap aperture box

AutoTrack Settings

Display polar tracking vector
Display full-screen tracking vector
Display Auto Track toolip

Alignmert Point Acquisition

snap is on, the system displays a marker and a tooltip when you S
MOVe your Cursor on over a snap point. AutoSnap turns on e arersee frenresae
automatically when an object snap is on. By default, AutoSnap = U ﬁ} d

marker, tooltip and magnet are on. You can change the settings of
AutoSnap on the Options dialog box. AutoSnap consists of the
following snap tools:

-Marker. The object snap location is displayed when the cursor

Object Snap Cptions

lgnors hatch objsats
] Beplace Z value with curent elevation

oKk |[ Cancel Help

moves over or near an object. Marker shape is determined by the snap it is marking.

-Tooltip. Indicates which part of the object you are snapping to in a flag at the cursor location.

-Magnet. Attracts and locks the cursor onto the nearest detected snap points. Provides a visual that is similar to snapping to a

grid.
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-Aperture box. Surrounds the crosshairs and defines an area within which, when you move the cursor, system evaluates objects
for object snaps. You can determine the aperture box is displayed or not, and the aperture box size can be changed too.

5.5. Use Polar Tracking and Object Snap Tracking
Auto tracking includes polar tracking and object snap tracking. You can turn them on and off by repressing POLAR and OTRACK
buttons on the Status Bar. When the polar tracking mode is on, the cursor moves along the specified angle. When the object

snap tracking is on, the cursor moves along an alignment path based on the snap point.

5.5.1.Polar Tracking

When polar tracking is turned on, guides display on the screen automatically at the polar e
QOur WebSite
angle increment that you specify. For example, if you draw a line with polar tracking turned Palettes ’
. . . . . ¥ Command Line CTRL+9
on with angle increment set as 65 degrees, the rubber-banding line displays at 65 degree Gl CTRL+0
increments. e e
¥ Quick Select...
Draw Order »
Isolation »
To enable polar tracking and specify the polar angle increment: Ity >
B Update Fields
. . . i &  Block Editor
1.Do one of the following:-Choose Tools > Drafting Settings from the main menu. Sref and BlackIn-place Editing '
. . . . £ Data Bxtraction...
-On the Object Snap toolbar, click the Object Snap Settings button. o e
-Type DSETTINGS in the command line and then press Enter. Run Seript..
Macro ]
2.Switch to the Polar Tracking tab. 3.Select the Polar Tracking On AutolI? ;
New UCS ]
checkbox. \ 12 Named UCS..
4.Do one of the following to specify the polar Lx [ Dretting seftings.. ]
H Model | Layeutl | Layout2 / n !Ei Group
angle increments: —_ Toggle Tabiet '
-Select an angle from the Increment Angle = - o '
drop-down list.
-Mark the Additional Angles check box and click New to define a custom angle increment.
5.Click OK. = Dratting Settings G Drafting Settings = |
Snap and GRid | Polar Trac| | [ Snap and GRid | Polar Tracking | Object Sniap | Dynamic input | Magnifier [ Symmets * [ »
. . Polar Tracking On {F10] Polar Tracking On (F10)
Remark: To toggle polar tracking on and off at any time, Polor gl Setingo Foler Ange Setings Cbjet Snap Tracking Stinga
Increment angle: Increment angle: @ Track othogonally only
click the Polar Tracking button on the status bar or press @ % - © Trackcusing o poer angle stings
; ] Additional angles 7 oo e
F10. £ Fiw
12 Delcte Polar Angle measurement
TSD (@) Absolute
To draw objects using polar tracking: — 0 Releve o st segert

-Turn on polar tracking and start a drawing command,
such as ARC, CIRCLE, or LINE. You can also use polar

tracking with editing commands, such as COPY and ok [ s J[ e ]
MOVE.

-As you move your cursor to specify points, notice the dotted polar tracking line
that appears at the tracking angles you specified. Points you specify while the
line is displayed conform to the polar tracking angle.

w2 |

w 00

SNAP GRID ORTHO [l Qeiivy OTRACK LWT [l
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5.5.2. Object Snap Tracking

Object snap tracking can track along alignment paths that are based on object snap points and display tooltips at the acquired
points. After you acquire a point, horizontal, vertical and polar alignment paths relative to the point are displayed when the
cursor moves over their drawing path. For example, you can specify a point along a path that is based on an object endpoint or
midpoint or an intersection between objects.

You can also use system variable TRACKPATH to control the display of polar and object snap tracking alignment paths.

pain
Endpoint: 46.3636 < 0°

start point

N oo | oo NG o | oo I

5.6. Use Orthogonal (Ortho Mode)

You can restrict cursor movement to the current horizontal and vertical axes so that you can draw at right angles, or
orthogonally. For example, when the Draw Orthogonal option is enabled, lines are restricted to 0 degrees, 90 degrees, 180
degrees, or 270 degrees. As you draw lines, the rubber banding line follows either the horizontal or vertical axis, depending on
which axis is farthest from the cursor. When you enable the isometric snap and grid, cursor movement is restricted to
orthogonal equivalents within the current isometric plane. Ortho mode and polar tracking cannot be on at the same time.
Tuming on Qrtho turns off polar tracking.

To fast enable orthogonal drawing:
-Press F8 or press the ORTO button at the status bar L [Speciy nert point: ETET <o |

el ORTHO OSNAP | OTRACK o [ mooe. [

5.7. Working with Linetypes

A linetype is a repeating pattern of dashes, dots, and blank spaces displayed in a line or a curve. You can assign linetypes to
objects by layer, or by specifying the linetype explicitly. And also, you can specify its scale,  ENEGEGEGEG_—_—_——
3|
load more linetypes into the program from a linetype library file, and create your own [@t =
- | =

custom linetypes.
By default, every drawing has at least three linetypes: CONTINUOUS, BYLAYER, and P CENTER2

— +— - — DASHDOT2

BYBLOCK. You cannot rename or delete these linetypes. : N

- More...

Remark: You should not confuse these linetypes with the hardware linetypes provided by 3 //;
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some plotters. Both linetypes of dashes produce the similar effects. However, if you use both linetypes at the same time, the

results can be unpredictable.

5.7.1. Load Linetypes

GstarCAD includes the linetype definition files gead.lin and geadiso.lin. If you select gcadiso.lin, you can use ISO pen-width
option when you plot.If you want to know what linetypes are already available, you can display a list of linetypes that are loaded
in the drawing or stored in an LIN (linetype definition) file. Both linetype definition files contain several complex linetypes.

@ b b
G Linetype Manager ﬂ (& Load or Reload Linetypes ﬂ
[“"e'“’e fiers e Load Deles Fie..
Show all linetypes - Invert filter
Cument Hide detail
R
Furrenl linetype:  Bylayer
Linetype Description ol
Linetype Appearance Description BANKLINET ‘ = |
Bylayer I 'l BANKLINEZ Stone Bank Ao_o_o_o_o_o_o_o_o_
ByBlock || | BANKLINEZ Stone Bark B-00 0000000
Continuous ——— Continuous I'l | BANKLINE4 Gravel Bank _o._o._o0._o._0_o_..
BANKLINES Sand Bank o nr_hnr b
BANKLINES GrassBank _J 444
BANKLINET R A TR
o BANKLINES . . .
el o || eankLngs T
Mame: Giobal seale factor: k BATTING Batting 5S555555555555555555
Diescription: Curert object scale: 1.0000 BORDER Border __ . _ _ _ __ __
BORDER2 Border (.5x) . S
Use paper space units for scaling 150 pen width: 1.00 Milimeters fl
ok | [ cancel | [ Hep | Lok ] | Comcel | [ ek I
L y — ——
H : age  Export  Help
5.7.2. Change the Linetype of an Object =
w2 B BTEGRBEH A [ Ofe (Ol -
et ~ 3, |||@ L MO - o = ByLayer -
Text Linear || Insert
my & (£ &4 B 2 R 2 E - S B - |E —— center2 |-
You can change the linetype of an object by changing B

the linetype of the layer the object is on, reassigning
the object to another layer, or by specifying a linetype
for the object directly.

5.7.3. Set the Current Linetype

.- —-——-—(CENTER2

Bylayer

ByBlock

Continuous

— - — - — DASHDOT2
—s———— FENCELINEL

More...

By default, all objects are created using the current linetype, which is displayed in the Linetype Control on the Properties

toolbar. To modify this current linetype, you can select a
linetype and make it current in the Linetype Manager dialog

box. If the current linetype is BYLAYER, objects are created

using the linetype assigned to the current layer. e L

If the current linetype is BYBLOCK, objects are created S —
using CONTINOUS linetype until they are grouped into a m
block. When you insert the block, it acquires the current st

linetype setting. g ;32:1‘;!

To make the linetype current: :?Zm mm

Bylayer

ByBlock

Continuous
—-——— CENTERZ

.l —-— . — DpasHpoT2

————— FENCELINEL
More..

Select a linetype from the Linetype Control pull-down list on the Properties toolbar, which is set to the current linetype.
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5.7.4. Control Linetype Scale

You can set global or individual scales for objects to

control the display of linetypes. The Global Scale G:;:"w“lg —
Factor and Current Object Scale are displayed in the [Shaw alinctypes 7] Pl it
Linetype Manager. The Global Scale Factor value is Curentlinetype:  Bylayer

stored in the system variable LTSCALE, which changes ;,,2; Jecoanes Do

the linetype scale globally for new and existing ?ik _—

objects.

The Current Object Scale is stored in the system e e [

variable CELTSCALE, which specifies the linetype Curert objectscale: 10000

scale for new objects. In a layout, you can use system s pper spsceunts o selng S
variable PSLTSCALE to adjust the linetype scale in Ok ) [LCaed ] [t

different viewports.

Remark: Setting the linetype scale too large or too small may result in a line pattern looking like a solid line, depending on what
the scale view is or at what scale the drawing is printed.

To set the current individual linetype scale:  Format > Linetype Command ling> LINETYPE

-Choose Format > Linetype-Click the Show Details button.-In the Current Object Scale field, type the linetype scale that you
want to make current.-Click OK.

To change the global linetype scale:  -Choose Format > Linetype-Click the Show Details button.-In the Global Scale Factor
field, type the global linetype scale that you want to change. Then click OK button.

5.8. Working with Layers

Layers are like the transparent overlays you use in manual drafting. You use layers to organize different types of drawing
information. Each object in a drawing exists on a layer. When you draw an object, it is created on the current layer.

5.8.1 Create and Name Layers

You can create an unlimited number of layers in every drawing and use those layers for organizing information. When you
create a new layer, it is initially assigned the color white (or black, depending on your system settings) and the linetype
CONTINUOUS. By default, a new layer is also visible. After you create and name a layer, you can change its color, linetype,
visibility, and other properties.

Layer Properties Manager L2 ]
Cuent layer LINES

To create a new layer:  Format > Layer SB@ > 5 Xy
Command line> LAYER 2

Feeze lock Color Lnetpe Lneweght PotStle Plt New viewporfeze Descaption

ICIDOO®
¢

o8l o fol DRV EoR ]

-Choose Format > Layer-Click the New Layer button.
-Type a name for the new layer and then click OK.

®

v A Shows 8layers.total Blayens [ ok || Coce Aooly Help
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To change a layer name in the current drawing:

-Choose Format > Layer-In the Layer Properties Manager dialog box, click the name of layer you want to change.

-Type a new name and click OK button.

5.8.2. Setting the Current Layer

When you start a drawing, objects are created
in the current layer. By default, the layer 0 is
set to the current layer, but you can also create
anew one and make it current. Any subsequent
objects you create are associated with the
current layer and use its color and linetype.

To make a layer current;

Layer Properties Manager

;:umlb,«HIDE
#Ba > % x ]

W Contiou
B W. Continy... — Defaut Co
MWW Contru
82 HIDDEN2 — Defauk Color_82

» Slu!AOnﬁmLod(CdawhmM&mﬁuNawvmmanmum
W W, Continu
L] !52c5uTER —Ddu

—— Defaut Color_7

W HIDDEN? — Ddul
— Defaut Col

— Defauit Col

"~ Al Shows 8layers. total 8 layers

[ ok Cancel [

-Choose Format > Layer-In the Layer Properties Manager dialog box, select a layer and then click the Set Current button to

make the layer current.-Click OK.

5.8.3. Removing Layers

You can remove unused layers from your drawing with PURGE or by deleting the layer from the Layer Properties Manager.

5.8.4. Controlling Layer Visibility

A layer can be visible or invisible. Objects on
invisible layers are not displayed and do not
print. By controlling layer visibility, you can turn
off unnecessary information.

To turn layers on or off:
Command line> LAYER

Format > Layer

-Choose Format > Layer
-Click the icon under "On" tab in the layer list.
-Click OK button.

5.8.5. Locking and Unlocking Layers

Locking a layer prevents you from accidentally
modifying its objects. When a layer is locked (but

r

Layer Properties Manager 4

Current layer: LINES

E&a »%5% XY

Vo d 0

7 CENT.
Yord Defpo..
P d HIDE
Vo Layer 1
Vo

Vg

»

|| Status Namel IFreeze Lock Color Linetype Lineweight Plot Style

Plot New viey

5 = Defautt Colo: (=]
n:

Default ’\hr_W‘Z @
] Tumn Iayer on or off for entire drawing Defaut Color_7 @
? -I.l‘- m' B W.. HIDDEN2 — Defaut Color 7 &
v o3 ﬂlv @ W.. Continu... — Default Color_7 @
W o @' EW. Continu... — Defaut Color_7 (=]
' £ @' H82 HIDDEN2 — Defaut Color 82 &
. . =

(=2

All: Shows 8 layers. total 8 layers

Layer Properties Manager &

Curent layer: LINES

s .

X v

> || Status Name On
0

CENT.
Defpo.
HIDE
Layer 1

ARRQQQY

REFE

v

Layer2 )
Y

Freeze | Lock a | Color Linetype Lineweight Plot Style Plot New viewport freeze De

S S S — . S—

jod Lock o
H oc¢

o Locks or unlocks layer globally for entire drawing a
s < 8
Eed B W._ HIDDEN2 — Defaut C e 7]
ks W, Continy... — Defaut C e 7]
o B W..Contrnu... — Defaut Color_ T
.

[ 82 HIDDEN2 — Defaut Color_82

(=28

All: Shows 8 layers. total 8 layers

[
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visible and thawed), you cannot edit them. If you lock the current layer, you can still add new objects to it. You can also change
the linetype and color associated with a locked layer. Unlocking a layer restores full editing capabilities.

To lock or unlock layers: ~ Format > Layer Command line> LAYER

-Choose Format > Layer from the main menu.
-Click the icon under "Lock" tab in the layer list.
-Click OK button.

5.8.6. Controlling Layer Printing

Controlling layer printing is another way you can specify which objects print in your drawing.By controlling layer printing, you
can turn off unnecessary information during printing. When you turn off printing for a layer, objects drawn on that layer are still
visible, but they do not print.

.
Layer Properties Manager

Current layer: LINES
To turn layer printing on or off:  Format > SB@ > 5 XV
. »|[ status Name On Freee lock & Coor Lietype Lneweght Pit St | Pt | Newviewporreeze Descrotion

Layer Command line> LAYER = o G f WV —DdaaCes @ G :
= 2N ¥ 8, NIRRT 0dad 0ol SD:mmmesrﬂa er i plottable or not for entire drawin J
< Defo ol @'  EW. Continu.. — Defauk Color i yer is pl g
7 HIDE Eod G° M W. HIDDEN2 — Defauk Color_7 (=] 2
7 Layerl o GF EW. Continu _Dd“i',:; =] B

~Choose Format > Layer = I 3 e o
[~ __JLNES . 2 .

-Click the icon under "Plot" tab in the layer list.

»

"3*' Al Shows 8 layers, total 8 layers ok J[ coca ][ mmy

-Click OK button.

5.8.7. Seiting a Layer's Print Style

If your drawing uses named print style tables, you can specify a print style for each layer. Named print style tables contain print
styles that you set up to control what objects look like when they print, without actually changing the objects in the drawing. If

your drawing uses color-dependent print style tables, you cannot specify a print style for a layer. These types of print style
tables automatically determine printing requirements by the color assigned to a layer or an object.

To change the print style assigned to one or more layers (only in a drawing that uses named print style tables):

Format > Layer Command line> LAYER =
Choose Format > Layer o, Taa oo
w72 Cortinuous Defaul —_ Changes plot style for entire drawing

LIEl Cortinuous:

-Click the name of Plot Style in the layer list to open Select Plot

. i . . [ Bt Continuous Defaut  Color_10
Style dialog box, from which, you can specify the desired plot style.
-Click OK button. _
Layer Properties Manager -
Current layer: LINES
ERGH &> XV
» || Status Name On Freeze | Lock a Color Linetype Lineweight Plot Style Plot  New viewpol
5 8 8 F Th L “ 0 - C{ Freeze: = i - @ d
.0.0. Ireeze or aw ayerS Z EZ:I o g Freezes or Thaws layer globally for entire drawing [ % %
e ) DeTguTTTTT )
47 HIDE 9 £ o3 Il W.. HIDDEN2 — Defaut Color_7 (=] o)
. o layerl 3og M W... Continu... — Defaut Color_7 2
You can also freeze layers to improve the = W.. Continu,. — Defauk = %)
. ) =4 . [ 82 HIDDEN2 — Defaut Color 22 (& =)
performance of operations such as zooming v UNEsS @ B W. Continu.. — Defauk Color 7 (& T
99
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and panning or producing hidden lines or shaded images. When a layer is frozen, objects drawn on that layer are no longer

visible.
To freeze or thaw layers:  Format > Layer

-Choose Format > Layer

-Click the icon under "Freeze" tab in the layer list.

-Click OK button.

5.8.9. Setting the Layer Color

Each layer in a drawing is assigned a color.
GstarCAD uses the BYLAYER color as the default
color setting for object creation so that new
objects are drawn in the color of the layer on
which they are inserted.

To change the layer color:
Command line> LAYER

Format > Layer

-Choose Format > Layer

Command line> LAYER

Layer Properties Manager

| Curent layer: Layer 1

o 0
Vo4 CENT.
Vo4 Defpo.
=4 HIDE

»

(=2

All: Shows 8 layers. total 8 layers

Select Color

)

index Color | True Color._| Color Books

Index Color(ACI):

[ 1 T HENEE R

-Click the icon under "Color" tab in the layer list to open Select Color dialog box, from which, you can specify the desired color
through index, true and color books tabs—Then click OK button.

5.8.10. Setting a Layer's Linetype

Each layer uses a default linetype. Linetype determines the appearance of objects both on the screen and when printed. It's
recommendable to assign the BYLAYER linetype to any objects that you draw on that layer.

To change the linetype assigned to one or more
layers: Format > Layer Command ling>
LAYER

-Choose Format > Layer

-Click the Linetype name in the layer list to open
Select Linetype dialog box, from which, you can
specify the desired linetype. -Click OK button.

5.8.11. Setting a Layer's Lineweight

Layer Properties Manager

M 152CENTER

W W.. Continuous
W W.. HIDDEN2
W W.. Continuous
82 HIDDEN2
B W...Continuous

Each layer uses a default lineweight. Lineweights determine the thickness of objects
both on the screen and when printed. All new layers are assigned the DEFAULT
lineweight, which is .25 millimeters or .01 inches. If you want a different lineweight

assigned to a layer, you can easily change it using Layer Properties Manager.

Select Linetype =)
Loaded Inetypes
Linetype Appearance Description
CENTER —————— Center______|
U Cortinuous Continuous I
HIDDEN2 — —— — Hdden(5)______|
ok ] [ cowel | [ Loade Hep
- —_—
Default -
"
0.05mm

— Default Call

— 020 mm Col

0.09mm
0,13 mm
0.15mm

0.00 mm ‘_‘

—— 0.25 mm Colj
— Default Cols
— Default Coll
— Default Cols
— Default Coll

0.18 mm
0.20 mm
0.25mm
0.30 mm
0.35mm -

iginal:  Default
Default

] l Cancel ] [ Help ]
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To change the lineweight assigned to one or more layers: Format > Layer Command line> LAYER
-Choose Format > Layer
-Click the Lineweight name in the layer list to open Lineweight dialog box, from which, you can specify the desired lineweight.

-Click OK button.

5.8.12. Filter List of Layers

You can use a layer filter to limit the display of layer names in =
ment layer: r Filter name:
the Layer Properties Manager. The following properties can §|& § » 4 ===
\ . . . » us Mame On -
be Included in the fllter deflnmon Layer namesy Colorsy jm DN o ] Ststus Name On Freeze Lock Color Linetype Lineweight Plotstyle Plot
linetypes, lineweights, and plot styles. Whether layers are s
. o1 L
locked or unlocked, turned on or off, frozen or thawed in the L o
=  REFE ‘-
current viewport or all viewports. When setting filter N (e
conditions, you can also use wild-card characters to filter Soun  Neme On fieem Lok sobr nelyc inovedte Pisive P

names by name. For example, typing D* displays layer name |2
preceded with D, just click Add button if the filter name has "4
been specified.

@
T Mw. HIDDEN2 —0.25...Color_7
" M w. Continu... — Default Color_7

LR
g

X @ Ew. Continu.. —Default Color 7 5
L Bl 152 CENTER  —— Default Color_152

o 7

o @

o3

=)
W w.. Continu... —0.20...C [=]
=)
@

To filter list of layers:

-Choose Format > Layer

-Click the New Property Filter icon, located at top left of the window.

—In the Layer Filter Properties dialog box, under filter definition, click the tabs properties you want to filter. Then click OK.

5.9. Displaying Lineweights

Lineweights are displayed differently in paper space layout than model space. Lineweights are useful for graphical
representations of different objects and information.

5.9.1. Display Lineweights in Model Space

Properties n % |4 Drawingl.owg  sampledwg %

In model space, a 0-value lineweight is — S
Col M ByLayer
displayed as a pixel, and other lineweights are e
display with a pixel width proportional to their ool
real-unit value. In model space, lineweight e
display does not change with the zoom factor. e
A lineweight value that is represented by a S
Start Z EEﬂmE_
width of several pixels is always displayed —
using the same number of pixels. In model |
space, press LWT button on the status toolbar e
to turn lineweight display on and off. S Baior

1« » » ' Model [Layoutl /LayoutZ

swr oo omo EYAMTDEIANCEIACICES @ |
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Chapter 5 Precision Tools and the properties of Drawing

5.9.2. Display Lineweights in Layouts

In paper space (layout tab), lineweights are displayed in exact plotting width. In plot preview and paper space, lineweights are
displayed in real-world units, and lineweight changes with the scale factor. From the Plotting Scale tab of Plot dialog box, you
can control the lineweight plotting and scaling in a drawing. In paper space, press LWT button on the status toolbar to turn
lineweight display on and off. This change does not affect the lineweight plotting.

2 %X |4 Drawingl.dwg - sampledwg X

Properties
[ ]
General -

Color M Bylayer

Layer Lines !
Unetype | —Bylayer |
Linetype scale |7
Plot Styte BYCOLOR [

|
Hyperink — Bylayer
Thickness | Default |
3D Visualization
Materizls — 009 mm ‘

Geometry —0.15mm |
Start X —0.18mm
Stant Y —_025mm ‘
Start Z —0 ‘

\
\
\
|
|

Genter X — 040 mm
CerterY ~ ==050mm

CenterZ
End X .70 mm

S - 0.50 mm
EndZ - 100 mm

e .1 20mm
Start angle 140 mm

Endangle | 200 mm
Totslange  EEE2.11mm L

Arc length 1446314

W ¢ > » " Model ; Layoutl {Tayout2

I VG ATol PoLAR | OshaP | omrack | tweicHT | pyn | moDEL

5.10.Spell Command

Users can check the spelling of all text as it is entered in your drawing with Spell command. Users can also specify the specific
language dictionary that is used and customize and manage multiple custom spelling dictionaries.

-
Check Spelling o]

Display the areas you want checked for spelling(w/)

Current custom dictionary(M)
(Engish v [ setng@m ]
Not in dictionary(N)

Proff nal T |
Addto D /D)
uggestions|la |
Poewins |
Prtessona [
‘ Change(C)
[ [ Changesn) |
[ ocosem || Help(H)
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6. Create Objects

Drawings are made up of objects. In general, you draw objects by specifying points with the pointing device or by entering
coordinate values at the command prompt.

6.1. Draw Linear Objects

6.1.1. Lines

A'line consists of two points: a start point and an endpoint. You can connect a series of lines, but each line segment is
considered a separate line object. To draw a line:  Draw > Line Command ling> LINE

1.Choose Draw > Line from the main menu. Point
2.Specify the start point. T
3.Complete the first line segment by specifying the endpoint. .
4 Press Enter to complete the command. A
X
To start a new line at the endpoint of the last line drawn, start the Line =, .
command again and press Enter directly at the "Specify first point:" ?::y?;ﬁ“
prOmpt Dmnm “‘"‘[d“] IOl FoLar | oshap | oTRack o | mc
6.1.2. Multilines

Multilines consist of several parallel lings, called elements.

You can determine the position of elements by specifying offset from the origin of each element. By default, multiline objects
contain two elements. You can create and save new multiline styles by yourself or modify existing mline styles.

To draw a multi-line: Draw > Multiline Command line> MLINE

1.Choose Draw > Multiline from the main menu.

2.Specify the start point.
3.Specify the endpoint. » 7 \Model {Layoutl {Layout2 /
pecify start point or [Justification/Scale/STyle]:
4 Press Enter to complete the command. pecfy next poin:
pecify next point or [Undo]:
'6 Multiine Style léj‘ | ify next point or [Close/Undo]:
GRID ORTHO POLAR
Current Mutine Style:  STANDARD
Styies: G New Multiline StylesSTYLEL =)
Set Cursrt Descripton NEW STYLE
New Caps Blemerts
Line: i Ll 0.500 BYLAYER ByLayer
Rename e I a 205 BYLAYER  Bylaysr
Delete rsrarcs: &
Description: — Angle 50.00 3000 .
Fil
-
Preview: STANDARD Fil color [ONene -
Color. M ByLayer
Display joints: [ Racypes Linetype..
oK ] [ Cancel ] I Help [ ] [ Concel | [ we |
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6.1.3. Rays

Aray is a line in three dimensional space that starts at a point
and extends to infinity. Because rays extend to infinity, they
are not calculated as part of the drawing extents. The default
method for drawing a ray is to select the start point of the ray
and then specify its direction.

To draw a ray:
Draw > Ray Command line> RAY
1.Choose Draw > Ray from the main menu.

2.Specify the start point and the direction.
3.Press Enter to complete the command.

6.1.4. Construction Lines

A construction line is a line through a given point, oriented at a specified

e
\ne
¥ Point
A
% [Speiy through point._J[FTTE J[i5aat |

M 4 » M ' Model / Layoutl

Layoutl

5 [Select object
ly {Specily base point or [Displacement] <Displacement>: Speciy secand point or <us
firs point as displacement>:
mmand: RAY
pecify start point:

Ispecify through point

11494.5506, 1330.2165, 0

VLI EVIO roLar | osnap | otrack JNRVGETM Dy | MoDEL -

angle in three dimensional space and extending to infinity in both directions.
You can also draw a construction line at a specific angle or at an angle

relative to an existing object.

To draw a construction line:  Draw > Construction Line
XLINE

1.Choose Draw > Construction Line from the main menu.
2.Specify a point along the line.

3.Specify the direction.

4.Press Enter to complete the command.

6.1.5. Polylines

A polyline is a single object with connected sequence of line segments or/and arc

S s o
—

O X

v

4 b ¥ " Model ¢ Layoutl / Layout2

Command line> &

Command: “Cancel*

{Command: "Cancel™

{Command: “Cancel®

Command: "Cancel”

Command: “Cancel™

Command: XLINE

Specify a point or [Hor/Ver/Ang/Bisect/Offset]: H
{Specify through poirt:

{Specify through poirt.

ISpeciy through point

> GRID |[geliglel POLAR [eliilAg I OTRA

segments.When you draw a polyline, you can switch to different options. After you draw .
more than one segment, you can close the polyline, undo or finish. +

To draw a polyline with straight segments: Draw > Polyline

1.Choose Draw > Polyline from the main menu.
2.5pecify the start point.

LX oy e portar ] 5% |

Command |Iﬂe> PLlNE 4 b bl Model £ Layoutl A Layout?

BlSpecify start point:

(Current linc-width is 0.0000

(Speciy next poit or [Aro/Halfwidth//Length/Undo/Wicth]:
ISpeciy next poit or [Arc/Close/Halfwidth/Lengih/Undo/Width]:
(Speciy next point or [Arc/Close/Halfwidth/ Lengih/Uindo/ Width].
ISpeciy next point or [Arc/Close/Halfwidth/Length/Undo/Width]:
[Speciy next poit ar [Arc/Close/Halfwidth,/Lengin/Unde/ Width]

11497, 548,0 SNAP  GRID [JelAGIeN POLA|

n
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3.Specify the endpoint of each segment.

4 Press Enter to end, or enter ¢ (close) to close the polyline.

To draw a line and arc combination polyline:
Draw > Polyline Command line> PLINE

1.Choose Draw > Polyline from the main menu.
2.Specify the start point.

3.Specify the endpoint.

4 At the command prompt, choose Arc.
5.Specify the endpoint of the arc segment.

6.To complete the command, Press ENTER.

To create closed polylines: Draw > Polyline

O
LJT—I

hes

M 4 » v Model /Layoutl ; Layout2

[& TSpecty next pait or [Arc/lose, Haltwidtn Lengthy Undos vidi:

3 |specify next point or [Arc/Close Halfwicth/Length, Lindo. Width]:

ISpecify next poirt or [Arc/Close/Halfwidth/Length,/Undo/Width: A

ISpecify sndpoirt of arc or
[Angle/CErter/CLase/Direction/Halfwidth,/Line/ Radius/Second pt/Undo/Width:
\Speciy endpoint of arc or

[Angle/CErter/C rection, Halfwidth/Line,/Radius/Second pt/Undo /Wicth]:

114639104, SNAP  GRID |[gelgilel POLAR |[Reiyl)

Command line> PLINE

When creating polylines with PLINE command, the Close option is only available if no less than two line or arc segments are
drawn. A closed polyline object is drawn if you connect the start point of the polyline to endpoint of the last line or arc segment

with a line or arc.

LWPolyline

Color Bylayer
Layer 0

Linetype Bylayer

14 4 » K Model / Layoutl / Layout?

[Specify endpointt of arc or

X

n [Angle/CEnter/CLose/Direction/Halfwidth/Line/Radius/Second pt/Undo,/Width]:

Specify endpoint of arc or

[Angle/CEnter/CLose/Direction/Halfwidth/Line/Radius/Second pt/Undo,/Width]: LINE
Specify next point or [Arc/Close/Halfwidth/Length/Undo,/Width]:
Specify next point or [Arc/Close/Halfwidth/Length/Undo,/Width]: CLOSE

Command

To create wide polylines: Draw > Polyline

(e ORTHO [CWEUEN OSHAP

Command line> PLINE

You can draw polylines of various widths by using the Width and Halfwidth options of PLINE command. The Width and
Halfwidth options set the width of the next polyline segments you draw. You can set the width of individual segments and make

them taper gradually from one width to another.

T

Specymesparter [ o]

M 4 » » Model {Llayoutl ; Layout2

R fSpecty ending width <0.3000>:

i {Specify next point or [Arc/Close/Halfwidth/Length/ Undo/Width]
|Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]:
(Specify nest poirt or [Arc/Close./Halfwidth/Length/Undo /Midth]
(Specify next point or [Arc/Close./Halfwidth/Length/Undo/Width].
|Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]:

Specify next point or [Arc/Close/Halfwidth/Length/Undo /Width]:

SNAP GRID ORTHO A
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To draw a boundary polyline: Draw >Boundary Command line >BOUNDARY

1.Choose Draw > Boundary from the main menu.
2.Specify the objects by doing one of the following:

G Boundary Creation [}

Pick Poirts

-Current viewport Define a boundary set with all entities in the
current viewport. if this option is selected, any boundary set
currently used will be canceled.

Island detection

Boundary retention

Retain boundaries

Objes p

-Existing set Click New button to switch to the drawing area,

and prompt users to select objects for defining boundary sets.

Press Enter to return to the dialog box after selection. This

option is only available after selecting objects by using the New button.

3.Select the Island Detection option.
4.Click Pick Points.

Boundary st

ok ] [ caca | [ Heb

5.In the drawing, click inside the area whose closed perimeter forms the boundary, not on the polyline itself. If desired,

continue clicking inside additional closed perimeters.
6.To complete the selection, press Enter.
7.In the Boundary Creation dialog box, click OK.

v

Lx [Fck et i |

M 4 » H “Model £ Layoutl / Layout2

% |Pick intemal poirt: Selecting all objects...

@ |Selecting evenything visible ...

[inalyzing the selected data

[Analyzing the selected data...Emor analyzing intemal islands

Pick intemal poirt:

11559.7166, 1350.4103, 0 SNAP  GRID ORTHO

6.1.6. Polygons

Creating polygons is a simple way to draw squares, equilateral triangles,
octagons, and so on. Polygons are closed polylines with between 3 and
1,024 equal-length sides.

To draw a polygon by vertex: Draw > Polygon Command
line>POLYGON

1.Choose Draw > Polygon from the main menu.
2.Type 6 to specify six sides for the polygon.
3.Specify the center of the polygon.

4.Specify the vertex of the polygon.

Y LWPalyline

I---!— Color Bylayer

Layer 0
Linetype Bylayer

>

4 4 ¢ b ' Model / Layoutl » Layout2

3¢ |Analyzing the selected data...Emor analyzing intemal islands

1 |Pick intemal paint:

BOUNDARY created 1 polylines.

Command:

Command:

11561.1469, 1351.7565, 0 SNAP GRID ORTHO  PC

4 4 » » Model / Layoutl / Layout2 /
e —_— —

F}Enter number of sides <4>: 6

1 pecify center of polygon or [Edge]:

|Enter an option [Inscribed in circle/Circumscribed about circle] <I>:1
gSpecify radius of circle:
-423.689, -223.8862, 0 SNAP GRID ORTHO POLA
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6.1.7. Rectangles

Rectangles are closed polylines with four sides. You draw a rectangle by specifying its opposite comers. The rectangle is
normally aligned parallel to the current snap and grid alignment, but you can use the Rotated option to align the rectangle to
any angle.

To draw a rectangle: Draw > Rectangle Command
line>RECTANG

1.Do one of the following:

-Select Draw > Rectangle on the main menu. D

-Click the Rectangle tool or type RECTANG command and press j»
Enter. <> ¥ \Model {Layoutl {Layout2 /

1% |Specify first comer point or [Chamfer/Elevation/Fillet/ Thickness/Width]: F
Y pecify fillet radius for rectangles <0.0000>: 10

it pecify first comer point or [Chamfer/Elevation/Fillet/Thickness/Width]:

2.1dentify one corner of the rectangle or enter an option. Specify {Soecy ofher comer poin o [vea/ Dimensions/Rotaion]

-272.9449, -287.2165, 0 SNAP GRID ORTHO POLAR eIVl OTRACK LW

first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]:

3.Identify the opposite corner of the rectangle or enter an option. Specify other corner point or [Area/Dimensions/Rotation]:

6.1.8. Points

You can draw a point object formatted as either a single dot or as one of 19 other possible display styles.

To draw a point: Draw > Point Command line>POINT

+ o+
o4
1.Choose Draw > Point > Single Point from the main menu. U
. : . ﬁg [
2.Specify the location of the point. e e e
x

»1 " Model /Layoutl /Layout2

To draw several points:

1.Choose Draw > Point > Multiple Point from the main menu.
2.Specify the location of each point.

To change the size and appearance of point objects:
Format > Point Style Command line>DDPTYPE

1.Choose Format > Point Style from the main menu.

2.Under Point Style, select the style you want. ‘ ‘ PortSee: 50000
3.Under Point Size, specify the point size, or choose one of the options. e

4 Click OK button. (oK [Ccamcat ][ 1w ]

When you regenerate the drawing, all point objects change to reflect the new size and
appearance settings.
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6.1.9. Freehand Sketches

A freehand sketch consists of many straight line segments, created either as individual line objects or as a polyline. Before you
begin creating a freehand sketch, you must set the length, or increment, of each segment. The smaller the segments, the more
accurate your sketch, but segments that are too small can greatly increase the file size.

To create a freehand sketch:

1.0n the command line, enter SKETCH and press Enter.

2.At the "Record increment" prompt, enter the minimum line segment length.

3.Move the cursor to the drawing area, then click or enter p (pen) to begin sketching.
4.Click or enter p (pen) again to lift the pen up and stop drawing, so that you can move
the cursor around the drawing area without drawing.

M« » v Model £ Layoutl / Layout?

5.Enter R (Record) at any time to write into the drawing the line you're drawing and formn SiETCH

those already drawn. 6.Press Enter to complete ey oo Ease Comect.2

the sketch and write all lines into the drawing. e s
To erase freehand sketch lines:

1.While running the SKETCH command, enter E. If the pen was down, it moves up.

2.Move the cursor to the end of the line you drew last and then move it back as far along the

ling as you want to erase. o Model Lol o2

% [Specify origin of UCS or [ZAds/3 points/OBject/Face/View/X/Y/Z] <0,0.0>

3.To end the erasure and return to the sketch Command prompt, enter E. If you want to o SiETCH
change the current viewport while sketching, make sure the pen is up and all lines were
written into the drawing.

6.2. Draw Curved Objects

6.2.1. Arcs

Home Insert Annotation 3D Layout

= - || rmove T
/DD® C’)'o&:‘wyd

Anarcis aportion of a circle. There are numerous ways to define an arc, the default method e Pevine crde Fa% iy i e =
uses three pick points, a start point, a second point and an end point. Using this method, T peemmrees = [ apom
the arc will start at the first pick point, pass through the second point and end at the third /“ Start, Center, End
point. Once you have mastered the default method try some others: /A star, Center, Angie
Z Start, Center, Length
-3 points -Start, Center, End -Start, Center, Angle -Start, Center, Length-Start, End, Angle /7 s 1
-Start, End, Direction 2nd . '
. point Vu Start, End, Direction
-Start, End, Radius -Center, Start, End '
ISF 3r¢_:| /I Start, End, Radius
-Center, Start, Angle poin oint :
-Center, Start, Length  -Continue L — (. e s en
*® ﬂ Center, Start, Angle
To draw an arc by 3 points as sample: Draw > Arc>3 = M (7 conn s ent
pOImS fE o ﬁ:gal[::g:er/w] <ORTHO OfF> ﬂ: Continue

snap GRD  ortHO  Polar (SR ISIETES
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1.Choose Draw > Arc > 3 Points from the main menu.
2.Specify the start and second points.
3.Specify the endpoint.

6.2.2. Circles

The default method for drawing a circle is to specify a center point and radius.
You can draw circles using any of following methods:

-Center, Radius ~ -Center, Diameter

-Concentric

-2 points -3 points

-Tangent, Tangent, Radius

-Tangent, Tangent, Tangent

To draw a circle by specifying its center and radius:Draw > Circle > Center, Radius
Command line>CIRCLE

1.Choose Draw > Circle > Center, Radius from the main menu.
2.Specify the center point.
3.Specify the radius of the circle.

To draw a circle tangent to existing objects:
Draw > Circle>Tan, Tan, Radius  Command line>CIRCLE

1.Choose Draw > Circle > Tan, Tan, Radius from the main menu.

2.Select the first tangent point on the object to be tangent with the circle.
3.Select the second tangent point on the object to be tangent with the circle.
4 Specify the radius of the circle.

6.2.3. Ellipses

Ol &8
&~ b
Circle Arc E‘l
o ! <[ 8
@ Center, Radius
@ Center, Diameter
Concentric
Q 2 Point
Q 3 Point
Tan, Tan, Radius
O Tan, Tan, Tan
Center
point TRadius
__ﬁ

4 4 » b " Model {Layoutl /Layout2

K id>n
B [Specify origin of UCS or [Z/vis/3 points/OBject /Face Miew/X/Y/Z] <0.0.0>:

Command: C
CIRCLE Specfy center point for cicle or [3P/2PTir/Arc/Mutple]
5 of Gircle or [Diameter]

0 SNAP

GRID ORTHO PoLAR (e

Tan

W 4 v v " Model {Layoul [ Layout2

pecify point on object for first tangent of circle
pecify point on obiect for second tangent of circle:
pecify radius of circle: Specify second paint

-3.2505, 10.2104, 0 SNAP

GRID ORTHO  P(

The default method for drawing an ellipse is to specify the endpoints of one axis of the ellipse, and then specify a distance
representing half the length of the second axis. The endpoints of the first axis determing the orientation of the ellipse. You can

draw ellipses using any of the following methods:

-Center  -Axis, End  -Ellipse, Arc
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To draw an ellipse by specifying the axis and endpoints: Draw > Ellipse> Axis
Command line>ELLIPSE

1.Choose Draw > Ellipse > Axis, End from the main menu.

2nd
endpoint

1st s

endpoint

W 4 » » "\ Model /Lsyoutl /Layout2

2.Specify the first endpoint and second endpoint.3.Specify a distance for half the length  Femam

of the second axis.

To draw an elliptical arc by specifying the axis endpoints: Draw > Ellipse=>Arc
Command line>ELLIPSE

1.Choose Draw > Ellipse > Arc from the main menu.
2.Specify the first endpoint.

3.Specify the second endpoint.

4.Specify the half length of the other axis.

5.Specify the start angle of the arc.

6.Specify the end angle.

6.2.4. Splines

1 Ispecty base point or [Displacement] <Displacement>: Specfy second paint or <us
ke first poirt as displacements-
mmand: ELLIPSE
peciy axis endpoint of elipse or [Arc/Center]
peciy other endpoint of ads

2nd
endpoint

1st
endpoint

M 4 » M 4 Model / Layoutl / Layout2

% Specify axis endpoint of clipse or [Arc/CenterFARC
8 |Specity axis endpoirt of eliptical arc or [Center]
ISpeciy cther endpoirt of axs

{Specify distance to other axds or [Rotation:
{Speciy start angle or [Parameter]: 15

ISpecify end andle or [Parameter/Inciuded angle]
Command:

Spline is a smooth curve that passes through a series of control points. Multiple points are required for drawing irregular
splines than can be closed as well, so the start and endpoints are coincident and tangent. The tolerance in a spline, describes
how precisely fits between multiple points (lower tolerance, more closely the spline fits the points). Usually there are two ways

to create splines:

-Create a spline converted from a polyline using Spline option of PEDIT command.

-Create a spline using SPLINE command.

Todraw a spline:  Draw > Spline  Command line>SPLINE
1.Choose Draw > Spline from the main menu.

2.Specify the first point of the spline.

3.Specify the second point of the spline.

4.Specify as many more points as you want.

5.When you have finished, press Enter.

To draw a closed spline: Draw > Spline  Command line>SPLINE
1.Choose Draw > Spline from the main menu.

2.Specify the first point of the spline.

3.Specify the second point of the spline.

4.Specify as many more points as you want.

5.When you have finished, on the command line, type C and press Enter.
6.To complete the command, specify the tangent point.

1« < » o " Model /{Layoutl {Layout2

X |Specify next point or [Close/Fit tolerance] <start tangent>:
8 |speciy next poirt or [Close/Fit tolerance] <start tangert >
pecity next point or [Close/Fit tolerance] <start tangert>
pecify next peint or [Close/Fit tolerance] <start tangent>:
pecty next point o [Close/Fit tolerance] <start tangent>: C
peciy tangent

mmand.

SNAP  GRID  ORTHO

M4 »

+1 ' Model / Layoutl / Layout2

& Comm:

and: spine

B (Unknown command "spine”. Press F1for help.

Comm:

and: SPLINE

(Specify first point or [Object]):
(Specify next point:
ISpecify next paint or [Close/Fit tolerance] <start tangent>:

98,96

ISpecify next paint or [Close/Fit tolerance] <start tangent>:

28,0 SNAP  GRID ORTHO

W < » v ", Model {Layoutl ] Layout2

B
-3

-110.1425, 5.591, 0

ISpeciy next point or [Closs/Fit tolerance] <start tangent:>
‘Speciy next point or [Close./Fit tolerance] <start tangent>
'Speciy next point or [Closs/Fit tolerance] <start tangent:>
ISpecify next point or [Close/Fit tolerance] <start tangent
‘Speciy next point or [Close/Fit tolerance] <start tangent>
ISpeciy next point or [Closs/Fit tolerance] <start tangent:>
|Speciy next poirt or [Close./Fit tolerance] <start tangent >
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6.2.5. Helix

Creates a 2D spiral or 3D spring. Initially, the default base radius is set to 1. During a < 1T>X)
drawing session, the default value for the base radius is always the previously entered @2 , -?‘

base radius value for any solid primitive or helix. The base radius and top radius cannot
both be set to 0.

To draw a helix: Draw > Helix ~ Command line>HELIX
The following prompts are displayed: Number of turns = 3 (default)Twist = CCW (default)
1.Specify center point of base: Specify a point

2.Specify base radius or [Diameter] <1.0000>: Specify a base radius, enter d to specify the diameter, or press ENTER to
specify the default base radius value

3.Specify top radius or [Diameter] <1.0000>: Specify a top radius, enter d to specify the diameter, or press ENTER to
specify the default top radius value

4.Specify helix height or [Axis endpoint/Turns/turn Height/tWist] <1.0000>: Specify a helix height, or enter an option

Y
L .
M 4 » M Model { Layoutl / Layout2 W« » » “Model / Layoutl 4 Layout?2
€ [Command: HELIX * Command:
B Tums = 3.0000 Twist =CCW &~ STRETCH ™
(Specify center point of base. (Specify stretch point or [Base point/Copy./Undo/eXi]
Specify base radius or [Diameter] <12.6743> Command: Specify opposite comer:
(Specify top radius or [Diameter] <5.5348>: Command: Cancel”
(Specify helix height or [Axs endpaint/Tums/Aum Height/A\Wist] <30.0000::50 Command
Command: Command:

585.1905, -21.8049, 0 SMAP GRID ORTHO POLAR 636.1002, 235.1603, 0

6.2.6. Donut

Donuts are solid, filled circles or rings created as closed, wide polyline. The system variable FILLMODE controls whether to fill
the donut or not. FILLMODE is set to 1, creates filled donuts; if FILLMODE is set to 0, creates without filled.

To create a donut, you specify its inside and outside diameters and its center.
You can continue creating multiple copies with the same diameter by specifying
different center points. To create solid-filled circles, just assign the same value ‘ e

for the inside radius and outside radius. v

M4 4 b M Model /Layoutl / Layout2

To draw a donut; Draw > Donut ~ Command line>DONUT

* Hd>:n

M Specify origin of UCS or [Z#is/3 peints/OBject/FaceMew/X/Y/Z] «0,0.0>
Command: DONUT

{Specily inside diameter of donut <2.0000=: 10

1.Choose Draw > Donut from the main menu. Spechy otsde dameter o dorut <2.0000% 7
. . . . Specify center of donut or <ext>
2.5pecify the inside diameter of the donut. i

r of donut or <exit>:

3,0 SNAP GRID ORTHO  POLAR
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3.Specify the outside diameter of the donut.
4.Specify the center of the donut.
5.Specify the center point to draw another donut, or press Enter to complete the command.

6.3. Create 3D Objects

With 3D models, you can: View entities in three dimensions, create three-dimensional entities, edit entities in
three-dimensional space, edit three-dimensional solids, display hidden-line and shaded views of three-dimensional entities.

6.3.1. 3D Thickness and Elevation

By default, the program creates new two dimensional objects with a zero elevation and thickness. The easiest way to create a
three dimensional object is to change the elevation or thickness property of
an existing two dimensional object. You can extrude any two dimensional
object into a three dimensional object by changing the thickness of the
object to a nonzero value. For example, a circle becomes a cylinder, a line
becomes a three dimensional plane, and a rectangle becomes a box.

To set the current elevation: Command line>CHANGE

W 4 » » ' Model /Layoutl /Layout?

1.Type CHANGE on the command line, and then press Enter after SEIECNG [ e seoesio dunce sovBenLiert Tmeses it s e
jal /Annotative]: E
pecily new elevation <0.0000x: 40

the two dimensional object(s).2.Enter P (Properties) and press Enter. e o o g Elo/ o Ui e A5 Wt Tk Nt e
3.Enter E (Elev) and press Enter. “ ———
4 Specify a new elevation, and then press Enter.

121.97 469, 0 SHAP

To set the current thickness:  Command line>CHANGE

T T

1.Type CHANGE on the command line, and then press Command Line %
. . . . Command: CHANGE -
Enter after selecting the two dimensional object(s). | [ttt Soty conostecomer: ound
elect object:
2Enter P (Propertles) and preSS Enter sF:rp:ecr#:n::::)?tanpclr:nogre“:[‘[r;'\):rrﬁlélil\:tfLAyer/LTypemSca\e/LWeight/Th\cknass/Matar
. al/Annotative]: T
3.Enter T (Thickness) and press Enter. Speciy new hickness <0.0000> 40
. . I ] Enter propﬁjrtyto change [Color/Elev/LAyer/L Type/t Scale/LWeight /Thickness/Mater
4.Specify a new Thickness, and then press Enter. 2/ ortaivel m
Command: 4 3

Command Line x
Command: 3DFACE -
(Specify first poirtt or [Invisible]
6.3.2. 3D Faces il
[Specify third point or [Invisible] <ext >
{Specty fourth poirt or [lnvisible] <create three-sided face:
[Specify third point or [Invisible] <ext >
. . . {Specify fourth poit or [Invisible] <create three-sided face>:
[Specify third poirt or [Invisible] <exit>
You can create a three dimensional face, which
. . . z pecify thind poirtt or [Invisibl 2
consists of a section of a plane in three v s ; :
[Specify third point or |- | ||-140.6992
X

dimensional space. After you specify the fourth
point, the program continues to prompt you for
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additional faces by alternating prompts for the third point and fourth point to

allow you to build a complex three dimensional object.

To create a three dimensional face: Draw > Modeling>Meshes>3D Face

Command line>3DFACE

1.Type3Dfaceon the command line.

2.Specify the first point of the three-dimensional face.
3.Specify the second, third, and fourth points.

4.Specify the third and fourth points for additional faces.
5.To complete the command, press Enter.

6.3.3. Ruled Surfaces: You can create a ruled surface, which is a
three-dimensional body that approximates the surface between two

existing entities. You select the two entities that define the ruled surface.

These entities can be arcs, circles, lings, points, or polylines.

To create a ruled surface:Draw > Modeling>Meshes>Ruled Mesh
Command line>RULESURF

1.Type RULESURF on the command line.

2.Select the first defining object.

3.Select the second defining object.

6.3.4. Tabulated Surface

Tabulated surface meshes are used as a serial of paralleled polygon on

specified path, you should draw direction vector and original object before
creating a tabulated surface. The objects like a line, arc, circle, ellipse, or 2D

or 3D polyline can be used as outline curves for defining polygons.

To create an extruded surface mesh: Draw > Modeling>Meshes > Tabulated

Mesh ~ Command line>TABSURF

1.Type TABSURF on the command line.
2.Select the object to extrude.
3.Select the extrusion path.

6.3.5. Revolved Surface

-
Command: RULESURF
Currentt wireframe density: SURFTAB1=6

‘Select fist defining curve: ™
Select second defining curve -
Command: <= v

Command Line

Command: TABSURF

Cument wireframe density: SURFTAB1=6
Select object for path curve:

1Select object for direction vector.

{Command

Use REVSURF command to create a surface of revolution by rotating a profile of the object about an axis. The object to be
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revolved can be a line, arc, circle, ellipse, elliptical arc, closed polyline, polygon, closed spline or torus. REVSURF is useful for
surfaces with rotational symmetry.

To create a revolved surface mesh: Draw > Modeling>Meshes>Revolved Mesh Command line>REVSURF

1.Type REVSURF on the command line.

2.Select the object to revolve.

3.Select the object to be used as the axis of revolution.
4.Specify the starting angle.

5.Specify the number of degrees to revolve the object.

Command Line x
(Command: REVSURF

(Curert frame densities: SURFTAB1=6 SURFTAB2=6

[Select objects to rotate:

[Select object that defines the ads of revolution:

|Specify start angle <0>: 360

ISpecify included angle {+=ccw, -=cw) <360> -
[Command! < *

6.3.6. Solid Box
A solid box consists of six rectangular surface planes. The base of the box is always parallel with the xy plane of the current
UCS. The length of the box is mapping to X axis of current UCS, and its width maps to Y axis, and height maps to Z axis.

RECTANG or PLINE command creates a rectangle or closed polyline from which you can create a box using EXTRUDE.

To create a box: Draw > Modeling>Box Command line>B0X

Command Line
1.Choose Draw > Modeling > Box from the main menu. o or oot
2.Specify the first comer of the base. b
3.Specify the opposite corner of the base. e

4.Specify the height.

6.3.7. Solid Cone

By default, the cone's bottom lies on the XY plane of the current UCS. The cone height is parallel to the Z axis. The apex
determines the height and orientation of the cone. You can draw a 2D circle and then use EXTRUDE to taper the circle at an
angle along the Z axis to create a solid cone. To complete the truncation, you can subtract a box from the tip of the cone with
the SUBTRACT command.

To create a cone: Draw > Modeling>Cone ~ Command line>CONE
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1.Choose Draw > Modeling > Cone from the main menu. el |
2.Specify the center of the base of the cone. Command Line
. . . ISpecify center poirvf of base or [3P/2P/Ttr/Bliptical]: Cancel”
3.Specify the radius or diameter. (ommand: Caneet
. . Specify center point of base or [3P/2P/Ttr/Hliptical]:
4.Specify the height. oty it o 27/ o
/Top radius] <66.45223:

6.3.8. Solid Cylinder

You can create cylinders defined by a circular base. The base of a cylinder is always parallel with the xy plane of the current
UCS; the height of a cylinder is always parallel with the z axis. You can draw a circle and then use EXTRUDE to create a solid
cylinder.

To create a cylinder :Draw > Modeling>Cylinder ~ Command line>CYLINDER

1.Choose Draw > Modeling> Cylinder from the main menu.
2.Specify the center of the base of the cylinder.

. . . Command Line
3. S pe C Ify the radius or diameter. Edwireﬁ;ne/fbdv\éirelfmme/H\dder\/Reahshc/ConcemuEVOther] <Conceptual>: _2
egenerating model
4.Specify the height. echreg 7 o
] <112 20625 <ORTHO Ons><ORTHO Of

6.3.9. Sphere

The latitude lines of a sphere are always parallel with the xy plane of the current UCS; the central axis is always parallel with the
z axis. You determine the size of a sphere by specifying either its radius or its diameter.

To create a sphere: Draw > Modeling>Sphere Command line>SPHERE

‘Command Line

(Select object: Specify opposite comer: 2 found
(Select object
Command: SPHERE

1.Choose Draw > Modeling > Sphere from the main menu.
2.Specify the center of the sphere.

(Specify center point or [3P/2P/Tir]
{Specify radius or[Diameter]

Command:

3.Specify the radius or diameter.

6.3.10. Torus

Atorus is constructed by revolving a circle about a line drawn in the plane of the circle and parallel with the z axis of the current
UCS. You determine the size of a torus by specifying its overall diameter or radius and the diameter or radius of the tube (the
circle being revolved).

Command Line

[Select object

Command: TORUS

[Specify center point or [3P/2P/Ttr]:
[Specify raidus or[Diameter]:

[Specify tube radius or [2Point/Diameter]:
Command:

To create a torus: Draw > Modeling>Torus Command line>TORUS
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1.Choose Draw > Modeling > Torus from the main menu.
2.5pecify the center of the whole torus.

3.Specify the radius or diameter of the whole torus.
4.Specify the radius or diameter of the body of the torus.

6.3.11. Pyramid

You can create a tetrahedron (three-sided pyramid) or a four-sided pyramid. The base of the pyramid is always parallel to the xy
plane of the current UCS. You determine the size of the pyramid by specifying the base points and either the apex, the corners
of the top surface, or the endpoints of the ridge.

To create a pyramid: Draw > Modeling>Pyramid  Command line>PYRAMID

1. Choose Draw > Modeling > Pyramid from the main menu.
2. Specify the first point for the base of the pyramid.

3. Specify the second and third points.

4. In the prompt box, choose Tetrahedron.

5. Specify the apex of the tetrahedron.

Command Line

Command: PYRAMID

4 sides Inscribed Circumscribed

Specify certer poirt of base or [Edge/Sides]:

(Specify base radius or [Inscribed] <32 94663

(Specify height or [2P/fewds endpoint/Top radius] <141.6194:
ICommand:

6.3.12. Wedge

You can create three dimensional wedges consisting of five surface planes. You determine the size of the wedge by either
specifying a second corner and the height; defining the wedge based on a cube having a given length; or specifying the length,
width, and height.

To create a wedge: Draw > Modeling>Wedge Command line>WEDGE

Command Line

[Specify height or [2Poirt] <55.1953>: *Cancel®
Command: WEDGE

(Specify first comer or [Center]

[Specify other comer or [Cube/Length]:
{Specify height or [2Poirt] <55.1953:>
Command:

1.Choose Draw > Modeling> Wedge from the main menu.
2.Specify the first corner of the base.
3.Specify the opposite corner of the base.4.Specify the height.

6.3.13. Solids Extrude

EXTRUDE command, extrudes the profiles of the selected object along the chosen path to create solids. The entities you can
extrude are planar 3D faces, closed polylines, polygons, circles, ellipses, closed splines, donuts, and regions. You cannot
extrude objects contained within a block or polylines that have crossing or self-intersecting segments.

To create an extruded solid: Draw > Modeling>Extrude ~ Command line>EXTRUDE

Command Line

1.Choose Draw >Modeling > Extrude from the main menu.

{Command: EXTRUDE
ument wireframe density: ISOLINES=4
(Select objects to extrude: 1found
Select objects to extrude
{Specify height of extrusion or [Direction/Path/Taper angle]
Command!

2.Select the object to extrude.
3.Select the extrusion path, or specify the height.
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6.3.14. Solids Revolve

REVOLVE command revolves a 2D object to the specified certain angle to form solids. The revolving axis can be X, Y axis of
current UCS as well as lines, polylines. Objects can be revolved are closed polylines, polygons, rectangles, circles, ellipses,
regions and so on.

To create a revolved solid: Draw > Modeling>Revolve ~ Command line>REVOLVE

1.Choose Draw > Modeling> Revolve from the main menu.
2.Select the object to revolve.

3.Do one of the following to define the axis of revolution:
-Specify a start point and an end point.

-Type 0 and press Enter to select an object.

-Type x and press Enter to select the x axis.

-Type y and press Enter to select the y axis.

4.Specify the angle of revolution.

‘Command Bar x

Command: REVOLVE -~
select objects:Find out 1, total 1

select objects:

Specify start point for axis of revolution o
r define axis by Object/Xaxis/Yaxis/Zaxis:
Specify endpoint of axis:

Specify angle of revolution <36@>:

Command : d *

6.3.15. Solid

With the Plane tool, you can draw rectangular, triangular, or quadrilateral areas filled with a solid color. The default method is to
specify the corners of the plane. After you specify the first two corners, the plane is displayed as you specify the remaining
corners. The program prompts you for the third point and then the fourth point.

® 92 soDOECRPE
=

Appearance -

To draw a quadrilateral plane: I i

Line
Ray

Constructien Line
Multiine

1.Choose Draw > Modeling >
Meshes> 2D Solid

2.5pecify the first, second, third and
fourth point. -
6.Finish the command, press Enter.

3D Polyline
Polygon
Rectangle

7
&
&
D Palyline
A
O
=
%, Helix
Loft
Section Plane Command Line
mmand: _SOLID

Donut Meshes » | 20 s0lid@) peciy frs point
Spline &h 3DFace ISpecify second point:

b pecify third point:
€ 3D Mesh peciy fourth point or <t >
Block B peciy third poirt

& Revolved Mesh peciy fourth point or <ext>:
»

Point £ Tabulated Mesh pecty tird paint
Hatch... peciy fourth point or <exi>
2y Ruled Wesh pecty third point =

mmand:

RG]

Setup

Ellipse »

s

Gradient.

Boundary
Region
Wipeout
Revision Cloud

oppBno

Text »

6.3.16. Flatshot
With FLATSHOT command you can create a 2D representation of all 3D objects based on the current view.The edges of all 3D

solids, surfaces, and meshes are projected line-of-sight onto a plane parallel to the viewing plane. The 2D representations of
these edges are inserted as a block on the XY plane of the UCS. This block can be exploded for additional changes.
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T Model / Layoust

Flatshot dialog box
Destination: Gontrols where the flattened representation is created.

Insert As New Block: Specifies to insert the flattened representation as a block in the current drawing.

Replace Existing Block:Replaces an existing block in the drawing with the
newly created block.

Select Block: Closes the dialog box temporarily while you select the block
you are replacing in the drawing. When you finish selecting the block, press
Enter to re-display the

Block Selected / No Block Selected:Indicates whether a block has been
selected.

Export to a File:Saves the block to an external file.

Foreground Lines:Contains controls for setting the color and linetype of lines
that are not obscured in the flattened view.

Color: Sets the color of lines that are not obscured in the flattened view.
Linetype:Sets the linetype of lines that are not obscured in the flattened view.
Obscured Lines: Controls whether lines that are obscured in the drawing are
displayed in the flattened view, and sets the color and linetype of these
obscured lines.

Show:Controls whether obscured lings are shown in the flattened
representation. When selected, the 2D flattened representation displays lines
hidden by other objects.

Color:Sets the color of lines that lie behind geometry in the flattened view.
Linetype:Sets the linetype of lines that lie behind geometry in the flattened
view.

Include Tangential Lines.Creates silhouette edges for curved surfaces.
Create:Creates the flattened view.

G FlatShot

Destination

@ Insert as new block
(") Replace existing block
® Select block

(No block selected)
() Export to afile
Filename and path:

C:\Users\asus\Documents\New Block.dw

Foreground lines

Color: M ByBlock

Linetype:

Obscured lines

Show
Color:

Linetype:

[ Include tangential edges

Continuous v

| |
&
‘ “

Continuous v

{ Create | [ Cancel | |

Help
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6.3.17. Creating Composite Solids

You can create composite three-dimensional solids by combining, subtracting, and finding the intersection of two or more
solids. With UNION command, you can combine the total volume of two or more solids or two or more regions into a

composite object.

To combine solids: Modify>Solid Editing>Union

1.Choose Modify>Solid Editing> Union from the main menu.
2.Select the objects to combine.

To subtract solids: Modify> Solid Editing> Subtract

1.Choose Modify>Solid Editing> Subtract from the main menu.

2.Select the objects to subtract from one another.

To intersect solids: Modify> Solid Editing>Intersect

1.Choose Modify > Solids Editing >Intersect from the main menu.
2.Select the objects to intersect.

6.4. Create Regions

Command line>UNION

Command Line

Command: Cancel™
Command: UNION

[Select object: 1found

[Select object: 1found, 2total
[Select object:

Command

Command line>SUBTRACT

Command Line

(Comman d: SUBTRACT

[Select solids, surfaces, and regions to subtract from
(Select object: 1found

ISelect object

LY

Command line>INTERSECT

mmmmm : INTERSECT

elect object: Specy opposite comer: 2found
elect object

ommand

You can convert a closed object into a two dimensional region. After you create a region, you can modify it using the various
three dimensional tools. You can create regions from closed objects, such as polylines, polygons, circles, ellipses, closed

splines, and donuts.
To create a region: Draw> Region  Command line>REGION

1.Choose Draw > Region from the main menu.
2.Select the objects to create the region and press Enter.

6.5. Create Revision Cloud

: ] F :

g g i

‘ 7777777 . 77777777 . “% 77777 and:
Region

Command Line

|-, Command: REGION

Select object: Specify opposite comer: 6 found
[Select object:

1 loop extracted.

Created 1region

Layer 0
Linetype Bylayer

REVCLOUD command, creates a polyline of sequential arcs to form a cloud-shaped object. You can convert objects, such as a
circle, ellipse, polyline, or spline, to a revision cloud. You can set the minimum and maximum default valugs for the arc lengths

of a revision cloud.

To create a revision cloud: Command line>REVCLOUD

1.After type REVCLOUD command, specify the first point.
2.Guide crosshairs along cloud path.
3.Revision cloud finished (the device point is near to first point).

‘Command Line

nnnnn d: REVCLOUD
Minimum arc length: Maximum arc lengih: Stye: Nomnal
[Arc length/Object /Style] <Object>
g cloud path

LWPolyline
Color Bylayer
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6.6. Create Break Line

Creates a polyline and inserts the breakline symbol. To use your own block for the breakline symbol, make sure that the block
contains two point objects on the Defpoints layer.

To create a revision cloud: Command line>BREAKLINE

1.Type BREAKLINE on the command line. g S0 D S PEG Yo
kline]:

first and second point for breakline. geo gonl Ervemnin@ Onacify [ocation
Command

for break symbol.
6.7. Create Wipeout

Wipeouts are created using existing polygons, closed zero-width polylines made up of only line segments, or new polylines

that you draw while using the WIPEOUT command. Also you could use a circle object to be wipeout or even you can pick up a

closed polyline object containing arcs. For example, you can explode and outline a block definition shape (car) then join it as

polyline then wipeout this polyline and group it with the block definition and place it on your drawing as showing below.

To draw a wipeout: Draw>Wipeout Command line>WIPEQUT

1.Choose Draw > Wipeout from the main menu.

2.Specify the start point and endpoint of each segment. D
]

Wipeout
Color Bylayer

Layer 0

mmand: WIPEOUT
lpecify first point or [Frames/Polyline] <Polyiine::

Linetype Bylayer

3.After specifying the last endpoint, press Enter.

indo}
ISpecfy next poirt or [Close/Undol:
[Command:

I
i
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6.8. Create table

The new Table function with TABLEDIT\TABLESTYLE\TABLEEXPORT command group are possible now to create and modify
table as well as to define the format of table. It is possible to export the table to CVS file and open it on Microsoft Excel.

To draw table: Draw>Table Command line>Table

6.8.1 Insert Table Dialog Box

Input TABLE command and press ENTER, and "Insert Table" dialog box will be open.

G Insent Table ==

Tatie Stve. Vaeton beraver

Tatloesanpie) »| @

| A3 = 7 15“_(¢_ 43D-CABA.78-45-10
|-

Table Style

Table Style: Choose a table style from within the current drawing from which to @

create a table. You can create a new table style by clicking the button next to the

/| Previ
drop-down list. B review
Preview: Controls whether a preview displays. If you start from an empty table, the Title
preview displays an example of the table style. He | Ha | Ha
ade|ade|ade
r r r
Insertion behavior
Insertion Behavior: Specifies the location of the table. © Specty window
Specify Insertion Point: Specifies the location of the upper-left corner of the @'um"cz'f:nzéﬂings S
table. You can use the pointing device or enter coordinate values at the m s > 625
Command prompt. If the table style sets the direction of the table to read from Toun Fow bt
the bottom up, the insertion point is the lower-left corner of the table. =L . ! )| Line6)
Specify Window: Specifies a size and a location for the table. You can use the
pointing device or enter coordinate values at the Command prompt. When this Column & row settings
Columns: Column width:
option is selected, the number of columns and rows and the column width and m = o &
row height depend on the size of the window and the column and row settings. i —
Rows: ow height:
g 1 = 6 = Line(s)
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Column & Row Settings: Set the number and size of columns and rows.
Columns Icon: Indicates columns.
Rows Icon: Indicates rows.

Columns: Specifies the number of columns. When the Specify Window
option is selected and you specify a column width, the Automatic option is
selected, and the number of columns is controlled by the width of the table.
If a table style containing a starting table has been specified, then you can
choose the number of additional columns you would like added to that
starting table.

Column Width: Specifies the width of the columns. When the Specify
Window option is selected and you specify the number of columns, the Auto
option is selected, and the column width is controlled by the width of the
table. The minimum column width is one character.

Rows: Specifies the number of rows. When the Specify Window option is
selected and you specify a row height, the Automatic option is selected, and
the number of rows is controlled by the height of the table. A table style with
a title row and a header row has a minimum of three rows. The minimum row
height is one line. If a table style containing a starting table has been
specified, then you can choose the number of additional data rows you
would like added to that starting table.

Row Height: Specifies the height of the rows in number of lines. The
height of a line is based on the text height and the cell margin, which are
both set in the table style. When the Specify Window option is selected
and you specify the number of rows, the Auto option is selected, and the
row height is controlled by the height of the table.

Insertion behavior
() Specify insertion point

Column & row settings
©@ Columns: Column width:
M s Automatic =
") Bows: Row height:
B |Automatic|= 8 = Linefs)
Insertion behavior
() Specify insertion point
@ Specify window
Column & row settings
@ Columns: Column width:
I & 2 Automatic -2
) Rows: Row height:
B |Automatic = 6 = Line(s)
Insertion behavior
() Specify insertion point
@ Specify window
Column & row settings
) Columns: @1} Column width:
[0 Automatic-= 635 =
") Rows: Row height:
B |Automatic 6 = Linefs)
Insertion behavior
(*) Specify insertion point
©) Specify window
Column & row settings
) Columns: @ i! Column width:
MM |Automatic= 635
@ Rows: Row height:
g 1 Automatic =-| Line(s)
Column & row settings
@ Columns: ~ Column width:
HII 1 Automatic -2
") Rows: ) Row height:
B Automatic|= B 2| Linefs)|

Set Cell Styles: For table styles that do not contain a starting table, specifies a cell style for rows in the new table.

First Row Cell Style: Specifies a cell style for the first row in the table. The
Title cell style is used by default.

Second Row Cell Style: Specifies a cell style for the second row in the
table. The Header cell style is used by default.

All Other Row Cell Styles: Specifies a cell style for all other rows in the
table. The Data cell style is used by default.

Set cell styles
First row cell style:

Second row cell style:

All other row cell styles:
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Cumrent

TableStyleSample1
Preview: TableStyleSample1

6.8.2.Table Style Dialog Box Styles:
Standard
Current Table Style: Displays the name of the table style that is
applied to tables you create.

Styles: Displays a list of table styles. The current style is
highlighted.

List: Controls the contents of the Styles list.

Preview:Displays a preview image of the style that is selected

TableStyleSample 1

Set Cument

o

DO 5

OO BB B
EeE B R N VK5 -3F

Com) Cre)

in the Styles list.

Set Current :Sets the table style selected in the Styles list as the current style. All new tables are created using this table style.
New: Displays the Create New Table Style dialog box, in which you can define new table styles.

Modify: Displays the Modify Table Style dialog box, in which you can modify table styles.

Delete: Deletes the table style selected in the Styles list. A style that is being used in the drawing cannot be deleted.

6.8.3.Create New Table Style Dialog Box

Specifies a name for the new table style and specifies the existing table style on which the new table style will be based.

New Style Name: Names the new table style.

Start With: Specifies an existing table style whose settings are the default
for the new table style.

Continue: Displays the New Table Style dialog box, in which you define
the new table style.

New Style Name:
Start With:
[Standard v] Help J

New Table Style: TableStyleSample2

6.8.4. New and Modify Table Style Dialog Boxes Stdcei E]
B =
General
Starting Table: Allows you to specify a table in your drawing to use as an example for Table direction: (up ~
Down

formatting this table style. Once you select a table, you can specify the structure and i p il

contents you want copied from that table to the table style. With the Remove Table icon,

you can remove a table from the current specified table style.

General Table Direction: Defines a new table style or modifies an existing table style. It

sets the direction of a table.

Down: The title row and the column heads row are at the top of the table.

Up: The title row and the column heads row are at the bottom of the table.

Preview: Displays an example of the effect of the current table style

. Cell styles —

SemngS SR ) ()

Cell Styles: Defines a new cell style or modifies an existing cell style. Data

You can create any number of cell styles. :'::de,

Create Cell Styles Button: Launches the Create New Cell Style dialog @

Create new cell styles

box. |Manager cell styles... ﬁ

Manage Cell Styles Button: Launches the Manage Cell Styles dialog box. ' Format: General E]
Type: Data v
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General Tab

Properties Cell styles

Fill Color: Specifies the background color of the cell.

|Header - @ '

Alignment: Sets justification and alignment for the text in the table I General IText | Borders

cell.

Format: Sets data type and formatting for the Data, Column Heading,
or Title rows in a table. Clicking this button displays the Table Cell
Format dialog box, where you can further define formatting options.
Type: Specifies the cell style as either a tag or data.

Margins

Horizontal: Sets the distance between the text or block in the cell and
the left and right cell borders.

Properties
Fill color: [l:] None v]
Alignment: [TC ']
Format: General D
Type: [Data ']
Margins
Horizontal: 15
Vertical: 15

[] Merge cells on row/column creation

Vertical: Sets the distance between the text or block in the cell and the T

Merge cells on row/column creation: Merges any new row or column
created with the current cell style into one cell. You can use this
option to create a title row at the top of your table

top and bottom cell borders. ‘

Text Tab

Text Style: Lists the available text styles.

Text Style Button: Displays the Text Style Dialog Box where you can create or
modify text styles.

Text Height: Sets the text height.

Text Golor: Specifies the color of the text. Choose Select Color at the bottom
of the list to display the Select Color dialog box.

Text Angle: Sets the text angle. The default text angle is 0 degrees. You can
enter any angle between -359 and +359 degrees.

Borders Tab

Lineweight: Sets the lineweight to be applied to the borders you specify by
clicking a border button. If you use a heavy lineweight, you may have to
increase the cell margins.

Linetype: Sets the linetype to be applied to the borders you specify. Choose
Other to load a custom linetype.

Color: Sets the color to be applied to the borders you specify by clicking a
border button.

Double Line: Displays table borders as double lines.

Spacing: Determines the spacing for double line borders.

o

g

[ ok ][ cancel | [ Hep
Cell styles
[Header v] @]
Generalf Text \ rders |
| S |
Properties
T s =
Text height: 45
Text angle: 0
Cell style preview

[ ok ][ camcel | [ Hep
Cell styles
[ox B B
| General | Text IiBOfﬂﬁS I
Properties
Linetype: ByBlock
coe
Double lines
Spacing: 1.125
() ) () (i) () () ()
Apply the selected properties to borders by clicking the
Cell style preview =
‘ o
=T
[ ok ][ cancel | [ Hep |
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7. Modify Objects

You can easily modify the size, shape, and location of objects. You can either, enter a command first and then select the
objects to modify, or you can select the objects first and then enter a command to modify them.

7.1. Remove Objects
You can use ERASE command to delete objects, whatever the methods you use to select objects. To restore the deleted objects,

use UNDO command. You can remove objects using one of the following methods: Delete objects with ERASE command, cut
the selected objects to the clipboard, or press DELETE to remove the selected objects.

7.2. Copy Objects

You can duplicate objects within the current drawing. The default method is to create a selection set and then specify a base
point, and a displacement point, for the copy. To copy objects at the specified distance, you can specify the distance directly
when the Ortho Mode or Polar Tracking is on.

Create only one copy of object one time:

1.Choose Modify > Copy from the main menu. e Cdc::

2.Select the objects, and then press Enter. ec abct: Sy cpposte caer: fund

3.0n the command line, type O (mOde). ety e poet oot e] <ot

4.0n the command line, type S (Single). — e o ok ot e dmerts ORTHO O
5.Specify the base and displacement point. e L

Create multiple copies for selected object one time:

1.Choose Modify > Copy from the main menu.

2.Select the objects, and then press Enter.

3.0n the command line, type O (mOde).

4.0n the command line, type M (Multiple).

5.Specify the base and displacement point of the first copy.
6.Specify the displacement point of the next copy.

7.To complete the command, press Enter.

Command Line

EpTory bovs ponor |
IEnter a copy mode op
'Specify base point or |
ret point as displacem
{Specify second point «
{Specify second point «

7.3. Mirror Objects

You can specify a baseline to create a mirror image using MIRROR command. The mirror image is symmetrical with the
original one. So if you want to create a symmetrical objects, you only need to draw a half one, then create a full one using
MIRROR command. Besides picking start and end point to define mirror axis, you can also directly select objects as mirror axis
like a line, polyline, a line of block or an external reference drawing.
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To mirror objects:

" Spely o pot it o [

1.Choose Modify > Mirror from the main menu.

O

(O O peec—

Command: *Cancel*

ICommand: MIRROR
(Select object: Specify opposite comer: 7 found

2.Select the object, and then press Enter. m m m /\/\ o 0"

3.Specify the first and second point of the mirror line.

ISpeciy first point of miror line:
Speciy second point of mior in

4.0n the command line, if you want to retain the original objects, type“N';'Jif you want to déléte fhé'lorigir%&f%m—ﬁwfﬁ.:

7.4. Offset an Object

You can use the offset to copy selected objects and align them offset to the original objects at a specified distance. You can
make offset objects using arcs, circles, ellipses, elliptical arcs, lines, two dimensional polylines, rays, and infinite lines.

To make an offset copy by specifying the distance:

1.Choose Modify > Offset from the main menu.

2.Specify the distance (select two points or enter a distance).
3.Select the object to offset.

4.Specify on which side of the object to place the parallel copy.
5.Press Enter to complete the command.

To make an offset copy passing through a point:

1.Choose Modify > Offset from the main menu. )
2.0n the command line, type T (Through). .
3.Select the object to offset.

4 Specify the point for the object to pass through.

5.Press Enter to complete the command.

7.5. Create an Array of Objects

Command: OFFSET

Parallel: [Through point]<Distance> <5»:3
Select objects:

[Both sides]<Side for parallel copy>:
Select objects:

Command: OFFSET
specify offset distance or [Through point]/<Distance>:T

Through point[More(M)]:M

Command :

New array options are available to create copies of objects arranged in rectangular, polar, or path pattern. The new array is as a
whole (dynamic block). It can be dynamically adjusted the number of ranks, spacing and other related parameters through

Ribbon Panel, Properties and Grip.

To create a rectangular array:

1.In “2D Drafting” workspace, click

“Home” > “Modify” > “Rectangular Array” in turn.

2. Select the object to be arrayed and press “ENTER”.
3. In the array preview, drag the grips to adjust the spacing and
number of rows and columns.

=
=
=)
=
<]
s
o
i
o
=
e
<
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You can also modify values in "Array" Ribbon .

To create a polar array:

1.In “2D Drafting” workspace, click
“Home” > “Modify” > “Polar Array” in turn.

2.Select objects to array.

3.Specify center point of array (array preview will be
showed).

4 Input “i” (items), and then input the number of items
to array.

5.Input “a” (angle), and then input the fill angle.

Array Polar

You can also select grips to edit array.

To create a path array

The best way to use Path Array is to create them at first.
And then you can use the tools or “Properties” of the
Ribbon to modify them.

1.In “2D Drafting” workspace, click
“Home” > “Modify” > “Path Array” in turn.

2.Select the object to array, and “ENTER”

3 Select an object (such as a line, a polyline, a 3D polyline,
a spline, a helix, an arc, a circle or an ellipse) to be as a
path to array.

4.Specify the way to distribute items along the path:

If you want to distribute items evenly throughout the path length, please click “Properties” panel in Ribbon > “Divide” in tumn. If
you want to distribute items at a specific distance, you can click “Properties” > “Measure” in turn.

5.Move the cursor along the path to adjust the items.

6.Press “ENTER” to finish Array.

=
=]
@©
a
>
©
<

7.6. Move Objects

You can move objects to a new place without changing the objects. You can perform MOVE command and then select object (1)
to move; specify a base point (2) and Displacement point (3). The object is moved from point 2 to the point 3.

To move entities:

Command Bar

OBIECT cormand: HOVE
1.Choose Modify > Move from the main menu. O oppecite. sormer:rind out 1, total 1
P Select objects: L
2.Select the objects, and then press Enter. = : Specify second point or <use First point ¢

‘Speciiy second point or <use first point as displacement>: Hl 9.7696] Hc 0"

3.Specify the base and displacement point.

OBJECT ;fz__
Q ; ‘E |specify stretch point or @] [36.9633] H <52° ‘
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To move an object using grips:

1.Select the object.
2.Click a grip to select it.

3.Drag the object to where you want to relocate it and press Click to release.

7.7. Rotate Objects

You can rotate the selected objects around a specified point. You can specify the rotated angle by specifying a point on the
drawing or entering the angle value directly. The direction that objects rotate depends on the value you enter is positive or

negative.
To rotate objects:

1.Choose Modify > Rotate from the main menu.
2.Select the objects, and then press Enter.
3.Specify the base point and rotation angle.

To rotate a selection set in reference to an Absolute Angle:

1.Choose Modify > Rotate from the main menu.
2.Select the objects, and then press Enter.
3.Specify the base point.

4.0n the command line, type R (Reference).
5.Specify the reference and new angle.

7.8. Align Objects

OBJECT

[Specify rotation angle o EI[IE [[<69° |

Command: ROTATE

select objects to rotate:

Opposite corner:Find out 2, total 2
Select objects to rotate:

Specify rotation angle or [Copy/Reference ] <@>:<Orthe off_
>

\
[New angle <0-: |[EEEIE <30 | &

Bar

You can align objects with another through move or rotation with ALIGN command.

To align and object to other as reference:

1.Choose Modify > Align from the main menu.
2.Select the object, and then press Enter.
3.Specify the first source point.

4 Specify the destination point.

finish the command.

7.9. Scale Objects

OBJECT

Kol

DESTINATIO
OBJECT

select objects to rotate:

Opposite corner:Find out 2, total 2
Select objects to rotate:

Specify the base point:

Specify the Reference angle <6@>:

Hew angle <@>:

Command Bar
Command: ALTIGN

Select objects:Find out 1, total 1
select objects:

Specify first source point:
Specify first destination point:

‘Command :

J.Press enter to

You can use SCALE command to scale the proportionality of the selected objects. You can type a scale factor or specify a base

point and distance to zoom objects. A scale factor that is greater than 1 enlarges the object; and a scale factor that is smaller

Command Bar

Cancel

‘Command: SCALE

Select objects:Find out 1, total 1

than 1 shrinks the object.

OBJECT
To scale a selection set by a scale factor: @

Select ohjects:
specify the base point:

Specify scale factor or [Copy/Reference] <2.5>:

[Specify scale factor or

B ol
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1.Choose Modify > Scale from the main menu.2.Select the objects, and then press Enter.
3.Specify the base point.
4 Specify the scale factor.

7.10. Lengthen Objects

You can change the length of entities or the included angle of arcs. The results are similar to extending and trimming.This
command does not affect the closed entities.

To change the length of an object by dragging: OBIECT
[New ster point forfine:

O @ New start point for line:

1.0n the command line type LENGTHEN.2.0n the

Command |In€, type DY (DYnamIC) Em:zg?do]ﬁelact objects to change>: -
LENGTHEN

389'60’[ the Ob]ec’[ you want to Change ;gi;tle:.g;:;ts[I;l;n:l::;égfi:aéxrd‘;??tf'mtal](SEIE(t objects to list lengthy:DY |§

4 Specify the new endpoint or included angle. Hew start point for Jine: e

7.11. Stretch Objects

When stretching objects, you have to specify a base point and displacement point. You should use crossing selection to select
the desired objects. With using grip edition, you can also stretch objects.

To stretch an object:

OBIJECT
1.Choose Modify > Stretch from the main menu. @ ‘O —

2.Select the objects using either a crossing window ora  ——— M- e
CrOSSIng polygon‘ and then press Enter g:i:z: zg:z:::to stretch by crossing-window or crossing-polygon... -

. . Opposite corner:Find out 3, total 3 b
SSpeCIfy the base p0|nt zggﬁyoig:?;m or [Displacement] <Displacement>: lt‘
4SpeCIfy the second pOint of diSplacement. |Specify second point or <use first point as displacement>: O v
To stretch an object using grips:
1.Select the object.
2.Click a grip to activate it.
3.Drag the grip.

4 Click to release.
Specify stretch point or
Base point | Copy | Undo | exit 4 b
7.12. Trim Objects
You can clip, or trim, objects so they end at one or
Commanline
more implied cutting edges defined by other objects. o ot s it o it
i i . . [Fence/Crossing/Project /Edge /eRase/Undo]
You can trim arcs, circles, lines, unclosed polylines, i e g o el
and rays. [ec bt o i st et etand o |7 |
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To trim an object:

1.Choose Modify > Trim from the main menu.

2.Select one or more cutting edges, and then press Enter.
3.Select the object to trim.

4 Press Enter to complete the command.

To trim several objects using the fence selection method:

1.Choose Modify > Trim from the main menu.

2.Select one or more cutting edges, and then press Enter.
3.0n the command line, type F (Fence).

4.Specify the first point of the fence.

5.Specify the second point of the fence.

6.Press Enter to complete the command.

7.13. Extend Objects

..............................

elect objects or <select all> -
elect object to tim or shiftselect to extend or
[Fence/Crossing/Project/Edge/eRase/Undo]: FENCE [

ecify next fence point or

€ »

You can extend objects so that they end at a boundary defined by other objects. You can extend arcs, lines, two-dimensional
polylines, and rays. Arcs, circles, ellipses, lines, splines, polylines, rays, infinite lines, and viewports on a Layout tab can act as

boundary edges.

To extend an object:

1.Choose Modify > Extend from the main menu.

2.Select one or more objects as boundary edges, and then press Enter.
3.Select the object to extend, and press Enter to finish the command.

To extend an object to an implied boundary:

1.Choose Modify > Extend from the main menu.

2.Select one or more boundary edges, and then press Enter.

3.0n the command line, type E (Edge).
4.0n the command line, type E (Extend).
5.Select the object to extend, and press Enter to finish.

To extend several objects using the fence selection method:

1.Choose Modify > Extend from the main menu.

2.Select one or more boundary edges, and then press Enter.

3.0n the command line, type F (Fence).
4.Specify the first and second point of the fence.
5.Press Enter to complete the command.

j——

[Fence/Crossing/Project/Edge./Unda]:
Select object to extend or shift-select to tim or
[Fence/Crossing/Project/Edge./Unda]:
[Fence/Crossing/Project/Edge

Undol]:

[Fence/Crossing/Project/Edge/Unda]: -
elect object to extend or shiftselect to tim or i
[Fence/Crossing/Project/Edge/Undo]: [l

[Fence/Crossing/Project/Ed =
e/Undo]: < [ D

elect objects or <select all>;
elect object to extend or shift-select to trim or
[Fence/Crossing/Project/Edge/Unda]: FENCE

pecify nexd fence point o
Unda]: ™
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7.14. Create Breaks

You can break arcs, circles, ellipses, lines, polylines, rays, and infinite lines. When breaking entities, you must specify two
points for the break. By default, the point you use to select the entity becomes the first break point; however, you can use the
first break point option to select a break point different from the one that selects the entity.

To break an object:

0
i
i

1.Choose Modify > Break from the main menu.
2.Select the object.

3.Specify the second break point. R
To select an object and then specify the two break points:
B e B e e el e
1.Choose Modify > Break from the main menu. o et e ot ST
. [Specify first break point
2.Select the object. oot condresk ot
Comman d:

3.0n the command line, type F (First point).
4.Specify the first and second break point.

60

7.15. Create Chamfers

You can connect two nonparallel objects by extending or trimming them and then joining them with a line to create a beveled
edge. You can chamfer lines, polylines, rays, and infinite lines. When creating a chamfer, you can specify how far to trim the
objects back from their intersection (distance distance method), or you can specify the length of the chamfer and the angle it
forms along the first object (distance angle method).

When chamfering a polyline, you can chamfer multiple segments between two selected polyling segments, or you can chamfer
the entire polyline.

To chamfer two objects using the distance-distance method: - - - -

1.Choose Modify > Chamfer from the main menu. s
H H Command: CHAMFER

20” the Command |Ine! type D (DIStance) "Trim" mode) Curent chamfer Dist1 = 20.0000, Dist2 = 20.0000

. . . (Select first line or [Undo,/Polyline//Distance/Angle/Trim/mEthod/Muttiple]: D
3.Specify the first chamfer distance. penty e oomer e 1000 15 ™

. . [Specify second chamfer distance <15.0000::
4.Spe(:|fy the second chamfer distance. ISelect first line or [Undo/Polyiine/Distance./Angle/Tim/mEthod Mukipie]

. . (Select second line or shift-select to apply comer: “Cancel™

5.Select the first object to chamfer. Command:

6.Select the second object to chamfer.

15

To chamfer two objects using the distance-angle method:

1.Choose Modify > Chamfer from the main menu.
2.0n the command line, type A (Angle).

3.Specify chamfer length on the first line. ety omi it 0
4.Specify chamfer angle from the first line.5.Select the first object to chamfer. ===

o
HAMFER

6.Select the second object to chamfer. o k) Langn = 15000 b - 20

iple]: ANGLE
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To chamfer selected vertices in a polyline:

1.Choose Modify > Chamfer from the main menu.
2.Select one polyline segment where you want to

mmand: “Cancel*
mmand: CHAMFER

"Trim" mode) Cument chamfer Dist1 = 50 0000, Dist2 = 50.0000

elect first line or [Ur y gle/Tr iple]: D
b . th h f LWroyline pecify first chamfer distance <50.0000>: 70
pecfy second chamfer distance <70.0000=: 70
egln e C am er 1 ¥ Colar Color150  Belect first line or [Undo/Polyline/Distance/Angle Trim/mEthod /Multiple]:
. (I J Layer 0 elect second line or shift-select to apply comer
3.Select the other polyline segment where you want ety Eytaser Fonmend

to end the chamfer.

To chamfer all vertices in a polyline: e e
i { ICommand: CHAMFER

P e . "Trim" mode} Cument chamfer Dist1 = 5.0000, Dist2 = 5.0000

i ISelect first line or [Undo./Polyline/Distance/Angle/ Trim/m Ethod/Mutiple]: D
[Specify first chamfer distance <5.00005 5

Specify second chamfer distance <5.0000>-

[Select first line or [Undo./Polyline/Distance/Angle /Trim/m Ethod/Muttiple]: P

;

1.Choose Modify > Chamfer from the main menu.

LWPalyline

2.0n the command line, type P (Polyline). L coor coriso [ Fret i pante
Layer 0 Command:

Linetype ByLayer

3.Select the polyline.

7.16. Create Fillets

You can create a fillet using FILLET command. This command can apply to the objects such as arcs, circles, ellipses, lines,
polylines, rays, splines or construction lines. A fillet is an arc that connects two objects smoothly and has a specified radius.
An inside corner is called a fillet; an outside corner is called a round. Before creating fillets, you should ensure the distance
between each vertex is long enough to accommodate the fillet radius in order to insert a fillet arc. When the fillet radius is set to
0, no fillet arcs are inserted. If two polyline segments are separated by one arc segments, system deletes this arc segment and
extends the lines to intersect with each other.

To fillet two objects:

1.Choose Modify > Fillet from the main menu. L
2.0n the command line, type R (Radius). - W d@ﬁ:‘:ﬁ:&hﬁd[z;:;&m‘:::{;dﬁmm/wkip\el: RADILS
: pecify fillet radius <0.0000>: 30
3 Specify the fillet radius. e i P e T
. . mmand
4 Select the first and second object. Connard

To fillet an entire polyline:

ICommand: FILLET
. o [Curent settings: Mode = Tim. Radus =300000
1.Choose Modify > Fillet from the main menu. P e i et oo s LR
E £ elect first uh]ad'ur [Undo/Polyline /Radius,/ Trim/Muttiple]: 9
2.0n the command line, type P (Polyline). bom Expece = pory o o/t s EOX P WFolgon otk UndlFe
H byline./Radius,/ Trim,/Muttiple
388|6C’[ the p0|y|lne ﬁgg:gr;l‘:n};%}r[En‘z:/PnM\ne/Rad\usﬁnm/Muhlp\e] P
- |7 lines were filsted
ICommand

To fillet selected vertices in a polyline:

1.Choose Modify > Fillet from the main menu.

mmand: FILLET

2.Select one polyline segment where you want to begin | .-‘: \‘; e stings: ode = Ti. Fadus =30.0000

elect first object or [Undo/Polyline/Radius/Trim/Muliple]: RADIUS
peciy filet radius <30.00005: 15

the f|”et “". elect first object or [Undo/Polyline/Radius/Trim/Muliple]:

‘,‘ ‘}1‘ " [Select second object or shiftselect to apply comer
3.Select the other polyling segment where you want to L ety come [ ]
end the fillet.
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7.16.1.Trim and Extend Filleted Objects J
While performing fillet, you can select Trim option to decide whether the

selected edges are extended to the endpoints of fillet arcs. By default, all FILLET>TRIM>TRIM FILLET>TRIM>NO TRIM

objects except of circles, ellipses, closed polylines and splines are trimmed

or extended when performing filleting.

PLINE & LINE Linetype Bylayer PL'{_INLI?_E_AI_ IE{:)NE

7.16. 2.Fillet Line and Polyline Combinations

If the objects to fillet are a line and a polyline, the line or its extension must
be intersecting with one of the polyline segments. With Trim option on, the filleted objects join with the filleted arc to form a
new polyline.

7.16. 3.Fillet Parallel Lines )

You can fillet parallel lines, rays, and infinite lines. The first entity must be a line or
ray, the second entity can be a line, ray, or infinite line. The diameter of the fillet arc
is always equal to the distance between the parallel entities. The current fillet radius is ignored.

PARALLEL PARALLEL
LINES LINES FILLETED

7.16. 4.Invert Fillet <
Il i<t it object o

Invert Fillet has a very wide range of usage particularly in construction and L
furniture industry. The FILLET command now offers a new option called Invert. You can create a reverse fillet by this option.

7.17. Disassociate Compound Objects

You can convert a complex entity, such as a block or polyline, from a single entity into its component parts. Exploding a
polyline, rectangle, donut, polygon, dimension, or leader reduces it to a collection of individual line and arc entities that you
can then modify individually. Blocks are converted to the individual entities, possibly including other, nested blocks that
composed the original entity.

4 Drawingldwg X .

%M/f O

EXPLODE EXPLODE EXPLODE EXPLODE
PLINES DIMENSIONS HATCHES BLOCK & ATTRIBUTES

N =0 /) BRI

1 Drawingl.dwg X g

ﬁ[\/\/m////%ﬁ%ﬂ

EXPLODE EXPLODE EXPLODE EXPLODE
PLINES DIMENSIONS HATCHES BLOCK & ATTRIBUTES
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With the following exceptions, exploding an entity usually has no visible effect on a drawing:

-If the original polyline had a width, the width information is lost when you explode it.

-If you explode a block containing attributes, the attributes are lost, but the original attribute definitions are retained.

-Golors, linetypes, lineweights, and print styles assigned BYBLOCK may be different after exploding an entity, because they will
adopt the default color, linetype, lineweight, and print style until inserted into another block.

7.18. Modify Polylines

Objects such as rectangles, polygons, and donuts, as well as three dimensional objects such as pyramids, cylinders, and
spheres, are all editable polylines. To modify a polyline, perform PEDIT command. The available options vary depending on
whether the selected polyline is a two dimensional or three dimensional object. If the selected object is not a polyline, the Edit
Polyline tool provides the option of turning it into one. You can convert only arcs and lines into polylines. If several arcs or lines
are joined endpoint to endpoint, they can all be selected and turned into one polyline.

Properties

Mo selection | |

General -

Caolor M ByLayer
Layer 0

Linetype — ByLayer
Linetype scale |1

Linewsight | — Bylayer

Thickness 0

4 Drawingldwg x

= Visuslizstion = CLOSED PLINE OPEN PLINE WIDTH PLINE

Materials Bylayer
Shadow displa..| Shadow and receiy

View o

CerterX  |36701913
Center Y 352.2038 {
Certerz |0 )
Height 636622

Wicth 169.0509 ’ ‘ LwPolyline
¥

o skeonon e PLINE TO SPLINE PLINE VERTEX | | woor oo
UCSiconato..|Yes Lﬁ Lmetype GyLayer
*

Layer 0

UCS per view _| Yes

UCS Name '« 4 v v " Model /Layoutl / LayoutZ

7.19. Modify Multilines

You can use the methods such as common editing commands, a multiling editing command and multiline styles to edit
multilines or their elements. You can use MLEDIT command to add or delete vertices for a multiline, to control the way two
multilings intersected (cross and T shape that can be closed, open or merged), to add multiline style or set multilines from the
existing multiline style, such as the number of elements, color, linetype, lineweight and the offset of each element.

G Multilines Edit Tools ===

To use a tool, click on the icon. Object selection must be peformed after the tocl has been
selected

Mutiines Edt Tools:

o [+ —
5e i L [l
Closed Cross Closed Tee Comer Joirt Cut Single. D
= = ] [ =

T - i I
Open Cross. Open Tee Add Venex Cu A
= [F M [ L=
= - i I
Merged Cross. Merged Tee Dedete Vertex Weld Al

Jose Help
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7.20. Clip

The new CLIP command clips a block, external reference, image, viewport, and underlay (PDF or DGN) to a specified boundary. It can be
used to replace XCLIP IMAGECLIP VPCLIP PDFCLIP DGNCLIP commands.

7.21. Add selected

You can use this function to create a new object of the same type and properties (such as colors, layers, lineweight, linetype
and scale factor) as selected object but with different geometric values.

For example, creating objects based on selected circles uses the general properties of the circle, such as colors and layers, but
prompt you to enter the center and radius of the new circle.

Steps to use ADDSELECTED

1. Select the object which the new object bases on.

2. Right-click and select "Add Selected".

3. Create an object similar to the selected object according to the prompts.

7.22. Multiple

Executes a command repetitively, avoiding press enter or space bar key. Because this command only repeats command names,
all parameters must be specified each time. If we want to draw more than one circle, you can enter MULTIPLE, knock down
“ENTER”, and then enter the CIRCLE, “ENTER”, you can draw a circle without the need to press the call to repeat the circle of
the order in the process.

7.23. Set by layer

Changes the property overrides of the selected objects to ByLayer including color, linetype, lineweight, and materials.
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8. Notes and Labels

8.1. Create Text

Create text, multiline text (mtext) and text that includes one or more leader lines.

8.1.1. Single-Line Text

You can use TEXT command to create a single or multiling text. Each line text is an independent object which can be modified.
Before typing text, you can specify the text style and the way to align at the prompt of creating text.

Press ENTER if you have typed some characters, and then the command line prompts to input characters for the next row of text.
While creating single line text, you are also enabled to extend or compress certain single line text object in specified space to
meet with your need by means of selecting Align or Fit option from the TEXT command line prompt.

To create text:

1.Choose Draw > Text > Single Line Text from the main menu.
2.Specify the start point for the text.

3.Specify the height of the text.

4.Specify the text rotation angle.

5.Type the text, and then press Enter at the end of each new line.
6.To complete the command, press Enter again.

To specify the line text alignment:

1.Choose Draw > Text > Single Line Text from the main menu.

2.0n the command line, type J (Justify) and press ENTER.

3.Type an alignment option BR to align text at its bottom-right comer.
4.Type the text, and then press Enter at the end of each new line.

5.To complete the command, press Enter again.

8.1.2. Multiline Text

Multiline text consists of one or more lines of text or paragraphs that fit within
a boundary width that you specify. When you create multiline text, you first
determine the paragraph's boundary width by specifying the opposite corners
of a rectangle. The multiline text automatically wraps so that it fits within this
rectangle. After defining the text frame, the system opens the In-Place Text
Editor, which is comprised of a text frame and the Text Formatting toolbar.
You can type text in the text frame and change the style from the Text
Formatting toolbar.

Command: TEXT

Current texd style: "Standand” Teod height: 8.3532 Annotative: No
\Specify start point of text or [Justify/Style]:

ISpecify height <8.3532>: &

Specify rotation angle of texd <0

F IR Pl
=]
‘Command Line
[Specfy start poirt of text or Pustfy/Style]: JUSTIFY
Erter an option [Align/Fit/Certer/Midde/Right/TL/TC/TR/ML/MC/WR/BL/BC/ER]: BR

|Specty bottomight poirt of text
{Specify height <5>:
(Specify rotation angle of text <0>

|El IL4>|

Ultiline
Text sample

]

Command Line

Command: MTEXT

Current texd style: "Standard” Text height: 5 Annotative: No

(Specify first comer poirt:

{Specify opposite comer or [Height/Justification/Linespacing/Rotation/Style/ Widt
h/Column]
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To create multiline text;

1.Choose Draw > Text > Multiline Text from the main menu.
2.Select the first and second corner of the text area.

3.In the Multiline Text window, type the text you want.

4.To create paragraphs, press Enter and continue typing.

Remark: Other text features please refer to the express tool guide.

On the toolbar, make format changes as follows:

1.To change the font of the selected text, select a font
from the list.

“|| sa s | @~ a,v:|a.n

“B /UG oot WRs

- =] ox|

2.To change the height of the selected text, enter a new
value in the Height box.3.To apply color to the selected
text, choose a color from the Color list.

4.Click OK on the toolbar or Press <Ctrl + Enter>

Multi
Text sample

Justify Multiline Text: You can specify the attachment point at the top left, top Text Farmatting

center, top right, middle left, middle center, middle right, bottom left, bottom IZ""TE‘ METES ']"‘ :

center, or bottom right. The multiline text can flow left to right, right to left, top to o — = = |

bottom, or bottom to top. MULTILINE
g

Format Characters within Multiline Text: During creating multiline text, you can

assign a new value to the selected objects to overlap the default setting. You can

specify underlines, bold, color and fonts for a single or multiple characters, or
different text height.

Indent Multiline Text and Use Tabs: You can control the appearance of text objects

[x] o e -
and create a list by specifying the tap stops and indenting text. The arrowheads MUL TILINE
on the ruler are used to define the indent of text (first line and paragraph). 5
Specify the Line Spacing: The line spacing of multiline texts is the distance
between the baseline of one line of text and the baseline of the next line of text. [Sadws < [0mnioe Jos -B 1
You can right-click in the textbox and choose Paragraph to specify the desired —
line space when the cursor stays on the text frame. MULTILINE —

SPACING

Create Stacked Characters: Stacked text is text or fraction applied to mark
tolerance or measure units. Before creating stacked text, you have to use special

characters to indicate the stacked place for the selected text. The following

! <1>|

contents present the special characters and illustrate how to create stacked text:

Stacked 174
Stacked 2111
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-Slash (/): Stacks text vertically and separates them with a horizontal line.
-Pound sign (#): Stacks text diagonally and separates them with a diagonal line.-Carat (~ ): Creates a tolerance stack, which is
stacked vertically as well as not separated by a line. You can also use Stack button on the toolbar to create stacked text.

8.2. Work with Text Styles

The text style is applied to the text objects. You can use text style to control the text font, size, angle, direction and other
features. By default, the current text style is STANDARD, and you have to make other text styles current when you want to apply
them. The STANDARD text style has the following default properties:

To create a text style:

1.Choose Format > Text Style from the main menu.
2.Click New, type a new text style name, and then
click OK.

3.Under Text Measurements, specify the Text Height,
Width Factor, and Oblique Angle.

4.Under Text Font, select the name, style, you want
to use.

5.Click Apply, and then click OK.

8.3. Create Leader

8.3.1. Leaders

f -
G Text Style —
Current test style: Standard
Styles:
Font
‘!E\-"ate Fort Name Fort Style: | Set Curert |
olandar
L O T R—
Use Big Font
o
(| Size
Annotative Height
[ ] Match text 0.0000
orentation to layout
Al styles
[ '] Cument Style Name
Upside down Width Factor:
1.0000
A || Backward:
| a BbCC : Oblique Angle:
[ Vertical 0
"oy | [ e | [ Fen |
-
G Text Style
Cumrent text style:  Style 1
Styles:
Fort
A Q”"f‘g ) Font Name: Fori Style:
anda
Sy (e P WTBod_~]  [Ba S e
[[]Use Big Font —
| Size -
[C] Annotative Height
[] Match text 20000
orientation to layout
- Y) Cument Style Name
Upside down Width Factor:
2.0000
ABbe2 7] Backward:
I aBbca e Oblique Angle:
[ Vertical ap
[Cmmy | [ oo | [ b

A leader is a line or spline with arrowhead at one end, and annotations
(Mtext, blocks as well as tolerance) at the other end. Generally, you
place an arrowhead at the first point. An annotation, created as
dimension text, is placed immediately adjacent to the last point.

| LEADER

Command: LEADER

Specify leader start poirt:

Specify next point:

Specify nexd point or [Annctation/Format/Undo] <Annctation:>:
(Specify next point or [Annctation/Format/Unda] <Annctation::
Specify next point or [Annctation/Format/Undo] <Annctation>: <DRTHO Onz
Specify nexd point or [Annotation./Format/Undo] <Annotation::
Specify next point or [Annotation/Format/Undo] <Annotation::
{Specify nexd point or [Annctation/Format/Undo] <Annctation::
Enter first line of annotation text or <options>: LEADER
Command:
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To create a leader and an annotation:

1.Choose Dimension > Leader from the main menu.

2.Specify the starting point of the leader.

3.Specify the endpoint of the leader line segment.

4.Specify additional leader line segment endpoints.

5.After you specify the last endpoint, press Enter.

6.Type the annotation, and press Enter to enter the next line of annotation text.
7.Press ENTER to complete the command.

8.3.2.Mleader

Multileader is used to attach annotation to multiple leader lines. Multileader could be used to give additional information or
special instruction in a point or specific area on your drawing .It also has more capabilities like using multiling text or blocks as
leader content in our drawing. This version supports the complete multileader set options like Add Leader, Remove Leader,
Align and Collect.

8.4. Modify Text

8.4.1. Change Text

All of text objects can be moved, rotated, deleted and copied, just as like other objects. You can change the properties at the
Properties panel. You have two methods to modify single-line text:

-To modify only the content of text, use DDEDIT command.
-To change text style, location, size and content, use PROPERTIES command to open Properties palette, from which, you can
make the relevant settings.
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To edit single or multiline text:

1.Type DDEDIT and then press Enter.
2.Select the single line or multiline text.

3.If select the single line text, the Edit Text box will pop up, edit the text and then press Enter.
4 If select the multiline text, the In-Place Text Editor will pop, edit the text according as you need.

Text Formatting

[ Stendard = | @Arial Unicode MS S *B [ Ugwv v & HR - |[=] ok | @
E-|s|== gliEr|al@a| @ oP  [H -] JH o ]
’Woally
[Select an annotation object or [Undol:
[Select an annotation object or [Unde]: "Cancel”
Command: DDEDIT
Select an annotation object or [Undal]:
To change single or multiline text properties: Medifl "
- i
. . ™ . & Mtext Edit...
1.Select a single line or multiline text object.
Clipboard
2 Right-click the selected object and then click Properties on the shortcut menu. A
. , & Move
3.In the Properties palette, enter any new text in the Text Contents, and then change @ Copy Selecion
. . . . b Scale
formatting and other properties as needed.4.You can also do double-click on the multiline O Rotte
Draw Order
text to open the In-Place Text Editor, from which, you can modify the contents and formats of B Growp
Deselect All
teXt- [# Quick Select..
@  QuickCalc
@ Find...
Popees w
[ -]

Contents MODIFY

Style NEW STYLE SAMPLE
Center -

Height

k]

Rotation

Width factor

Obliquing 0
MODIFY e ow
= Text alignment Y 2487.7803
Text alignment Z 0

Paosttion X

Posttion Y

Postion Z

Upside down

| Backward

propettes %
Do [ ] [z[&[E

Hypeink.

Conterts \prm 10 @Arial Unicode MSb)
Shyle Standard

Justy MC

Direction By syle

Text height

Line space factor

Line space distance

Line space siyle

Background mask

Defined with

Annotative

Defined height

11379
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9. Dimensions and Tolerances

Dimensions indicate the measurement values of objects (e.g. length or width), 3 1
distance or angles among objects, or the distance between feature point and the \ /
specified origin. You can create five basic types of dimensions: linear, angular, radial, 28

diametral and ordinate. Dimensions have several distinct elements: dimension text,
dimension lines, arrowheads, and extension lines.

1.Dimension text: A character string that usually indicates the measurement value, 4

includes prefixes, suffixes, tolerances, etc.2.Dimension line: Indicates the direction and extent of a dimension. For linear
dimensions, it displays as a line, for angular dimensions, it displays as an arc segment. 3.Arrowhead: Usually displayed at both
end of the dimension line. You can specify various sizes and shapes for arrowheads or tick marks. 4.Extension lines: Extend
from the object to the dimension line, in order to define dimension ranges.

9.1. Create Dimensions

You can create dimensions by selecting the entity to dimension and specifying the dimension line location, or by specifying the
extension line origins and the dimension line location.

9.1.1. Horizontal and Vertical Dimensions

As you create linear dimensions, the system automatically applies a horizontal or ||
vertical dimension depending on the specified extension line origins or the ﬂ—‘Fq - |

location where you select an object. However, you can create a dimension by F—Ujl —H

Vertical

specifying it be horizontal or vertical. 60

Horizontal

To create a horizontal or vertical dimension:

133

0 L
1.Choose Dimension > Linear from the main menu.

2.Press Enter, and then select the object to dimension. Or, you can specify the first and second extension line origins.
3.Specify the dimension line location.

9.1.2. Create Aligned Dimensions

In the aligned dimensions, the dimension line is parallel to the line passing
through the extension line origins. The aligned dimension is also parallel to the
objects you specify. The system creates the extension lines automatically.

To create an aligned dimension: \

1.Choose Dimension > Aligned from the main menu.
2.Press Enter, and then select the object to dimension. Or, you can specify the first and second extension line origins.
3.Specify the dimension line location.
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9.1.3. Create Baseline and Continued Dimensions

Both baseline and continued dimensions are multiple linear dimensions. Baseling dimensions are measured from the dame
baseline and continued dimensions are placed end to end. Before creating either baseline or continued dimension, you have to

create a linear, aligned, or angular dimension.

To create a linear baseline dimension:

1.Choose Dimension > Baseline from the main menu.

2.Specify a second extension line origin3.Select the next extension line origin.
4.Continue selecting extension line origins as required.

5.To end the command, press Enter twice.

To create a linear continued dimension:

1.Choose Dimension > Continue from the main menu.

2.To select a starting dimension, press Enter.

3.Select the next extension line origin, and then press Enter. Or press Enter, and
then select an existing dimension to continue.5.To add continued dimensions,
continue selecting extension line origins.

6.To end the command, press Enter twice.

9.1.4. Create Rotated Dimensions

You can create rotated dimensions at a rotated angle you specify using DIMLINEAR
Rotated option. An example of a rotated dimension is shown in the following illustration.
In this illustration, the specified angle of the rotated dimension is equal to the angle of the slot.

9.1.5. Create Angular Dimensions

60
40 C
B
20
A
20 17 18
A B C
O

Angular dimensions are used to measure the angle between lines or three points. You can dimension objects including circles,
arcs, and lines. When you create the angular dimension, you can modify the text contend and alignment before placing the

dimension line.

To dimension an angle between two lines:

1.Choose Dimension > Angular from the main menu.
2.Select one line.

3.Select the other line.

4.Specify the dimension line location.

97°
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To dimension an angle encompassed by an arc: 161°

1.Choose Dimension > Angular from the main menu.
2.5elect the arc.
3.Specify the dimension arc location.

9.1.6. Create Radial Dimensions

You can create radial dimensions for circles or arcs to measure their radial. The radial r{)f
dimension is a line with an arrowhead that points to a circle or arc. <
To create a radial dimension:

1.Choose Dimension > Radius from the main menu.

2.Select the arc or circle.

3.Specify the dimension line location.

9.1.7. Jogged Dimension

Jogged dimension is namely jogged radius dimension, which is also called "scaled radius dimension". User can specify center
position to place the origin of dimension for replacing center point of circle or arc within radius dimension. DIMJOGGED

command is useful for creating dimensions in case that the center of circle or arc to be dimensioned is located outside the
layout and can't be displayed in its actual position either.

To create a jogged radius dimension;
1.Choose Dimension > Jogged from the main menu.

. Q
2.Select a circle or an arc. Q_’lx
3.Select center position as the dimension origin.
4.Specify a point to position the jog symbol.

9.1.8. Create Diameter Dimensions
You can create diameter dimensions for circles or arcs to measure their diameters. Creating diameter dimensions resembles

creating radial dimensions. You can create various diameter dimensions based on the location and size of circles or arc, and the
settings of the dimension style.

To create a diameter dimension:
@ad
1.Choose Dimension > Diameter from the main menu.
2.Select the arc or circle.
3.Specify the dimension line location.
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9.1.9. Create Ordinate Dimensions

Ordinate dimensions are used to measure the perpendicular distance from an origin point called the datum to a feature, such as
a hole in a part. Ordinate dimensions are comprised of a leader ling with an X or Y value, and leaders are drawn along the
orthographic direction at the current UCS.

j : ﬁ :
To create an ordinate dimension: i I v

) ) . . 1733,84 ‘ " \
1.Choose Dimension > Ordinate from the main menu. 1726,27 ‘ ‘ + A
2.Select the point for an ordinate dimension. mssr |~ [T ’ |
3.Specify the ordinate leader endpoint. 170ede s
9.1.10. Create Quick Dimension
Creates or edits a series of dimensions quickly by typing QDIM command.
To create a quick dimension: 20 17 18
1.Choose Dimension > Quick Dimension from the main menu.
2.Select the geometry to dimension, and then press Enter. a
3.0n the command line, it will display "Specify dimension line position, r)
or[Continuous/Staggered/Baseline/Ordinate/Radius/Diameter/datumPoint

/Edit/seTtings] <Continuous>:".You can perform the operation as
desired. The default is Continuous.

9.1.11. Create Arc Length Dimension

Arc length dimension is available for measuring the arc length of arc or polyline arc segment. GstarCAD creates arc length
dimension by specifying extension ling position directly after selecting arc by default. And use an arc symbol as arc length

P

dimension, which is differing from linear dimension and angular dimension. 40

To create an arc length dimension:

1.Choose Dimension > Arc Length from the main menu. ;/\4

2.Select an arc or polyline arc segment.
3.Specify a point to position the arc length dimension.

9.2. Use Dimension Styles

You can control the appearance of dimensions by changing settings to help maintain dimensioning standards, you can store
these settings in dimension styles.
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9.2.1. Dimension Styles

You can create, save, restore, and delete named dimension styles. Dimension styles provide a way for you to change various

settings that control the appearance of dimensions. You can change the following settings:

-Extension lines, dimension lines, arrowheads, center marks or lines, and the offsets between them.
-The positioning of the parts of the dimension in relation to one another and the orientation of the dimension text.
-The content and appearance of the dimension text and units of the dimension value.

To create a dimension style:

1.Choose Dimension > Style from the main menu.
2.In the Dimension Style Manager dialog box, click New.

3.Type the name of the new dimension style, and choose which
style started with and what kind of dimension used for. Then click

Continue.

5.In the New Dimension Style dialog box, change the dimension

settings as necessary. Repeat this step for each tab, as
needed.6.To end the command, click OK.

G New Dimension Style: new dim style

Lines | Symbols and Arows | Text | Adjust | Pimary Units | Atemate Unts | Tolerance | |

Dimension Lines
Calor: MEyBiock =

Linetype:

Lineweight
Extend beyond ticks
Bassline spacing: 375
[ Dim line: 1

Suppress: [] Dim line 2

Exdension lines

Color: M ByBlock

Linetype ext ling 1 ByBlock -

Linetype ext fine 2.

ByBlock

2
2
%
‘

Linewezight:

Suppress: [CBtine 1 [JEdine2

To rename a dimension style:

1.Choose Dimension > Style from the main menu.2.In the
Styles list do one of the following:

-Double click the required style.

-Right click on the required style name, and then choose
Rename.3.Type the new name.

4.Click Close to exit.

G Dimension Style Manager =
Cument Dim Style: 1S0-25
Styles Preview of: 150-25
!
Annoty™ Current
A 150-2 G Create New Dimension Style ﬂ =
Stand =
New S Name ==
[Copy of 150 29] Continue fody
[150-25 -
- mpare...
[ Annotative ;]D
Use for:
List: [NI dimensions ']
Al styles
Dont list styles in Xrefs
s
==
14,41
0|
i &
2 O)
4
&
Extend beyond dim lines; 125
Offset from arigin 0625 =
[ Fixed length extension lines
Length: 1
0K | [ Cancel | [ Heb
r N
G Dimension Style Manager =5
Curent Dim Style: 150-25
Siyles: Preview of: Standard
A Annotative Set Curent
10-25
omem | ~fums

Delete

Dont list styles in Xrefs

PR
=i z0z08 Qveride...
ISP

RO.6045

Lt Desciiption
150-25 + Atemate precision = 2, Alemate
ratio factor = 254000, Atemate tolerance
precision = 2. Aowhead size = 0.1800,

=
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To delete a named dimension style

1.Choose Dimension > Style from the main menu.
2.In the Styles list, right click on the required style name, and then
choose Delete.3.Click Close to close.

To display information about the current style:
1.Choose Dimension > Style from the main menu.

2.In the Dimension Style Manager dialog box, click Compare.
3.In the Compare Dimension Style dialog box, choose the same

dimension style from the Compare and With pulldown list. All properties

for specified dimension style will be displayed.
4.1f you want to know the different information between two styles,

choose one style in the Compare box, choose the other in the With box,

and then you will see difference in the following tab.

5.Click Close to close.

9.2.2. Modify Dimension Lines

On the Line tab of the Modify Dimension Style dialog box, you can
set the color of dimension lines, lineweight, ticks beyond extend
line, baseline spacing, and visibility.

9.2.3. Modify Extension Lines

Extension lines have the following properties: color, lineweight,
distance beyond extension lines, offset from start of extension lines,
and visibility. You can set these properties on the Line tab of the
Modify Dimension Style box:

-The distance beyond extension lings means that how far the
extension lines extend beyond the dimension line.

-Start offset is the distance between the extension line origin and the
start of the extension line, also called extension origin offset.

9.2.4.Choose Dimension Arrowheads

You can control the appearance and size of arrowheads or hook
marks placed at the ends of dimension lines. You can specify
different arrowheads for both ends of a dimension or leader lines.
The First arrow is toward the first extension line; The Second arrow
is toward the second extension line.

(& Dimension Style Manager

Cument Dim Style: 150-25

Stvles Preview of: Standard

A Annotative Set Curent
1S0-25
Standarg New..
Set Current LoLs3
Rename ; /\ Body.
955
Delete 20208 [ .
) T
RO.8045
List Description
150-25 + Attemate precision = 2, Atemate
Ees ratio factor = . Atemate tolerance

precision = 2, Amowhead size = 0.1800,

Dont st styles in Xrefs

(& Compare Dimension Styles @
Compare: [Standard VI
With: [NEW STYLE -]
gcad found 4 differences:
Description ariable Standard ~ MEW STYLE
Color of dimension line DIMCLRD  ByBlock Blue
Dim line linetype DIMLTYFE BYBLOCK Continuous
Dim line lineweight DIMLWD -2 35
Ext line color DIMCLRE  ByBlock  Green
G Modify Dimension Style: NEW STYLE =)
Lines | Symbols and Arows | Text | Adust | Pimary Units | Atemate Lints | Tolerance |
Dimension Lines
10159
Linetype: Continuous  ~
2.0208
Extend beyond ticks 0
60"
Baseline spacing 032
RO.2045
Suppress [IDmine1 [ Dimline 2
BExtension lines
Cobr Ecendbeyenddmines: 018
— i
Offset from origin: 00625 =
P
[ Fixed length extension lines
Linewsight: ByBlock =
Length 1
Suppress: [ Extline 1 [[Edline 2
OK | [ Concel | [ Heb
G Modify Dimension Style: NEW STYLE ==
Symbols and Arows | Text | Adjust | Frimary Units | Atemate Units | Tolerancs |
Amows
First
[BiCiosed iled - 10159
Second
[BCiosed fled - 11955
Leader: l 20208
[EiCiosed iled - e >
FrrocEs RO.2045
018
Center marks e
- @ Preceding dimension text
© None £ oo b ot
©) Above dimension
© Mark 009 £
©) None
© Line
Radius jog dimension
Dimension Break Jog angle: a5
Break size Linearjog dimension
375 Jog height factor:
15 2/ - Tex height
OK | [ Cancel | [ Heo
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To choose an arrowhead:

1.Choose Dimension > Style from the main menu.

2.In the Dimension Style Manager dialog box, select the style you want to change and click Modify button.

3.In the Modify Dimension Style dialog box, click the Symbols and Arrows tab.
4. Make your selections under the Arrowheads.
5.Click OK and then choose CLOSE to exit.

9.2.5. Fit Dimension Text within Extension Lines

G Modify Dimension Style: NEW STYLE

When there is no enough space between extension lines to accept

| Lines | Symbols and Amows | Tet | Adust | Primary Unks | Atemate Unis | Tolerance |

both of dimension text and arrowheads, you have to adjust one or
both of their placement. By default, the system fits them best
depending on the available space. You can specify other methods
to place them on the Adjust tab of the Modify Dimension Style
dialog box.

Fit options

move outside the extension lines is:

@ Efther text or amows (best fit)

©) Arows

() Text

) Both teat and amows

) Mways keep text between ext lines
[ Suppress armows if they dont fit inside

To format dimensions:

Text posttion

) Beside the dimension line

() Over dimension line with leader

1.Choose Dimension > Style.
2.In the Dimension Style Manager dialog box, select the style you
wish to change and choose Modlify.

() Over dimension line., without leader

 there isn't enough room to place both text and
amows inside extension lines, the first thing to

When text is not in the default posttion. place it:

10159

113955

2\

RO.2045

Scale for dimension features
[7] Annetative
) Scale dimensions to layout

1.0000

® Use overall scale of

Fine Tuning
[T Place text manually
[~] Draw dim line between ext lines

3.In the Modify Dimension Style dialog box, click the Adjust tab.

[ cancel | [ Hep

4.Under Fit Options and Text Placement, select an option.5.Click OK and choose Close to exit.

9.2.6. Fit Diameter Dimension Text

You can create various diameter dimensions based on text placement, fit options and

Modify Dimension Style: new dim style

the selection of "Always keep text between ext lines" option on the Adjust tab.

@37
&

Text and arrows inside
with inside horizontal
option selected

User defined horizontal
placement dimension line
and arrows, no center mark,
forced interior line

Default horizontal
placement text outside
circle, center mark,
no forced interior line

Lines | Symbols and Arows [ Text | Adust | Primary Units | Atemat
Fit options
if there isn enough room to place both text and
amows inside extension lines, the first thing to
move outside the extension lines is:

Either text or amows (best fit)

Arows

Text

Both text and amows
© [ways keep tex between ext ines|

Scale ford

Suppress amows f they don! fit inside
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9.2.7. Align Dimension Text

Whether the text is inside or outside the extension

line, it has no effect on the justification of dimension
text. You can choose whether the text is align with the

dimension lines or remains horizontal.

To align dimension text with the dimension line:

1.Choose Dimension > Style.
2.In the Dimension Style Manager dialog box, select

the style you wish to change and choose Modify.3.In
the Modify Dimension Style dialog box, click the Text

tab.4.Make your selections.
5.Click OK and choose Close to exit.

9.2.8. Position Dimension Text Vertically

The vertical text placement is the position of the
text relative to the dimension. You can place text
above, below, or centered within the dimension
line, or use the JIS dimensions.

9.2.9. Position Dimension Text Horizontally

The position of text along the horizon is relation
to the extension lines. The settings include

Centered, At Ext Line 1, At Ext Line 2, Over Ext Line1, and Over Ext Line2.

9.2.10. Dimension Units

You can determine the appearance and format of the
primary and alternate dimension units. You can set
the primary units for linear and angular dimensions,
including unit format, numeric precision and so on.
These settings control the display of dimension
values.

Lines | Symbols and Arows | Texd | Adust | Pamary Units | Atemate Units | Toleranos |
Text appearance
Text stye: Standard =[]
Teot color, HRed -] !
Fil color: H6reen -]
Text height: 25
Fraction height scale 1 [FE7]
Draw frame around text Text aligmertt
Tt postion © Horizortal
Vet
© Aligned with dmension ne
View Direction: From leftta right - (©) 150 standard
Offset from dimlinc: 6% =
[ ok ] [ Cacd | [ Heo
Lines | Symbols and Arows | Text | Adjust | Primary Units | Akemate Unis | Tolerance |
Text appearance
Text style: Standard +| (] I
Text color: WRed -
Fill color DGreen -
— 2 _L k4o
Fraction height scale 1
Draw frame around text TeiemTe
TS © Horzortal
Vertical Up -
7 Migned with dimension line
(] Over Bxt Line 1 -
View Direction From rightto lekt g | | ©'SCsmd=d
Offset from dim line: 65 =
ok ] [ caced | [ Hek 3
Lines | Symbols and Amows | Text [ Adjust | Primary Units | Atemate Units | Tolerance |
Linear Dimensions.
Untfomnat .H,
Precision:
Fraction format:
Decimal separator:
Round off: |
Prefix:
Suffic Angular dimensions
Measurement scale Pt Decimal Degrees. - f
Scale factor: 1
[ Aoply to layoust: dimensions oni ly feca .0, g
Zero suppression Zero suppression
[ Leading Trailing [ Leading
‘Subrurits factor: e [ Traling
100
Suburit suff O nches
[ok ] [ concel | [ Heb
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To round off dimensions:

1.Choose Dimension > Style from the main menu.

2.In the Dimension Style Manager dialog box, select the style you wish to change and choose Modify.

3.In the Modify Dimension Style dialog box, click the Primary Units tab.

4.In the Linear Dimensions and Angular Dimensions fields, type or select the nearest value to which you want to round off
dimensions.

5.Click OK and choose Close to exit.

9.2.11. Alternate Units

You can create a dimension in two systems of measurement simultaneously in a drawing. This feature is helpful when you want
to add feet and inches dimensions in a drawing created using metric units. The alternative units appear in a square brackets ([])
in the dimension text. Alternative units can be applied to linear dimensions only.The precision for alternate units determines the
number of decimal places.

To create an alternate dimension: - - : —

Lines | Symbols and Amows | Text | Adjust | Primary Units | Atemate Units | Tolerance |

Display aemate units

. . et s S
1.Choose Dimension > Style. o
2.In the Dimension Style Manager dialog Precisn
box, select the style you wish to change atar s PR /

. Round distances to: 0 z
and choose Modify. o Plcemen
.

3.In the Modify Dimension Style dialog box, S

@
Zero suppression 9! After primary value

click the Alternate Units tab. s [toing B

4.Click the Display Alternate Units check W ‘F.

box. I

5.Make your selections.

6.Click OK and choose Close to exit. %] (o] [

9.2.12. Display Lateral Tolerances

Lateral tolerance represents a value that the amount a measured distance can vary. You can control the degree of accuracy
needed for a future by specifying tolerances in manufacturing. These dimension tolerances indicate the largest and smallest
permissible size. You can also apply geometric tolerances to indicate deviations of form, profile, location, orientation, and
runout.

Deviation tolerances represent with the plus and minus values that are appended to the dimension values. If the deviation
tolerances are equal, the = signs precede them and they are known as symmetrical. Otherwise, the plus value locates above
the minus value.
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The vertical placement of tolerance values that is relative to the main dimension text can be specified. For example, you can

align the tolerances with the top, middle, or bottom of the dimension text.

[ Lines | Symbols and Amows | Text | Adust | Primary Units | Akemate Unis | Tolerance |
Tolerance format
= 14,140
Method Symmetrical >
None SYMMETRICAL
Precision 5
Deviation g R
Limits L) "
Uporvan: | e ’ ' % DEVIATICON
Lower value 5 +0,5
& 24 -0,6 24+0,5
Scaling for height: 1 =
i Atemate urit tolerance
Tolerance alignment 35+0,5 35 +0s +0,5
Align decimal separators e -0,6 -0,6 35-0,6
Align operational symbals Zero suppression
e ] Leading Dfeet
Je= OFeet Traing Oinches TOP MIDDLE DOWN
[¥] Trailing 0Olnches
oK | [ GCamed | [ Hep - | | ‘ | ‘ |

9.2.13. Set the Scale for Dimensions

Setting dimension scale depends on the method you use to lay out and plot drawings. Dimension scale has effects on the size
of dimension geometry relative to the objects in the drawing. In addition to text height and arrowhead size, dimension scale
affects offsets in dimension as well, such as the extension line origin offset. When you create dimensions, it's recommended to
set the size and offset to values that represent their actual plotted size. However, the tolerances, measured lengths, coordinates
and angles cannot be applied to the overall scale factor. The method of creating dimensions in a drawing layout is shown as
follows:

-Dimension in model space for plotting in model space. If you want to create dimensions that are scaled correctly for plotting,
you have to set the system variable DIMSCALE to the inverse of the desired plot scale. For example, if the plot scale is 1/4, you
have to set DIMSCALE to 4.

-Dimension in model space for plotting in paper space. If you want to create dimensions that are scaled automatically for
display in a paper space layout, you have to set the DIMSCALE to 0. This method is useful when you encounter the following
situations: the dimensions in a drawing need to be referenced by other drawings (xrefs); when you create isometric dimensions
in 3D isometric views. To prevent the dimensions in one layout viewport from being displayed in other layout viewports, it's
recommended to create a dimensioning layer for each layout viewport that is frozen in all other layout viewports.

-Dimension in layouts. You can create dimensions in paper space by selecting model space objects or by specifying object

snap locations on model space objects. The dimensions created in a paper space layout do not need additional scaling: there is
no need to change the default value of DIMLFAC and DIMSCALE.
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9.3. Modify Existing Dimensions

You can modify all components of the existing dimension objects in a drawing either individually or by using dimension styles.

9.3.1. Modify Dimension Style

You can modify all of properties of the Gg:;t::e i :
existing dimension objects in a drawing e -
using dimension styles. You can also create a P _,/ % }"Zf’
dimension style override to temporarily P >
change a dimensioning system variable [ o e

without changing the current dimension style. ) e

If a dimension style is changed, the
dimension associated with that dimension
style updates automatically.

9.3.2. Make Dimensions Oblique

Extension lines are normally created at a perpendicular angle to the
dimension line. You can change the angle of the extension lines, however, so
that they tilt relative to the dimension line.

To make oblique extension lines:

1.Choose Dimension > Oblique from the main menu.
2.Select the linear dimension, and then press Enter.
3.Type the obliquing angle, and then press Enter.

G New Dimension Style: new dim styie 2 S
Lines | Symbols and Arows | Text | Acust | Pamary Unis | Abemate Unis | Tolernce
Telerarce fernal
Methad [spmmetncal = 4:
Precison (200 = I 4 \
Upper vatue: 0 z — , \
Loner vale: [ / )

Seaing forheight

Verial postion [Down -

Tolerance sigrmert

£

R T IOEHA +H IH PO BRED

| CIEIETRR Modity Window Help Express.
Quick Dimension
\\\\\

Aligned

Arc Length
Ordinate

Leader
Tolerance... 1l
Center Mark
Inspection

Jogged Linear

Align Text »
ension

Dimension Style...

QOblique

Help  Express

Radius ’l

Jogged 2
Diameter

Angular

Baseline

Continue

Dimension Space

Dimension Break.

Remark: To align the oblique angle if you don't know the exact measurement, use snaps to pick two points on the entity.

9.3.3. Dimension Jogged Linear

=
&,

The DIMJOGLINE command is available for adding or removing jog & wacLengsh

symbol for linear dimensions. The jog symbol is default to be placed at
)]
the center point between first extension line and text. To relocate jog g
symbol, you can adjust the position of dimension text or specify new o

position to locate jog after reselecting dimension. "

i

To add a jog to linear dimension: T

(¥) CenterMark
[#l  Inspection

¥\, Jogged Linear

1.Choose Dimension > Jogged Linear from the main menu. H

]

3.Specify a point on the dimension line to determine the jog symbol, or  |&

[T Modify Window:
[ Quick Dimension

Linear
Aligned

Ordinate

Radius
Jogged
Diameter
Angular
Baseline

Centinue

\[i, Dimension Space
1 Dimension Break

Leader

Oblique

Align Text

2.Select a linear dimension. P C——

Override
Update

Help  Express.

Help  Express

52

52

press ENTER directly to position the jog symbol in default place.
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9.3.4. Dimension Inspection

Dimension inspection is created to transmit the frequency of inspecting the part being dimensioned, the dimension value and
parts tolerance are ensured to be within specified range. Dimension inspection is composed by a frame and internal text and
contains utmost three kinds of information field: inspection tag, dimension value and inspection rate.

Inspection tag, used for mark the text of dimension inspection is located at the left side within the inspection frame.
Dimension value is the value before adding dimension inspection, which is located at the central part of the inspection

dimension including tolerance, text and measurement value.
Inspection rate is expressed by percentage, which is located at the right side
within the inspection frame, indicates required frequency of the part being created.

To create an inspection dimension:

1.Choose Dimension > Inspect from the main menu.

2.In the Inspection Dimension dialog box, click Select Dimensions button.
3.Select dimensions to add dimension inspection, and then press ENTER to finish
selection and return to the dialog box.4.Select a shape for frame from the Shape
option.5.Click Label option to input label in the text box.6.Click Inspection Rate
option to input a value in the text box.7.Click OK.

To remove an inspection dimension:

1.Choose Dimension > Inspect from the main menu.

2.In the Inspection Dimension dialog box, click Select Dimensions button.
3.Select dimensions to remove dimension inspection, and then press ENTER to
finish selection and return to the dialog box. 4.Click Remave Inspection
button.5.Click OK.

9.3.5. Adjust Dimension Space

Once you have created multiple
paralleled linear dimensions or

77,84

angular dimensions, you can 45,08
adjust the space among these R 323:5 """""" -

. . : ]
paralleled lines with an equal
value either default or specified. 7z
DIMSPACE command adjust the é
space among paralleled linear 4l 1

or angular dimensions or

Inspection Dimension i
__i Select dmensions
Shape Label/Inspection rate
© Round X0 | 100% 7 Label
EXT
Rogds
¥ Inspection rate
None XXX 100%
9%
o ] Cancel Hep
(EXT[77,94[357,

77,94

46,08

40,69

36,77 7

overlapped dimensions

automatically in case that the
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original space is not equal values. If you set the space value to 0 when adjusting space among dimensions, you can align
selected dimensions at the dimension line as well.

9.4. Add Geometric Tolerances

Geometric tolerances show acceptable deviations of form, profile, orientation, location, and runout of a feature. You add
geometric tolerances in feature control frames. These frames contain all the tolerance information for a single dimension.
Geometric tolerances can be created with or without leader lines, you can create them with TOLERANCE or LEADER
command.

@#.505-.525
[ B.005@[A[D@[B]
A feature control frame consists of two or more components. The \_Tem .
first feature control frame contains a symbol that represents the LD&lum o
geometric characteristic to which a tolerance is being applied, Zm:nyM;d:ﬂ:
for example, location, profile, form, orientation, or runout. Form Primary Datam
tolerances control straightness, flatness, circularity and Modtiar 0"
cylindricity: profiles control line and surface. In the illustration, folerance _
the characteristic is position. é}j;fﬁfﬁiiﬂg
9.4.1. Geometric Tolerance Dialog Box
Specifies the symbols and values for a feature control frame.
1. Geometric Characteristics symbol (menu) 1 2 3 4 5 6
2. Tolerance Zone form (toggle) (e - =)
3. Tolerance zone value Y Vv Vv v v v
Sym Tolerance 1 Tolerance 2 Datum 1 Datum 2 Datum 3
4. Material condition symbol (menu) o1 ] H H: B ]
5. Datum reference 1 of 3 H N H N | i | |
6. Datum reference 2 of 3 M Projected Tolerance Zone: [ 4— 7 ‘
7. Projected tolerance zone symbol (toogle) 2| oot G
8. Projected tolerance zone value (o J[ canced J[ Hep ] \
9. Datum identifier L
9.4.2. Geometric Tolerance Symbols
The geometric tolerance symbols and their characteristics are shown in the following.
1. Position (Location) 8.  Flatness (Orientation)
2. Concentricity or Coaxiality (Location) 9. Circularity or roundness (Form)
3. Symmetry (Location) 10. Straightness (Form)
4. Parallelism (Origntation) 11. Profile of a surface (Profile)
5. Perpendicularity (Orientation) 12. Profile of a line (Profile)
6.  Angularity (Orientation) 13. Circular runout (Runout)
7. Gylindricity (Orientation) 14. Total runout (Runout)
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11 12 13 14

9.4.3. Material Conditions

Depending on control type, you can add a diameter symbol prior to the tolerance value, and specify a material condition
symbol behind this value. You can apply material conditions to features that can vary in size.

9.4.4. Datum Reference Frames

A datum reference consists of values and modifying symbols. A datum is a theoretically exact geometric reference that
measures and verifies a theoretically exact point, axis, or plane. The system provides up to three datum reference letters and
relative symbols followed by the tolerance value.

9.4.5. Projected Tolerance Zones

Projected tolerance zones control the height of the fixed perpendicular part of the extension area, and control tolerance
accuracy by positional tolerances. Before you set the symbol to projected tolerance zones, you set a height value to specify the
minimum projected tolerance zone.

9.4.6. Composite Tolerances

A composite tolerance consists of two tolerances that applied to the same geometric characteristic of a feature or for features
that have different datum requirements. Before you create a dimension and add a composite tolerance for a drawing, you have
to specify the first line of a feature control frame and then choose the same geometric characteristic symbol for the second line
of the feature control frame. The specified geometric symbol compartment is extended over both lines. Then you can create a
second line of tolerance symbols.

To add a geometric tolerance:

1.Choose Dimension > Tolerance from the main menu.
2.In the Geometric Tolerance dialog box, click the first square under Sym and select a symbol to insert.
3.Under Tolerance 1, click the first black box to insert a diameter symbol.
4.In the Text box, type the first tolerance value.
5.To add a material condition, click the second black box and click a symbol to insert it.
6.Under Tolerance 2, repeat steps 3 through 5 to add a second tolerance value.
7.Under Datum 1, Datum 2 and Datum 3, enter the datum reference letter.
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8.Click the black box to insert a material condition symbol for each datum reference.

9.In the Height box, type a projected tolerance zone height value, if appropriate.

10.To insert a projected tolerance zone symbol, click the Projected Tolerance Zone box.

11.In the Datum Identifier box, add a datum value and then click OK.

12.In the drawing, specify the location of the feature frame.

7 GEOMETRIC TOLERANCE SAMPLE DRAWING.dwg

[t 46,590 ——==

—--|14,300|— 28,500
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& [#55@ 75,2 ]A[B|C|
0,3
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14,380

~
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@ D

h)

%31,25—J
t——36,03—=
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=)

(G Geometric Tolerance
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10. Blocks, Attribute and reference

Block Definition =
= 19
10.1. Create and Insert Blocks Base port Ohiects Behavior
Specfy On-screen Specify On-screen Annotative
. - _ﬁ&%ma | Seectabiecs| (1
Usually, blocks are several objects combined into one that Retan
x 0 N o Scale unformly
you can insert into a drawing and manipulate as a single Y o E:“:‘” 9] Alow exgloding
object. Blocks can help you better organize your work, = Sitiecyiciad
quickly create and revise drawings, and reduce drawing file S?f..;f; 7 Dot
size. — o
L Hpednk.
Open in block edtor [ok__ ][ cance Help

10.1.1.Create Blocks

Usually, blocks are several objects combined into one that you can insert into a drawing and manipulate as a single object. A
block can consist of visible objects such as lines, arcs, and circles, as well as visible or invisible data called attributes. Blocks
are stored as part of the drawing file. You can use several methods to create blocks:

-Combine objects to create a block definition in your current drawing.
-Create a drawing file and later insert it as a block in other drawings.

To create a block for use within a current drawing:

1.Choose Draw>Block> Make from the main menu.

2.In the Block Definition dialog box, enter a block name in the Name

box.

3.Click Pick point button to specify the insertion point for the block in
the drawing area.

4 Click Select objects button to select the objects for the block, then
press Enter after selection. Then click OK button.

10.1.2. Create Nested Blocks

B
JRagt - Ny
H Ll i =
';’ u !* Objects to Block 1
e
W-eolee--l 0 peetteeniesziol

You can define blocks and other blocks as nested blocks so as to simplify the organization of complicated blocks. With nested
blocks, you can build a single block out of several components. But you should notice that blocks that reference themselves

cannot be inserted.

112




Chapter 10_ Blocks, Attribute and Xrefs

10.1.3. Create Drawing Files for Use as Blocks

You can create a block as a separate drawing file that you can insert into
other drawings.

To save a block as a separate drawing file:

1.0n the command line, type WBLOCK.
2. Under Source area, choose one of the following:

-Block: Saves existing block object to a separate drawing file.
-Entire drawing: Saves the entire drawing to a separate drawing file.

-0Objects: Saves those objects you select to a separate drawing file.

3. Under Destination area, type the name of the drawing file you want to
create and choose the saved path, click OK to save.

10.1.4. Change the Base Point of Drawings to Be Used as Blocks

5
G Write Block [
Source
Block
() Entire drawing|
@ Ohjects
Base poirnt Objects
Picl point Select objects
X 0.0000 © Retain
() Convert to block
Y: 0.0000 ~
() Delete from drawing
z 00w I\ No object selected.
Destination
File name and path
[b:\Program Files\Gstarsoft\New Block.dwg | [=]
Insert units: [Mwllimeter v]
[ ok | cameel |[ Beb |

When inserting a drawing file into another drawing as a block, by default, system uses the origin (0,0,0) of WCS as the base
insertion point. To specify different insertion point, you can use BASE command. Next time you insert the same block, system

uses the new insertion point by default.

10.1.5. Update Changes in the Original Drawing

Once the drawing file has been inserted into another drawing as a block, the original drawing changes as well. But the block
having been inserted will not change. If the block happens to change along with the original drawing, you should attach it as

external reference but not as a block.

10.1.6. Use Paper Space Objects in Blocks

Objects created in paper space are not contained in the block when it is being inserted into the drawing. You can convert the

objects in paper space as block or save as an individual drawing file before inserting into other drawings.

10.1.7. Insert Blocks

You can insert blocks and other drawings into the
current drawing. When you insert a block, it is treated
as a single object. When you insert a drawing, it is
added to the current drawing as a block. You can then
insert multiple instances of the block without reloading
the original drawing file. If you change the original
drawing file, those changes have no effect on the
current drawing unless you redefine the block by
reinserting the changed drawing.

Insert
o 7] o)
Path @
Inserton Port Scale Rotation |
V| Specfy On-screen Specy On-screen Specy On-screen
Xl 1 Age: O
Yol 1 Block Unt
Z 1 Unt Miimeters
Unfom Scale Factor. 1

ok ][ Comen Heb
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To insert a block;

1.Choose Insert > Block from the main menu.

2.In the Insert Block dialog box, under Insert, click Block Name.
3.In the Name box, select the name of the block you want to insert.
4If you want to use the pointing device to specify the insertion point, scale, and rotation, select Specify On-Screen. Otherwise,

enter values in the Insertion Point, Scale, and Rotation boxes.

5. Click OK to insert.

To insert an entire drawing into the current drawing:

1.Choose Insert > Block from the main menu.

2.Click Browse to specify the file from the Insert Block dialog box. Path

3.You can use the default insertion point, scale, and rotation or

Insertion Point

select Specify On-Screen and enter values in the Insertion Point, XS”:YO“W
Scale, and Rotation boxes. Y. 0
4 If you want the objects in the block to be inserted as individual =

objects instead of as a single block, select Explode. Precondition

is the block you created is allowed to explode.
5.Click OK to insert.

10.1.8. Modify a Block Definition

Rotation
Specfy Onscreen Specfy On-screen
X 1 Angle 0
el 1
Block Unit
1 Untt Miimeters
Unfom Scale Factor: 1
OK Cancel Help

You can redefine all instances of a block within the current drawing. To redefine a block that was created in the current drawing,
you create a new block using the same name. You can update all the blocks in the current drawing by redefining the block. If
the block was inserted from a separate drawing file that was subsequently updated, reinsert that block to update all other

instances in the current drawing.

To redefine a block in the current drawing:

1.Choose Draw > Block > Make from the main menu.
2.In the Block Definition dialog box, type the name of the
block you want to redefine in the Name box.

3.Click Pick point button to specify a point as the insertion
point for the block in the drawing area.

4.Click Select objects button to select the objects for the
block, and then press Enter after selection.

5.Click OK.

6.Click Yes in the prompt box that displays to redefine the
block in the current drawing.

G Block Definition

Mame:
1

Base point

Objects

- ©

Behavior

G Block - Redefine Block

“1" is already defined as a block. What do you want to do 7

LI T

Number of 1 block reference in the drawing:1
*es: Redefine block, No: Don't redefine block.

[

Saitings
Block unit

[] Open in black editar

Desoription

OK

][ Cancel ][

Help
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10.1.9. Remove Block Definitions

Too many block definitions in a drawing file may
affect the drawing size. To reduce the size of a
drawing, you can remove unused block definitions.
Erasing a block reference from a drawing may
delete the block reference but retain the block
definitions in the block definition table. Using
PURGE command can help removing unused block
references from your drawing in order to reduce
the drawing size. You should erase all references
from a block before you can purge the block
definition.

10.1.10. Define and Use Block Attributes

View items you cannot purge

Multieader styles
MutiLine Style
Plot styles
Registered application
Shape
{73 Table styles
B Textstyles

V! Confirm each item to be purged
Purge pested items

An attribute is a particular object that you can save as part of a block definition. Attributes consist of text-based data. You can
use attributes to track such things as part numbers and prices. Attribute values are either fixed or variable.

To define an attribute:

1.Choose Draw>Block> Define Attributes from the main
menu.2.Under the Attribute, type the tag, prompt, and default
text.3.Under Insertion Point, specify the location of the attribute, or
click Specify on-screen to select a point in the drawing.4.Under
Mode, select the optional attribute modes. 5.Under Text Settings,
specify the text characteristics.6.To add the attribute to the drawing,
do one of the following:

-Click Define to add the attribute and keep the dialog box active so
you can define another attribute.

-Click Define and Exit to add the attribute and end the command.

To edit an attribute definition:

1.0n the command line, type DDEDIT.2.Select the attribute definition
text to edit.3.Modify the attribute tag, prompt and default in the Edit
Attribute Definition that displays.4.Click OK.

r ~
G Attribute Definition ﬁ
Mode Attribute
[ Invisible Tag:
Constant
1 Corstz Prompt:
[T Verify
[] Preset Defaut: @
[¥] Lock position
[T Muttiple lines Text Settings
= e -
V|5
pecty on-s [ Annotative
® (Lo Te height: 20000 &,
[ —_— 0
Z 0000
Boundary width: 0000 Ef%
Align below previous attribute definition
[ ok ][ cancd | [ hHep |
]
r Y
G Edit Attribute Definition S5
Tag: WINDOW
Prompt: 80120
Default: I-
[ ok ] [ cancel | [ Hep
A
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10.1.11. Modify Block Attributes

You can use the Block Attribute Manager to modify attributes in
block definitions. For example, you can modify the following items:

-Attributes of blocks can be displayed after modification.

-Text properties that define how attribute text is displayed in the
drawing.

-Properties that define the layer that the attribute is on and the
attribute line's color, weight, and type

HOW MANY BODIES? 3

To edit an attribute attached to a block:

1.0n the command line, type DDATTE.2.Select the block to edit.
The Edit Attributes dialog box displays all the attributes attached
to the block you select.3.Edit the attribute values as necessary.

Then click OK. Coeel ™

. Data Extraction - Define Data Source (Page 2 of 8) ﬂ |
10.1.12. Extract Block Attribute Data

Data Source
@ Drawing/Shet set

. . . Include current drawing
Enter EATTEXT to start Attribute Extraction if the blocks © Sdct bt o comt g El _
in the drawing contain attributes. You can extract block i e s ks e s =
. . . . w Extraction settings
information according to the wizard prompt and B | | Elcsiactobjects fombods
generate list so as to overview the attributes information [J]Extract objacts from xrefs
of the blocks. You can get guide information from the LI e e
wizard until you accomplish selecting drawings, blocks \ Bxtract from |

. () Objects in model space
and blOCk aHrIbUTeS | __| @) All objects in drawing '
. . . [ oK J [ Cancel ] [ Help ]

With the extract block attribute data function, you can

easily create list using drawing data through extracting attribute information and export to external files.
10.1.13. Synchronize Attributes

The ATTSYNC command applies attribute changes in block definitions to all block references of the same name. You can use
this command to update instances of blocks containing attributes that were redefined using the BLOCK or BEDIT commands.
ATTSYNC does not change any values assigned to attributes in existing blocks. ATTSYNC removes all changes of format or
features that are made by ATTEDIT or EATTEDIT commands. And it also deletes all extended data associated with blocks and
might affect dynamic blocks and blocks created by third-party applications.

10.2. Reference Other Drawing Files (Xrefs)

External references provide additional capabilities not available when you insert a drawing as a block. When you attach an
external reference, however, any changes you make to the original drawing file are reflected in the drawings that reference it.
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External references are useful for assembling master drawings from component drawings. Use external references to coordinate
your work with others in a group. External references help reduce the drawing file size and ensure that you are always working
with the most recent version of a drawing.

10.2.1. Attach External References

When a drawing is attached to current drawing as external reference, it will be linked to the drawing, any changes to the
referenced drawing may affect the external reference in current drawing. External references are inserted into the drawing as
block definitions and used as single objects, but you should distinguish the external references and blocks.

To attach an external reference:

1.Choose Insert>External References from the main menu. 2.Clickthe DWG icon at the top left of the window.
3.In the Select Reference File dialog box, specify the drawing file to attach and then click Open.

4.In the External Reference dialog box, under Reference Type, choose how you want to insert the drawing:
-Attachment: Inserts a copy of the drawing and includes any other drawings references.

-Overlay: Lays a copy of a drawing over your original drawing

5.Make any additional selections and then click OK.

6.1f you marked Specify On-screen for any items, follow the prompts to attach the external reference

External Reference x
Ble-o
)

Reference Name Stats sae
A orawngt Opened
£ moos:2 Loaded 163.30K8
L;( BLOOKS 2DMNAMICBLOCKE Mot referenced 0.00K8
5

Reference
Stats
Sae

Type
OATE
Save path
Found At

10.2.2. Control the Properties of Referenced

Layers e
Cumert layer 0
R >H Xv

You can control the visibility, color, linetype, and
other properties of an xref's layers and make these
changes temporary or permanent. |f

the VISRETAIN variable is set to 0, these changes
apply only to the current drawing session. You can
also control the fade display

through XDWGFADECTL variable. In addition you can control Xref layer properties directly into the Layer Manager Properties
dialog box.

»
@
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10.2.3. Xref Clipping Boundaries
Image
Qe Vg
You can control whether to display clipping boundary of xref e
. . . i Offset
through setting system variable XCLIPFRAME. Also you can Clip 85 Ay .
& Mov
Xrefs by selecting the option on the menu bar: e o
Modify> Clip> Xref o
B v
10.2.4. Nest and Overlay External References i oot
i~ Filet
Xrefs can be nested in another xref and attached to current ® S
drawing. In the process of attaching, you can select insertion
position, scaling factor and rotation angle for xrefs.
External Reference x
B 2@
10.2.5. Binding an Xref to a Drawing
'™ orawingt Opened B
% o o Loadsr; , s
To provide a copy of a drawing containing & socd  Asch vmied 23]
G Bind Xrcfs M 2 aoo Unlond Net referenced 001
external references to someone else, you must 5 aoaa e ::f;’f:;;’_md ol
also provide all the external reference files. BndTvpe . — =
(@) Bind E
Binding the external references makes them a et Rl bbb donrmntten
permanent part of the drawing, which is S
similar to inserting a separate drawing as a e K T e
block. You can bind external references by doing right click to the selected Xref file. s Sl ranenin -

Nested reference selected: Cannot change path, name, ortype

10.2.6. Refresh Xrefs

You can refresh the Xref by clicking the refresh button located at the top of the External Reference Dialog Box.

10.3. DGN Underlay

In GstarCAD 2018 version, the full DGN files are S Yo s T~ —
% |
supported and related commands such as e i

OGN Undertay L A
Color Bylayer * o} [
- Layer 0 ® o T L. 3 C]
Linetype Bylayer 4

o s s~
dom =

DGNIMPORT, DGNATTACH, DGNADJUST,
DGNMAPING, etc are available. Now you can import

and attach as underlay a Microstation native format B 2
T
rrari R
, Lo ll— e il la%:
- d Bl
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10.4. DWF Underlay

| Select Reference File

GstarCAD supports DWF Underlay, you can insert a DWF file as Underlay.

10.5. PDF Underlay

If you receive project drawings in the form of a PDF file, you can reuse that PDF data in your own GstarCAD drawing files.

| select Reference File

Lookin: |, Drawing and icture ~ 02 E-
= Name Date Type Size Tags
i 1 2015 drawings 11/28/2014 ... File folder
1 test drawing 12/17/2014 ... File folder
1PDF UNDERLAY 10/24/2014 .. Adobe Acr. 4300 KB
El TLiPlano Seccional La .. 4/14/20146... Adobe Acr... 201 KB
A
i~
[ |
w
< i ]
Fil name: PDF UNDERLAY ~ Open
Files of type: FDF files(" pd) ~ Cancel
PDF files(” pdf)

After inserting the PDF file as underlay, Then you can start
drawing or placing geometry at specific point of the underlay.

Lookin: | Drawng and picture - @F > E
t Mame Date Type Size Tags
s 1. 2015 drawings 11/28/2014 ... File folder
1) test drawing 12/17/2014 ... File folder
g
s
|
EE < i ]
Flle name Open
Flles of type DWVE fies{-anbsc Cancel
DVIF files(" dwic" dwf) S —
| Attach PDF Underlay Y S|
Name [PDF UNDERLAY - Browse
Select one or more pages from PDF file:
Path type Seale
[ Speciy On-screen
- Ful path -
1 2 3 1
Insestion Point
] Specify On-screen
Rotation
o R oo
O
0
o o o

What’s more, you can adjust the underlay display like contrast, fade, monochrome, and colors for background through the

properties palette. E

POF UNDERLAY - 3

3

EAGSTARCAMPAND
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10.6.About Clipping Underlays

The clipping boundary can be specified as a

limited portion of the external reference graph,
block reference, graphics, viewport, and underlay.
You can clip external reference such as DGN. DWF.
IMAGE - PDF and other underlay or block reference.
You can use clipping boundary to determine the
external reference or block reference section that
you want to display, or to hide the redundant parts
of the reference inside or outside the boundary by
the following methods.

The boundary can be a polyline, a rectangle, or a polygon whose vertexes are limitedwithin the global scope of the underlay.
You can modify the boundary of the graphics to be clipped. When you clip the graphics, you do not change the object in the
external reference or block, but only change the way they are displayed.

Clip Block

BN i oo i

ON| QFF | Clipdepth | Dclete | generate Polyine 4 b

Clib AlsmboLs

10.7. Edit Reference Tab

With REFEDIT function allows you to edit blocks as reference. Users can access this function from toolbar in the classic
interface and also there is an edit reference panel in ribbon interface. In edit reference panel, users can select the options like
save changes, discard changes, add to working set and remove from the working set base on block modifications. Now you can
edit an xref or a block definition directly within the current drawing.

........

- L Repeat REFEDIT
\gentily Reference | Settings Recent Input »
Reforence name: Preview - Edit Xref In-place
G 17 HATCH BOUNDARY IMPROVEMENT | - e e
£@ G17 HATCH BOUNDARY IMPROVEMEN Tipersor = Open Xref
£@ G17 HATCH BOUNDARY IMPROVEMEN Tplarta '-ﬂ__g - VEYy Clip Xref
£ G17 HATCH BOUNDARY IMPROVEMENTplarta g* - "ﬂ
£ G17 HATCH BOUNDARY IMPROVEMENTplanta » [ External References...
£@ G17 HATCH BOUNDARY IMPROVEMENTplanta
L@ G17 HATCH BOUNDARY IMPROVEMENTplanta i Clipboard » =
£& G17 HATCH BOUNDARY IMPROVEMENTplanta ~ R
“1 n G Isolation »
Path: FAGSTARCAD\PRODUCT LINE\PLATFORM\GSTARCAD 2017\G17 FEATURES DWG\G17
© Automatically select al nested objects &7 Erase / =
Promot to select nested objects «&  Move
93 Copy Selection
B Scale
“11) Rotate
Z Draw Order » 2 2 -
Group »
Deselect All
Select Similar I
[¥ Quick Select...
QuickCalc
=l 2 W
@, Find... FTAET ; Sk
2% Properties : = -
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The objects that you select from the selected xref or block are temporarily extracted and made available for editing in the current
drawing. The set of extracted objects is called the working set, which can be modified and then saved back to update the xref or
block definition.

Reference Edit Dialog Box

Identify Reference Tab: Provides visual aids for identifying what to edit and control how it is selected.

SReference Name: Displays the reference selected for in-place editing and any references nested within the selected reference.

If multiple references are displayed, choose a specific xref o | G Reference et ==
block to modify. Only one can be edited in place at a time. dertfy Reference | etings|
Preview: Displays a preview image of the currently selected e I
. . . £ REFEDIT ENHANCEMENTipersonas01
reference as it was saved in the last drawing. The reference £ REFEDIT ENHANCEWEN Tabusol3 |2
) ) ) £ REFEDIT ENHANCEMENTlarbusto03 L
preview image is not updated when changes are saved. D o i
Path: Displays the file location of the selected reference. If it s e e
. . . @ REFEDIT ENHANCEMENTplantas04 -~
ISd blOCk, no path IS dlsplayed Path:  FAGSTARCAD\PRODUCT LINE\PLATFORM\GSTARCAD 2017%G17 FEATURES

@ Automatically select all nested objects

Automatically Select All Nested Objects: Controls whether R

nested objects are included automatically in the reference ‘ [
editing session.
Prompt to Select Nested Objects: Controls whether nested objects must be selected individually in the reference editing
session.

Settings Tab

Create Unique Layer, Style, and Block Names: Controls whether layers and other named objects extracted from the reference
are uniquely altered. If selected, named objects in xrefs are altered (names are prefixed with $#8$), similar to the way they are
altered when you bind xrefs. If cleared, the names of layers and other named objects remain the same as in the reference
drawing. Named objects that are not altered to make them unique assume the properties of those in the current host drawing
that share the same name.

Display Attribute Definitions for Editing: Controls whether all variable attribute definitions in block references are extracted and
displayed during reference editing. If Display Attribute Definitions for Editing is selected, the attributes (except constant
attributes) are made invisible, and the attribute definitions are available for editing along with the selected reference geometry.
When changes are saved back to the block reference, the attributes of the original reference remain unchanged. The new or
altered attribute definitions affect only subsequent
insertions of the block; the attributes in existing block
instances are not affected. Xrefs and block references ‘ _

without definitions are not affected by this option. . Oe?q;hijfblkm
Lock Objects Not in Working Set: Locks all objects not in Lok durctent e =

the working set. This prevents you from accidentally
selecting and editing objects in the host drawing while ina
reference editing state. The behavior of locked objects is
similar to objects on a locked layer. If you try to edit
locked objects, they are filtered from the selection set. (o J[ Concel ][ Heb

Ok | [ Cancel | [ Hep J

G Reference Edit ==

Identify Reference || Seftings |
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11. Hatches and Raster Images

11.1. Hatches

11.1.1. Define Hatch Boundary

To create a hatch, you should define hatch boundaries first by
means of selecting objects to be hatched or picking a point
inside the desired object. A hatch boundary can be any
combination of objects, such as lines, arcs, circles, and
polylines that forms an enclosed area.

11.1.2. Control the Hatching in Islands

You can specify methods of hatching objects in outermost
boundary as normal, outer and ignore. Normal is the default

ANSI31 ~[]
EZ777277

Isands

Isjand detection

Object type: Polyine

Boundary set

Do | [ ] €

hatch pattern, besides, you can view hatching results of different types in the Islands area on Hatch tab of the Hatch and

Gradient dialog box.

Normal: Hatch the pattern from the outer boundary to inside. Hatching process will be stopped when encounter inner crossing
points, and continue hatching until second inner crossing point appears.

Outer: Hatch from the outer most layer of configuration, and keep the internal blank.

Ignore: Ignore internal objects, only hatches outer objects.

To select objects for hatching:

1.Choose Draw > Hatch from the main menu.

2.From the Hatch and Gradient dialog box, click the Island detection option, and then choose one of the following islands:

Normal, Outer, Ignore:

O

NORMAL ISLAND

OUTER ISLAND

0

?’o

.

IGNORE ISLAND

3.To keep any new objects that are created for drawing the boundary hatch, select the Retain Boundaries check box under Other

options. Existing objects are always retained.
4.In the Boundaries, click Select Objects button.

122




Chapter 11_ Hatches and Raster Images

5.In the drawing, click the objects to be hatched individually, and then press Enter when done.
6.In the Hatch and Gradient dialog box, click OK.

Select an area for hatching:

1.Choose Draw > Hatch from the main menu.
2.From the Hatch and Gradient dialog box, click the Island detection option, and then choose one of the following islands:
Normal, Outer or Ignore.

® .

NORMAL ISLAND OUTER ISLAND IGNORE ISLAND

A7),
=N

3.To keep any new objects that are created for drawing the boundary hatch, select the Retain Boundaries check box under Other
options. Existing objects are always retained.

4.In the Boundaries, click Pick Points button.

5.In the drawing, click inside the closed perimeter of a boundary. If desired, continue clicking inside additional closed
perimeters.6.To complete the selection, press Enter. Then click OK button.

11.1.3. Choose and Define Hatch Patterns G Hatch and Gradient =)
Hatch | Gradiert Boundaries
\ , \ Type and pattem Add: Pick points
Hatch pattern consists of a repeating pattern of lines, dashes, and = R
dots. You can select a hatch pattern from a set of predefined e AT = B
_ oo
patterns, or you can define a pattern of your own. The hatch N 07 (2]
pattern you used most recently is the default pattern the next time : R
you add hatching. The program supplies predefined standard _— e
hatch patterns, which are stored in the ICAD.pat and ICADISO.pat ' ) —
Double 0. E:DDD space [ Create separate hatches
hatch pattern library files. —_—
15000 |
| 20000 ==
To specify a predefined hatch pattern: Huhm
‘5'5";“”
1.Choose Draw > Hatch from the main menu. . o |
2.In the Hatch and Gradient dialog box, click the Hatch tab. e — e
3.Beside Type, click Predefined to apply a scale factor to make the
side Type, Pplya scalefa »
pattern larger or smaller than the default size. . —

4.Enter the scale factor as a percentage of the default.
5.Enter the angle in degrees (1-360). The default angle is
clockwise, you can change the angle of any hatch pattern
by entering a numerical value.

6.Enter the ISO pen width. This option is only available if
you select existing ISO hatch pattern in the Pattern option.
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7.To copy the pattern properties from an existing hatch, choose Inherit Properties.
8.To associate the hatch pattern to its boundary objects, under Other options, select the Associative check box. An associative
hatch updates automatically if you move any of its boundaries.
9.To continue, add a hatch by selecting objects or picking points to selected area or boundary you want to hatch.

To specify a user-defined hatch pattern:

1.Choose Draw > Hatch from the main menu.
2.From the Hatch and Gradient dialog box, click the Hatch tab.
3.Beside Type, in the Type list, click User Defined.

4.For Spacing, enter the line spacing for the pattern.
5.To copy the pattern properties from an existing hatch, choose Inherit Properties, and select a hatch pattern from a hatched

object in the drawing.

6.To associate the hatch pattern to its boundary objects, under Other options, select the Associative check box. An associative
hatch updates automatically if you move any of its boundaries.
7. To continue, add a hatch by selecting objects or picking points to selected area or boundary you want to hatch.

To use a predefined library pattern:

1.Choose Draw > Hatch from the main menu.

2.Click the Hatch tab.

3.Select a Predefined type.

4.To select a predefined pattern, do one of the following:

-In the Pattern list, click the pattern name.
-Click the graphical representation of the hatch pattern.

5. To continue, add a hatch by selecting objects or picking

points to selected area or boundary you want to hatch.

G Hatch Edit

r,Hfld‘J Gradient
Color
) One color

Color1 Color2

Orientation

[| Centered

@ Two color

Angle: 0

M | &

——

f—

Preview

Boundaries

Add: Pick points

Add: Select objects
Remove boundares
Recreate boundary
Select boundary objects

Options

[7] Annotative

[V] Associative

[7'] Separate hatches

Draw order:
l MOBILIARIO & I

Transparency:
Specify Value v

= —1)

Inhertt Propetties

Ok | [ Concel | [ reb

]))

(G Hatch and Gradier

Boundaries

Options in Gradient tab:

Hatch | Gradient
Type and pattem
Type: Predefined A
0| | Pattem NSI31 - -]
Color - =
ANSI32 ] [
Swatch ANSI33
ANSI34 L
ANSI35
ANSI36
Angle and scale ANSIZT -
Angle ANSI38
| 0 - AR-BB16
AR-BB16C
Double AR-BSE ace
AR-BRELM
AR-BRSTD
ARLONC
AR-HBONE
Hatch origin AR-PARGT
® Usercurert AR-RROOF
% RS CUTSILONAN AR RSHKE
(© Specified orign - AR-5AND
E 2XZBRIKC
2XZBRIKS
Default to bouncnepor K
BL APPIANZ E[
I Store as defautt (APPIANRN
ASPHALT
BOARD
Preview AOARDW K
BOARDWN
— O X -

(G Hatch Pattern Palette

ANS| | IS0 Other Predefined | Custom

H i =

soup ANGLE AR-BB16

AR-B8B

AR-BRELM

Pl

AR-HBONE  AR-PARQ1

2

AR-SAND ZXZBRIKC

=

AR-BRSTD

AR-RROOF

2X2BRIKS

=

AR-BB16C

L

AR-LCONC
AR-RSHKE

ANCHORLK

ANS! ron, Brick, Stone mason

o

Inherit Properties

Come ) e >

Draw Order: Assigns a draw order to a hatch or fill. You can place a
hatch or fill behind all other objects, in front of all other objects, behind
the hatch boundary, or in front of the hatch boundary.
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Layer: Assigns new hatch objects to the specified layer, overriding the current layer. Select Use Current to use the current layer.

Transparency: Sets the transparency level for new hatch or fills, overriding the current object transparency. Select Use Current to
use the current object transparency setting.

11.1.4. Hatch to Back
In order to avoid a filling pattern blocks any text, label or other graphics on the current drawing, you can set the display order of all the fill
patterns to back position from all other objects with HATCHTOBACK command.

HATCHGENERATEBOUNDARY

HATCHSETBOUNDARY

HATCHSETORIGIN
HATCHTOBACK

11.2. Work with Raster Images

You can view and manipulate raster images and associated file paths in your drawings.

11.2.1. Attach, Scale, and Detach Raster Images

Raster images consist of a rectangular grid of small
squares or dots known as pixels. Raster images can
be copied, moved, or clipped as well as a normal
object in the drawing. You can also adjust the
contrast, transparency, image quality and image
frame visibility. Additionally, when inserting raster
images, the file format depends on the content of
the file rather than the extension name. The
following table display all the image file formats
supported:

11.2.2. Attach Raster Images

Use IMAGEATTACH command to select and attach raster images, or bitonal, 8-bit gray, 8-bit color, or 24-bit color image files
to a drawing. The image file can be inserted as blocks as many times as you like once attached to the current drawing, you can
clip the attached raster image and setup its lightness, contrast, fading and transparency.
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To attach a raster image: s - =

e
Attach Image =

Neme: (2015120210013

| preview Pathtype

*H

g

1.Choose Insert > Raster Image reference from :
the main menu. ‘ a
2.Specify a file to attach, and then click Open. |= “$ ok o
3.In the Image dialog box, in the Insertion point : -
and Scale, click Specify on-screen. Specify an B —

angle value in Rotation, and then click OK. T i Cie—

4.Specify a insertion point. e = =
5.Specify a scale. “

11.2.3.Scale Raster Images

You can specify scale factor in the Image dialog box, otherwise to attach it by its
original size. The raster image will be scaled by the specified factor, the scale factor v

is used without unit by default. .

Model  Layoutl / Layout2

11.2.4. Detach Raster Images

Raster images can be detached if it no longer needs to use in the drawing, a specified image detached from the drawing
together with its multiple copies, links and definitions, but the original image file will not be influenced.

11.2.5. Modify and Manage Raster Images

Controls the properties such as displaying and clipping boundary of raster images. You can view and manipulate attached raster
image and change its saving path in Image Manager. Users can turn on/off image boundary in current view using IMAGEFRAME
command and setting up the values 0 (off) 1(on).

To turn image frames on or off for all images:

1.Choose Modify>Qbject> Image> Frame

2.Do one of the following to toggle frames off and on:
-Type value 1 to display and print frames for all images in a
drawing.

-Type value 0 to hide all frames on the screen and during .

printing. i

e

L.

Model [ Layoutl / Layout2

ommand: _imageframe
Enter new value for IMAGEFRAME <1»: @
Regenerating model.
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To clip an image in the shape of a rectangle and polygon:

1.Choose Modify>Clip> Image2.Select the edge of the image you
want to clip.

3.Type N (New boundary) to create a new clipping boundary.

4 If you choose Rectangular:

-Define the first corner of the clipping rectangle.

-Define the second corner of the clipping rectangle. The selected image
is clipped so that only the interior of the rectangle is visible.

5.1f you choose Polygon:

-Select the points for the polygon, and then press Enter \
when the polygon is complete. The selected image is h

clipped so only the interior of the polygon is visible.

11.2.6. Change Raster Image Brightness, Contrast, and Fade

Use IMAGEADJUST to adjust displaying result and lightness, contrast and fade that are related to the display and plot effect
when plotting drawings. IMAGEADJUST does not affect the original raster image as well as other instances of the image.

Retain
isplaying -
|

Creste Define  Manage  Block 54
Block - Attribute Attributes Editor  Foint

Block Set Base i

r N
Image Adjust g
Brightness 20151202100143

Dark 0 Tint 28
Contrast

Low {2 High 50

0

OK

11.2.7. Improve the Display Speed of Raster Images

You can adjust the display speed by setting the raster image quality. The image quality is sorted into high and draft levels, If the
quality is set to draft, the image will be displayed with some granular materials, however with faster display speed.
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12. Layout, Plot and Publish Drawings

12.1 Create Multiple-View Drawing Layouts

12.1.1. Overview of Layout

A layout represents a plotted page on which one or more model views are displayed. GstarCAD provides two collateral working
environments as Model and Layout tab. You can create thematic models on Model tab.

Multiple slides of the model can be set in Layout tab. Use these general steps to prepare

your drawing for printing multiple layouts:

1. On the Model tab, create your drawing.

2. Create a new layout. You can use an existing Layout? or Layout? tab, or you can create

a new Layout tab.

Mew layout

From template...
Delete

Rename

Move or Copy...
Select All Layouts

Activate Previous Layout
Activate Model Tab

Page Setup Manager...
Plot...

3. Create at least one layout viewport on the Layout tab. Use each viewport to help control

which portion of the drawing prints and at what scale.

Export Layout to Medal...

Hide Layout and Mode tabs

4. Specify additional settings for the layout, such as the scale of the drawing, print area,

print style tables, and more.
5. Print or plot your drawing.

You can right click on Layout tab and select "New layout" to create a new layout, and also import layout from template. Options

on Shortcut menu are listed:

12.1.2. Work with Model Space and Paper Space

Model space is generally used for creating and editing drawings.
Preparations for plotting are usually working on paper space for the
drawings on layouts are close to the plotting effects.

Model space is an area in which you create two dimensional and
three dimensional objects based on either the World Coordinate
System (WCS) or a user coordinate system (UCS). The contents of
paper space represent the paper layout of your drawing. In this work
area, you can create and arrange different views of your model
similar to the way you arrange detail drawings or orthogonal views
of a model on a sheet of paper.

Layout tab is enabled to make relevant plot settings. Paper space is
provided in each layout option, and you are allowed to create
viewports and specify page setup such as paper size, orientation
and location that can be saved together with the layout.

You can save and name the page setup and apply it to other layouts

‘ Block Reference
Color Bylayer
Layer 0

Linetype Bylayer
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when setting pages. You can also create new layouts using existing layout template file (DWT or DWG).

Click on the Model tab, you can view and edit objects in model space.

12.1.3. Specify Layout Settings

Once created a drawing in Model tab, you can toggle to
Layout tab and setup the layout for plotting, such as paper
size, drawing orientation and so on. You can right click on
the Layout tab to create new layouts or import from
template files, and then click Modify button on the Page
Setup Manager dialog box to set the page.

12.1.4. Select a Paper Size for a Layout

The paper size here refers to the size of the drawing. When
you start Plot dialog box in Layout tab, you can assign the
paper type from pull down list of the Paper Size text box.
The Paper size is directly previewed from the sketch with its
size and units. The available paper types provided in the

G F‘age Setup Manager

Q Cumert layout:  Layoutl

Page setups
<Nonez

Curment page setup:

Selected page setup details

Device name: <Mone>

Plotter: <Mone>

Plot size: 210.00 x 257 .00 Millimeters (Landscape)
Location: Mot applicable

Description: The layout will not be plotted unless a new plotter

corfiguration name is selected.

[ Display when creatin [ Close ] [ Help ]

pull down list are decided by the current configuration. If you want to configure plotters to export raster images, you must
specify output size by pixels. The paper size can be customized in the Plotter Configuration Editor.

12.1.5. Determine the Drawing Orientation of a Layout

The drawing orientation is sorted into Landscape and
Portrait, which decide the plotting orientation of the drawing
to be seen on a paper. Once specified the drawing
orientation, you can control whether to plot the top or the
bottom of the drawing by selecting Plot Upsize-down
option. The changes setup in Page Setup dialog box are
still saved in layouts. Certain page settings can be replaced
by customized plot settings, but the settings will not be
saved in the layout unless you click Apply to Layout option.

12.1.6. Adjust the Plot Offset of a Layout

=]

fo—
G Page Setup - Layoutl

Plot siyle table (pen assignments)

I =

[ Display plot styles

Page Setup

Printer/Plotter
Name: None

Shaded viewport options
Plotter: None As displayed

uy

Locatior Mot applicable:

Deseription:  The layout wil not be plotted uniess a ne
configuration name is selected.

210 mm

Paper size Plot options

Flot object lineweights

1SO_A4_(210.00_x_297.00_MM) -

Flot with plot styles

Plot Plot scale
ares sese Plot paperspace last

What to plot Fit to paper

("] Hide paperspace cbiects

ETR e
Plot ofset forign set to prntable area) 10000 [Wilimeters ¥]= | Drawing orentation
X 000 Milmeters | | Certerthe plot 000 s s S
s ,
@ Landscape =
Y. 000 Milimeters [] Scale lineweights 2] it psicodown

ok | [ canes | [ Hep |

You can offset the geometry on the paper by entering a positive or negative value in the X and Y Offset boxes. Changing the
plotting origin may change the position of drawing on papers. The plot origin locates at

the left lower corner of plotting area with offset value of O relative to X and Y direction. Select Center on Paper if the specified
plot area is part of the drawing rather than the whole layout, which changes the position of plot origin.
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Plot with origin (0,0) Plot with origin (10,10)
12.1.7. Set the Plot Area of a Layout

You can set the area to be plotted in Plot dialog box. When creating new layouts, the default plot option is drawing limits which
means plotting all the objects within the drawing paper. The plot origin is (0,0), located at the left lower corner of the page. Do
the following methods to select a plot area:

-Layout: Plots all the objects within the drawing paper.

-Window: Set the Plot Scale for a Layout, Plots any portion of the drawing you specify within the rectangle window. Click the
Window button to use a pointing device to specify opposite comers of the area to be plotted, and then return to the Plot dialog
box.

-Extents: Plots the portion of the current space of the drawing that contains objects.

-Display: Plots the contents displayed in current view.

12.1.8. Set the Plot and Lineweight Scale for a Layout

G Page Setup - Layoutl

When you specify a scale to output your drawing, you can choose m & *
Fit to Paper to scale the drawing to fit onto the selected paper size. | ™ ™ — e
Usually, the objects in model space are displayed at the scale set sttt iy
in layout viewports. To plot the objects in model space with the o
scale specified in layouts, you assign the scale to 1:1.Even if plot oo o -] mw
scale of layouts is assigned, it's enabled to scale the lineweight at L i e
a certain scale. Scaling the lineweight is nothing to do with the Q, : o ot
plot scale when plotting drawings, which is mainly used for the e | e =
lines included in the objects to be plotted. o) [om] T
12.1.9. Move and Copy Layouts

Newlyot [ G Move or Copy =
You can right click on the Layout tab to select o e ——
Move or Copy option, on the Move or Copy dialog e | —
box, you can select a layout which you want to e
place after the current layout. To Create a Copy of . reve o=
current layout, you can select a layout and check :Iﬂ::%w Manager..
Create a Copy, the copied layout will place before Export Layout to Modsl..
the layout you selected. You should notice that Layor__HideLoyoutand Mode tobs o

Model tab can't be moved or copied.
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12.1.10. Create Layout from Template

Right click on the Layout tab to select from template
option to import DWG or DWT file directly, using

Insert
& Blo

‘
=il o

information of existing template to create new layouts. B2 ot =
. . . . [ DGN Und
System provides template file with extension name i E
as .dwt. Layout templates from any drawing templates o 1
. . . B 30 studion.
can be imported into the current drawing. B rcsrie. -
f@ Drawing Exchange Binary..
@ Windows Metafile. W
Lo . 2 Z:::;;ﬁms @‘ File name: Drawing
To create a new layout from an existing file: R = S i —

1. Choose Insert>Layout>Layout from Template
2. In the dialog box, select the desired template file, and then click
you want to insert, and then click OK. You can choose multiple layo

12.1.11. Create and Modify Layout Viewports

On a Layout tab, you must create at least one layout viewport to see

Open. In the Insert Layout(s) dialog box, select the layout(s)
uts by holding down Ctrl while selecting layout names.

your model. Each layout viewport is created as a separate

entity that you can move, copy, or delete. Any changes you make in one layout viewport are immediately visible in the other
f the drawing). Zooming or panning in the current viewport

viewports (if the other layout viewports are displaying that portion o
affects only that viewport.

Create layout viewports:

1. On the command line, type MVIEW.

2. Type F (Fit), or create 2, 3 or 4 viewports by entering 2, 3 or
4 separately, or specify two opposing corners to create a
custom viewport.

3. Choose the viewport arrangement, typing H (Horizontal) or V
(Vertical).

4. Do one of the following:

-To arrange the viewports to fill the current graphic area, type F
(Fit). -To fit the viewports within a bounding rectangle, specify
the corners of a rectangle.

-4 [

C™

|Viewports: [ON/OFF/Fit/Lock/2/3/4/Polygon/Object]<First corners:FIT

You can create a single layout viewport, or you can divide the graphic area into many viewports arranged

[Horizontal/Vertical/Above/Below/Left/Right].

To modify layout viewport properties:

1. Click the border of the layout viewport whose
properties you want to modify.

2. Open the Properties palette through the menu
option "Tools > Palettes > Properties" or "Modify >
Properties".

Properties %
Layer v n
Calor W Red
Linetype CONTINUOUS |,
Unstype scsle 1,000
Lineweight BYLAYER
Fyperink
CerterX 53829
Certer 4021
Certer? o
Height 71535
Widh 3.8310
on Yes
Gt No
Display locked Mo
Sandard scake_|Custom I
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3. In the Properties palette, select Standard Scale, and then select a new scale from the list. The scale you choose is applied to

the viewport.

Turn Layout Viewports On or Off;

1.Click the desired Layout tab.
2. Type MVIEW and then press Enter.
3. Type ON or OFF.

4. Select the edge of the layout viewport to turn on or off, then press Enter.

Create Non-rectangular layout viewports:

Comm:
cancel

Viewports:

Use Object and Polygonal options of MVIEW to create irregular viewports,
Select Object option to convert objects created in paper space to viewports. While

selecting Polygonal option to draw irregular polylines including arcs and lings which are

enabled to either intersect or three vertexes at least, the polyline will be closed

automatically.

12.2. Plot Drawings

[ON/OFF/Fit/Lock/2/3/4/Polygon/Object]<First corners:OFF

When a drawing is completed, you can output it using several methods. You can plot the drawing on paper or create a file for

use with another application.

12.2.1. Plot Settings

When you create a drawing, you do most of your work on
the Model tab. At any time you can print your drawing to
see how it looks on paper. It's easy to startup printing,
and then later create layouts and custom print settings to
enhance your printed output.

To start printing:

1. Choose File > Plot from the main menu.

2. Set the printer and relevant parameters, and then click
OK.

12.2.2. Set Paper Size

You can assign the paper type from pull down list of the
Paper Size text box. If you want to setup paper size, you

G Plot-Model
Page Setup Plot style table (pen assignments)
Name. [stione> ~J[ Add ) [Mane e
Printer/Plotter Shaded viewport options
Neme flane Shadeplot  [Asdsplayed  +
e e amy
Location: Not appiicable o
Description: ~ The layout will nat be plofied urless a new plotier
corfiguration name is selected. Plot options
Flet te file Ko [F] Plot in background
Paper size Number of copies Plot object lneweigis
[150_A4_210.00_x_257.00_Mw) - 1 z et with plet stles
Plot paperspace last
Flot area Plot scale Hide paperspace cbiects
What to plot Fitto paper ] Plot stamp on
Scale: [ Userone [915eve chirges o ot
Plot offset (origin set to printable ares) 1.0000 Milmeters v | = Drawing orientation
x 115 Willmeters [] Certter the plot 095 s ©® Portrait N
& © Landscape
Y. 1385 Vilimeters Scale lneweights ] Plot upside-own
Preview Fopto Loy | [0k ][ Cancdd ][ b ] [«]
G Plot-Model
Page Setup
1024 00_F Is)
Name: [ <None> X (_640.00_Porels)
700mm_(700.00_x_1000.00_MM}
1S0_C5_(229.00 x_162.00_WM)
F1507B12(1000.00_x_707.00_MM)
Printer/Plotter 1SO_B1_(707.00_x_1000.00_MM)
P 1SO_B2_(707.00_x_500.00_MM)
Name: M 150_B2_(500.00_x_707.00_MM)
Ly 150_B4_(354.00_x_250.00_MM)
1SO_B4_(250.00_x_354.00_MM)
Plotter: None 1SO_B5_(237.00_x_182.00_MM)
1SO_B5_(182.00_x_237.00_WM)
Location: Not applicable 1S0_A0(1185.00 x_841.00_Mk)
/1S0_A0_(841.00__1189.00_MM)
Desciption The layout will not be plotted uriess a new plotter 5941 St o0 -
configuration name is selected. 420.00_MM)
00_MM)
Flot to File S
00_MM)
210.00_MM)
Paper size 7.00_MM)
00_inche
{_E17(30.00_¢_42 00_Inches)
[150_A4_(210.00_x_257.00_M) B [ S e
21 ARCH E (36.00 x 48.00 Inches)
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should configure plotters first, all the available plotters are both system plotters of Windows configured and non-system driven.

To select a printer or plotter:

1. Choose File > Plot from the main menu.
2. From the Name list in Printer/Plotter area, select a printer or plotter you want to use, and then click OK.

12.2.3. Position the Drawing on the Paper
You can adjust the position of the drawing to be plotted on a paper before plotting.
To specify the print area origin:

1. If necessary, click the desired Layout tab or the Model tab.

2. Choose File > Plot from the main menu. PR ——— T e P ———
3. Do one of the following in the Plot Offset area:
-To center the specified print area on the printed
page, select Center the Plot check box.

-To specify an origin for the print area, type the X and Y coordinates.
4. Select OK, and then click Apply to Layout.

X 04353 Milimeters [ 7] Certerthe plot 2946% s (@) Portrait

@ i[andscaps

vy 0.0000 Millimeters Scale lineweights [ Plot upside-down

= [Creotrotopon |[" "ok [ cancel | Hep ]®

Saves changes that you make in the "Plot dialag box' to the
layout.

12.2.4. Set Drawing Orientation ety

The drawing orientation determines whether to plot a drawing portrait or landscape. If yoU — ueetcosee Dii;lf:‘f;l’iilm

select Landscape, plots the drawing using the length edge as horizontal. While selecting : 33:::112?

Portrait to plot the drawing using its minor edge as horizontal Changing, the drawing I

orientation just like rotating the paper under the drawing. Meanwhile, selecting Plot Dijjmlm

upsize-down to control whether to locate the drawing upsize-down on paper. ‘. DE::MM
ol ][0k [ Gra [t |®

12.2.5. Set Plot Scale

Plot scale of the drawing can be specified directly from the Scale e B

pull-down list in Plot Scale area of Plot dialog box. You can also ™ o] e o to o

choose User define to set desired plot scale, or choose Fit to Paper to i o o s o ey Do

scale the drawing to fit onto the selected paper size. The plot scale BT

together with plot unit and drawing unit must be specified before ok [ Cacd | mp | ©
plotting. For example, if you select the paper size to mm, entering 1
under mm and 10 under Units blank produces a plotted drawing with

each plotted unit represents 10 actual millimeters.

[y
“g8sEBaas®EN Y

-

i
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To automatically scale the drawing for printing:

1. If necessary, click the desired Layout tab or the Model tab.
2. Choose File > Plot from the main menu.

3. To scale the drawing to fit on one printed page, in Plot Scale, click Fit to

Paper.
4. Select Apply to Layout and click OK.

12.2.6. Set Plot Options

The following options show plot patterns with instructions on how to plot objects.

-Plot in Background. Specifies that the plot is processed in background.
-Plot Object Lineweights. Specifies that lineweights assigned to objects and

layers are plotted.

-Plot with Plot Styles. Plots a drawing with specified plot styles. Plots
lineweights automatically once selecting this option automatically. If you do not
select this option, objects are plotted with their assigned properties and not

with the plot style overrides.

-Plot Paperspace Last. Plots model space geometry first. Paper space geometry

is usually plotted before model space geometry.

-Hide Paperspace Objects. Suppresses the plotting of objects that are located
behind other objects regardless of how it's displayed on screen. This option is

only available in the Layout tabs.

Plot scale Hide paperspace objects
Fito paper 7] Plot stamp an
Scale: | User define [ Save changes to layout
1.0000 = Drawing orentation
Inches () Portrait
Villmets - B
- =i
Scale lneweights ] Plot upside:down
[ movtomow |[ ok [ Cowel |[ bk | &
-
=
Plot options
Plot in backaground
Number of copies Plot object lineweights
- ] Plot with plot styles
Plot paperspace last
Hide paperspace objects
e &
User define A
1.0000 Milimeters ~ » | = Drawing orientation
9 " () Portrait
4636 units = b
= @) Landscape
Scale lineweights 71 Plot upside-down
[ moytolayot [ ok [ Conedl |[ b | ®

-Plot Stamp on. Horizontally or vertically placed the plot stamp information on a specified corner of drawing. The plot stamp

settings can be saved to log file, also cannot be saved.

-Save Changes to Layout. All the changes you make in the Plot dialog box will be saved to the layout if you click OK.

12.2.7. Specify the Area to Plot

To specify a portion of the drawing to print, if necessary,
click the desired Layout tab or the Model tab.

1. Choose File > Plot from the main menu.

2. Under Print Area, click one of the following:

-Display — Plots the current view on the screen.

-Extents — Plots the contents within the specified drawing
extents.

-Limits/Layout — Plots the contents within the specified
drawing limits or entities in the printable area.

-Window — Plots the portion of the drawing contained in the
specified window. Click the Window button to use a pointing
device to specify opposite corners of the area to be plotted,
and then return to the Plot dialog box.

3. Select Apply to Layout and click OK.

G Plot-Model T — e
Page Selup Plotsiyle table fpen assignmerts)
Name:  [<heone> <[ A ] [Nene -le
Pirter/Pltter Shaded viewport options
Name: [None Shadeplot [ As displayed =
e e aney
Location Nt applcable
Desciption:  The layout wil not be plotied urless 3 new pltter
corfiguration name ks selected
Plotto e
Paper size
[150_A4_(210.00 x_297.00_m) -] 1
Plot paperspace last
Flot scale Hide paperspace obiscts
Fit o paper [F Pit stamp on
Scale: | User define Saye changesto layout
Ee irtable ares) = Drawing orientation
Windo, jmeters (] Center the plot 24982 |uis e N
o © Landscaps
1385 Wilimet seichts
X lmeters Scale Ineweichts 7 Pt upside-down
Pr [ Aepytolayou | [ 0K ][ Cancel ][ hep ]
|
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12.2.8. Preview a Plot

Viewing a drawing before printing gives you a preview of (G Piciose =)
what your drawing will look like when it is printed. F S e
Narme: [stiene> - A ) [Nene g
Printer/Plotter Shaded viewport options
To preview a drawing before printing: S e———

Plotter: Canon iR2318/2320 UFRII LT Quaity

Location 1P_132.168.021

Descrpton:

1. If necessary, click the desired Layout tab or the Model tab. | ===
2. Choose File > Plot Preview from the main menu. r—
3. Do one of the following:
-To print the drawing, click preview and click Plot on the top -

left corner of print preview. X % Wanetes ClGerietho i

y. 1365 Vilimeters Scale inewe

-To return to the drawing, click the off button or press Esc.
g P ==

Plot cbject lineweights
Plot with plot

Plot paperspace last

Fide paperspace objects

[T Piot upside down

soohiolmvon | [ 0K ) [ Ganodl [ meb ] [«]

12.2.9. Use Plot Styles

Plot styles help you control what your drawing looks like when it is printed. Because plot styles are saved in plot style tables,
which are files located on your computer, you can reuse them to help eliminate the need to reconfigure your print settings each
time you print a drawing. A drawing can use one type of plot style table at a time. There are two types of plot style tables:
-Color-dependent plot style tables (CTB) contain a collection of plot styles based on each of the

)
255 index colors available in a drawing.-Named plot style tables (STB) contain a collection of
plot styles that you define. They can vary regardless of color. Fla e ensssarmers)
i &

5 DWF Virtual Pens ctb
To assign plot style tables:1. If necessary, click the desired Layout tab, or click the Model tab. g Patems o
2. Choose File > Plot from the main menu. ez
3. Under Plot Style Table (pen assignments), select a plot style table in the one of the following: Hggz::;:ggg;gg
-None: Applies no plot style table. Objects plot according to their own properties. Eiri.e"m e

-Monochrome: Plots all colors as black.
-New: Creates a new plot style table.
4. Select Save Changes to Layout, and then click Apply to Layout.

To MOdlfy plOt Style tables: TG Pl Style Table Editar - gead s (=)
Fom Vi

Plot styles Properties

1. Choose File > Plot from the main menu.

2. Under Plot Style Table (pen assignments), click the plot style table you
want to modify, and then click the button to display “Plot Style Table Editor”.
3. Click the General tab on Plot Style Table Editor, and then do any of the
following:

-Enter a new plot style description. e i
-Select Apply global scale factor to non-ISO linetypes to apply the scale factor i )
-Enter a scale factor to apply to non-ISQ linetypes used for any plot style in the
current plot style table.

Linetype: Use object linetype -

Adpite

2 tnewsighl' |joc obiect ineweight =

Use cbiect join style

Edi Linweights... | [ Saveas

@
E
o
g
8
T
z
&
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4. Click the Form View tab, and then do any of the following:

-Make changes to a color-dependent plot style by selecting it in the Plot list,
and then make color, linetype, or lineweight changes for the plot style in
Properties area. Your changes are saved automatically for the selected plot
style.

-Make changes to a named plot style by selecting it in the Plot list, and then
make color, linetype, or lineweight changes for the plot style in Properties area.
Your changes are saved automatically for the selected plot style.

-Add a new plot style by clicking Add Style. Enter a new name, and then click
OK. Select the options for the plot style. (Available for named plot styles only.)
-Delete a plot style by selecting it in the Plot list, and then click Delete Style.
(Available for named plot styles only.)

5. Click OK.

12.2.10. Plot Files to Other Formats

S Pt sore ok B s
G Plot Style Table Editor - gead.ctb
General || Fom View |

Plot style table file name
goad b

Fie Information
Number of styles: 255
Path: C:\Users\ovs\App Data'\Roaming \Gstarsoft \GstarCAD\R17.0'en-.. \gead ctb
Version1.0

Legacy (can be used to import old DWGs)

] Apply giobal scale factor to non-150 linetypes
1 Scale factor

Save &Close

Plot files have various formats. You can output drawings in any image formats with unique plotter driver.

G Plot-Model e —SR =)
Page Setup Plot style table (pen assignmerts)
Name: [(None> '] l Add ] [gcad.ab v] &
Printer/Plotter Shaded viewport options
Name [Canon iR2318/2320 UFRILLT -] Propeties.. | Shadeplt | As displayed =
Send To OneNote 2010 |7
Plotter Microsoft XPS Document Writer m Quality
. Fax T
Location:  Canon iR2318/2320 UFRII LT L 100
D . DWFE ePlot pc3 B
LBl DV <Flot (XPS Compaible).p B
I Pitto e VG T2 PDEpc Flet options
o File Pyl
i el et Nl [CPetinbackground
Paper sze Number of copies Plot object lineweights
[M '] 1 = Plot with plot styles
Plot paperspace last
Flot area Flot scale Hide paperspace objects
What to plot: Fit to paper [F] Plot stamp on
Scale: | User define Saye changes to layout
Plot offset (origin set to printable area) 1.0000 = Drawing orientation
x 1% Wilimeters.[I] Center the piot 336635 |unts ] b
. = ) Landscape
Y. 1385 Milimeters Scale linewsights [ Plot upside-down
| e ) e ) [

12.2.11.Publish Drawings

Specifies drawing sheets that you can assemble, reorder, rename, copy, and save for publishing as a multi-sheet drawing set.

You can publish the drawing set to a DWF, DWFx, or PDF file or send it to the plotter named in the page setup for hardcopy

output or as a plot file. The following options are displayed in the Publish Dialog Box:
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Publish e
s"’"""‘33 &) 2 Publish Options Information
{Nooe S % 8 Location: C:\Users‘ovs\Documents\
Publshto: 4 Fie Type: Muisheet fie
[an«mdnpapemp '} Naming: Specfy name
V! Agomatically load all open drawings S Layer information: Don include
Merge Control: Line overwrte
6 7 8 9 10
SheaNaneli 3D DWF 12 Page Setup 13 Status
&l UnsavedDrawing 1-Mode! & <Defauk None> o No emors
£ UnsavedDrawing 1-Layout 1 & <Defaut None> o No eors
&3 UnsavedDrawing1-Layout2 & <Defauk None> +” No emors
aal DRAWING SAMPLE MECH4-Model & <Defak None> o No emmors
£J DRAWING SAMPLE MECH4-LOCKI} & <Defauk None> o No emors
£ DRAWING SAMPLE MECH4-LOCKI} & <Defankt None> +” No ermors
Publish Output

Selected Sheet Details | 5 |

— Number of copies: 1 7 Jinclude plot tamp 19 & 20
Layout Name 1 - )
s Btshitonnd D] 5] 29
Plot size Precision: 18 -
Piot scale s | Open in viewer when done 23
Page setup de
[ heowas | 14 [ ][ Coca | [ b |

1. Load Sheet List Button: Displays
the Load Sheet List dialog box, in
which you can select a DSD file or a
BP3 (Batch Plot) file to load.

2. Save Sheet List Button: Displays
the Save List As dialog box, in which
you cansave the current list of
drawings as a DSD file.

3. Sheet List: Displays the current
drawing set (DSD) or batch plot (BP3)
file.

4. Publish to: Defines how to publish
the list of sheets. You can publish to
gither a multi-sheet DWF, DWFx, or
PDF file.

5. Automatically load all open
drawings: When selected, the
contents of all open documents are
automatically loaded in the publish

list.

6. Add Sheets Button: Displays the
Select Drawings dialog box, in which
you can select drawings to add to the
list of drawing sheets.

7. Remove Sheets Button: Deletes the
selected drawing sheets from the list
of sheets.

8. Move Sheet Up Button: Moves the
selected drawing sheets up one
position in the list.

9. Move Sheet Down Button: Moves
the selected drawing sheets down one
position in the list.

10. Preview Button: Displays the
drawing as it will appear when plotted
on paper by executing

the PREVIEW command.

11. Sheet Name: Combines the

drawing name and the layout name
with a dash (-).

12. Page Setup/3D DWF:Displays the
named page setup for the sheet. You
can change the page setup by clicking
the page setup name and selecting
another page setup from the list

13. Status: Displays the status of the
sheet when it is loaded to the list of
sheets.

14/15.Show and select sheet details:
Displays and hides the Selected Sheet
Information and Selected Page Setup
Information areas.

16. Publish Options: Opens

the Publish Options dialog box, in
which you can specify options for
publishing.

17. Number of Copies: Specifies the

number of copies to publish.
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18. Precision: Optimizes the dpi of
DWF, DWFx, and PDF files for your
field: manufacturing, architecture or
civil engineering.

19. Include Plot Stamp: Places a plot
stamp on a specified corner of each
drawing and logs it to a file.

20. Plot Stamp Settings: Displays

the Plot Stamp Dialog BoxPlot Stamp

Settings Dialog Box, in which you can
specify the information, such as
drawing name and plot scale that you
want applied to the plot stamp.

21. Publish in Background:Toggles
background publishing for the
selected sheets.

22. Send the Sheets to the Plotter in
Reverse Order: When selected, sends

sheets to the plotter in reverse of
default order. This option is available
only if the Plotter Named in Page
Setup option is selected.

23. Open in Viewer when Done: When
publishing completes, the DWF,
DWFx or PDF file will open in a viewer
application.
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Chapter 13 Create and Edit Dynamic Blocks

13. Create and Edit Dynamic Blocks

Dynamic block references contain grips or custom properties that change the way the reference is displayed in the drawing after
it is inserted. Dynamic blocks allow you to insert one block that can change shape, size, or configuration, instead of inserting

one of many static block definitions.

Some dynamic blocks are defined so that geometry within the block can only be edited to certain sizes specified in the block
definition. When you use a grip to edit the block reference, tick marks are displayed at the locations of valid values for the block
reference. If you change a block property value to a value other than one specified in the definition, the parameter will adjust to

the closest valid value.

13.1. Dynamic Block Editor

You can access the Block Editor by typing the edit command or by double-clicking the block without attribute. The Block Editor
ribbon interface will show as below, the black arrows mark the stand for parameters, while the yellow lighting is the symbol for

action. It will pop-up toolbars in a classic interface.

T/ Neme  Dnsert  Ametets 3B Vie  Beage Oyt Heck Bhiter  Kalp  Exress

& - o YUSeE goegE UL %
E§¢. OB Ricin “vom ¢-oTHFH
Hock Attribute = =B L 4B E
_ Beag Tead ewmater Acticn Pwmater Sets

%‘I‘nﬂﬂiy 2 /
Y
T/ visiblity

Syle - - =X
O %X Bk
g2 X
Vizmbality Close Black
State | 2
Fimbility Clese
Trogerties 3 x
%o sadection | % |3
stretch 2
Layes c
Caler W lge
Lisetype Blaw

Lisetype scale I

%md’ 1 Liseveigt  STLATER
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13.1.1. Dynamic Block Editor Tool Panels

Using the tools in this Tool Panel to define, edit and modify dynamic blocks definitions , makes it very convenient and fast.

Manage
Save or Save as the default block; Create or edit another
block.
g &
) 4

Save
Elaock

Manage

Tool
Define, edit or update the block attribute.

o

Define Update
Attribute

Tacl
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Parameter

You can add parameters for Dynamic Blocks on this panel.

18

o, L
&+

Parameter

Parameter

Action
You can add actions for Dynamic Blocks on this panel.
L& % B[R
7w oo
B =

Aotion

Parameter Sets
You can add the parameter set on this panel.
(I I
wa I8 I?MS Iog IR IE

B E
B

arameter Sets

A4 4F 4k d [ d [ 4;? [

£ e o
{!r{:n]::

13.1.2. Parameters

Visibility
This panel is specially used for Visibility editing.

% O b

E 45E -
¥izibility

State

Vizibility

Close

Itis used to exit the Block Editor. Before exiting, some
commands like save or open etc. might not work.

X

Close Block
Editor

Close

Define custom properties for the dynamic block by specifying positions, distances, and angles for geometry in the block. You
add parameters to a dynamic block definition in the Block Editor. In the Block Editor, parameters have an appearance similar to
dimensions. Parameters define custom properties for the block. Parameters also specify positions, distances, and angles for
geometry in the block reference. When you add a parameter to a dynamic block definition, the parameter defines one or more

custom properties for the block.

A dynamic block definition must contain at least one parameter. When a parameter is added to a dynamic block definition, grips
associated with key points of the parameter are automatically added. You must then add an action to the block definition and

associate the action with a parameter.

Parameters also define and constrain values that affect the dynamic block reference's behavior in a drawing. Some parameters
can have a fixed set of values, minimum and maximum values, or increment values. For example, a linear parameter used in a
window block may have the following fixed set of values: 10, 20, 30, and 40. When the block reference is inserted in a drawing,
you can only change the window to one of these values. Adding a value set to a parameter allows you to limit how the block

reference is manipulated in a drawing.

Point Parameter

lcon: LE'

Command: BParameter—0
Definesan X and Y location in the drawing. A point

parameter can be associated with a move or stretch action.

Linear Parameter

4 [
lcon; M

Command: BParameter—L
Shows the distance between two anchor points. Constrains
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grip movement along a preset angle. A linear parameter can
be associated with a move, stretch, scale or array action.

Polar Parameter
o
lcon; "

Command: BParameter—P

Shows the distance between two anchor points and displays
an angle value. You can use both grips and the Properties
palette to change both the distance value and the angle. A
polar parameter can be associated with a move, scale,
stretch, polar stretch, or array action.

XY Parameter

lcon;

Command: BParameter—X

Shows the X and Y distances from the base point of the
parameter. It can be associated with a move, scale, stretch,
or array action.

Rotation Parameter

Icon:ii\n

Command: BParameter—R
Defines an angle. The rotation angle can be in any value, or
be defined in a range or a specified value.

Alignment Parameter

Icon: =

Command: BParameter—A

Definesan X and Y location and an angle. An alignment
parameter always applies to the entire block and needs no
action associated with it. An alignment parameter allows the
block reference to automatically rotate around a point to
align with another object in the drawing. An alignment
parameter affects the rotation property of the block.

Flip Parameter

=3
lcon:

Command: BParameter—F
Aflip parameter flips objects. You can associate a flip
parameter with a flip action.

Visibility Parameter

i

lcon: E

Command: BParameter—V

Controls the visibility of objects in the block. A visibility
parameter always applies to the entire block and needs no
action associated with it. In a drawing, you click the grip to
display a list of visibility states available for the block
reference.

Lookup Parameter

lcon: Ij

Command: BParameter—K

Defines a custom property that you can specify or set to
evaluate a value from a list or table you define. It can be
associated with a single lookup grip. In the block reference,
you click the grip to display a list of available values. You
can associate a lookup parameter with a lookup action.

Base Point Parameter

+

lcon:

Command: BParameter—B

Defines a base point for the dynamic block reference relative
to the geometry in the block. Cannot be associated with any
actions, but can belong to an action's selection set.

141



Chapter 13 Create and Edit Dynamic Blocks

13.1.3. Actions

Actions define how the geometry of a dynamic block reference will move or change when the custom properties of the block

reference are manipulated in a drawing.

Move +&%

ICommand:BActionTool—M

A move action causes objects to move a specified distance
and angle such as a point, a linear, a polar, an XY parameter,
etc, moves all objects in a selection set in a/any direction.

Scale &

Command:BActionTool—S

A scale action such as a linear, a polar, an XY parameter, and
S0 on, scales the selected objects in the direction of the
parameter. Users can manipulate the grips in different way
by changing the properties and values in the Properties
palette.

Stretch [+
Command:BActionTool—TA stretch action causes objects to

move and stretch a specified distance in a specified location.

A stretch action associated with a point, a linear, a polar, an
XY parameter, etc.

Polar Stretch

Command:BPargfrister—PIn A
polar stretch action rotates, moves, and stretches objects a
specified angle and distance when the key point on the

13.1.4. The General Steps of Creating a Dynamic Block Definition

associated polar parameter is changed through a grip or the
Properties palette.A polar stretch action can only be applied
to a polar parameter.

Rotate ¥

Command:BActionTool—P

A rotate action is always associated with a rotate parameter.
Selected objects can be rotated freely, or the way the grips
are mamﬁhlated is different in the Properties palette.

Flip
Command:BActionTool—F
A flip action is always associated with a flip parameter.

Armay B5

Command:BActionTool—A

An array action is associated with a linear, a polar, an XY
parameter, etc, copies and arrays selected objects in
different way.

Lookup [Ei

Command:BActionTool—L

A Tookup action can only be associated with a lookup
parameter.

In order to get a Dynamic Block Definition, improve block editing efficiency and avoid repeating modifications, we can create

Dynamic Block by the following steps.

Step1: Planning

Before creating Dynamic Block, it is essential to plan Dynamic Block, plan the functions, appearance, the method of drawing
and required Parameter(s) and Action(s) which are needed to achieve prospective functions.

Step2: Draw geometric figure

The included basic pixel during Dynamic drawing, of course, you can draw these pixel in Block Editor.

Step3: Add Parameter and Action

This is the most pivotal step when creating Dynamic Block. When editing the Parameter and Action, you not only consider the
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achievement of Parameter and Action, but also consider the readability of Dynamic Block and the convenience of Modification,
let the action point of the Parameter attach on the corresponding pixel as far as possible, and put the Action near to its relevant
parameter, if there are more Parameters and Actions, they still need to be renamed for understanding, editing and Modification.

Step4: Test Dynamic Block
Save and Exit Block Editor, start the Dynamic Block test to check if it reaches to the prospective effect.

13.2. Dynamic Blocks Creation Samples

See what you are able to do within the Dynamic Block Editor, and get the most out of your design. See the follow samples:

13.2.1. Base Point Parameter

Although the majority of parameters only taken into effect when operations are matched with

actions, there are exceptions, base point parameter is one of them. - = v;sﬁ“y ft 4 X
Visibility Close Block

State Editor

Visibility Close

1. Define blocks: Define block and draw a circle in the block editor, as shown.

2. Add base point: Click "base point" parameter on the parameter panel, put the parameter on
the center of the circle according to system prompt, as shown in the below illustration.

% AETE
e _EJ +
3. Insert block: Save and exit block editor, insert the block in the model. You
can realize, base point becomes the insert point of the block after adding the
base point parameter. Please note, if you set an insert point via the block define Frenily et ot o B[S K]
dialog box, and add a base point parameter as well, the base point is the default
insert point.
13.2.2. Visibility

Using the Visibility Parameter function, you can control the display and hide a certain view in Dynamic Block.
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1. Prepare view: Prepare a three cars view and define as block.

2. Add Parameter of Visibility: Enter into Block Editor by Double-clicking the Block or right- click the menu, click the button
Visibility of Parameter in the Parameter panel, appoint the position of the Parameter according to the system prompt, as shown

below.

WVisibility

3. Edit the states of Visibility: Double click the button Visibility, the Visibility States dialog box will be displayed. In the dialog
box, you can rename, new and remove the Visibility States. In order to control the visibility of the three cars view in this example,
we click on new for the three Visibility States as shown in the following picture.

Click the following button as shown in the picture and choose roadster in the pull down menu.

Visbiy Stetesty,
I % B ik T | o
g = cars
. Roadster [=] Truck
Visibility
State Roadster R
¥i cars -
Truck
[ 0K ” Cancel ][ Help(H) ]
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Click the “Invisibility” button in the Visibility tool panel, select truck and car, make them I= % O SN 4
*=—  Roadster -
invisible in the “roadster” state, as shown in the following picture, after selecting, press e s
¥isibility Close

enter to confirm. For the state of “Car” and “Truck”, set them in the same way. ~

4. Move and Adjust; After finishing the editing of the Visibility States, move the three cars
view to make them overlap as shown in the picture bellow.

5. Test Dynamic Block: Insert the edited Dynamic Block into a drawing, select Dynamic Block and click the grip of Visibility
Parameter, choose one item in the pop-up pull-down list, Dynamic Block will change the display state automatically, as shown
in the following picture.

E i |

13.2.3. Alignment

/

Alignment Parameter can give dynamic blocks the function of alignment automatically, which can /

save the step of rotating the blocks. Roughn/e Qg

. . . \; \ ,,/;
1. Add an alignment parameter for a roughness symbol: Draw a roughness symbol in the Block Editor. <\ » )
Select the icon of the alignment parameter. Specify the location and the aligned orientation of the ?T\;/_'H
parameter following what the computer asked as shown in the picture, the dotted line is the align

orientation.
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2. Test the dynamic block; Insert the roughness dynamic

blocks, move the align grips, the symbol will align with

the interface of the dimensions, as shown pin the picture % P I , 7%
g | i i€ - . |

Flip: When you use the "roughness symbol block" to label the spare parts, the symbol is sometimes already in the right position,
however, the characters' direction is not right. We need to add the "character flip" function to receive the correct label.

1. Add flip parameter: Click the "flip" parameter button, add the flip parameter W visiblity

i ; ; !
according to prompt, as shown in the picture. i Roug ess

2. Add flip action: Click the flip action button on the action panel, match
parameter and object for the action. Herein, we choose "roughness" as the object, and position the action button, as shown in

below picture. l
flip 2
Use the same method to add a

Histais 4 g o 1 pair of flip parameter and action  pipstate 47 Roug €SS % flip 1
% * of the vertical direction, as Y

shown: -

Vvisihlity FlipState 1
% Vvisiblity

13.2.4. Point Movement

- 1 ] |

1. Draw a drawing: Draw a drawing and define it as a block.

Position
=
g
<
@

2. Add point parameter: Click point parameter on the tool bar, define the parameter

position according to prompt, as shown in the picture.

3. Add move action: Click move action button on action panel, match parameter and object for the action, and define the
position. The position of action label does not affect the effect of the dynamic block, however, for the sake of beauty&
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convenience, try to put the label near the related parameter.

Select Objects Select Objects.

e

Placed action
4, Test dynamic block:Insert the dynamic block, drag the blue grip, then move the

keyway to the right accordingly, as shown in below picture. Obviously, the dynamic L
block can achieve the expected results. Please pay attention, if it is not run with ortho

constraint, the keyway can move towards every direction because the direction of the Point
) ) Movement
point parameter is random, the o .
| A

\
characteristic of the parameter L]Lh l
decides the characteristic of he. | ) ) B
action. S

13.2.5. Linear Movement

Actually, limited to the demand of the material mechanics characteristics, keyway is only allowed to be placed on the central
line. So, a horizontal movement is enough for keyway and the movement to other direction is not meaningful. Next we will take
advantage of the linear parameter to define the keyway’s movement direction on the central line of the step shaft.

1. Draw: Draw the follow drawing and define it as a block.

4y -

Distance

2. Add linear parameter: The way of adding a linear parameter is similar to A‘
dimension, both try to put the absorption point of the parameter on the central 7,%55'&)
line of the step shatt.

Distance

3. Add Move Action: Different from the point move, after specifying the .
parameter, the system will prompt: Specify parameter that is related to

. . . - 4
movement. Select right grip of parameter as “Related parameter point”, as ——JEB» 2 .
shown in the following picture.

The parameter point we mentioned corresponds to the operate point of Move. - Distance
After exiting Block Editor you can drag this point to make dynamic block

change correspondingly. After selecting the related parameter point you can )

specify the move objects for action, as shown in the following picture. Place e - -
action label, save and exit dynamic block.
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4 Testing Dynamic Block: Select dynamic block and drag the right grip of the
parameter. Meanwhile, no matter how the cursor moves, the keyway is limited
to the central line of the step shaft. That is to say with the limitation of the B =
linear parameter, the dynamic block can only move along the direction
specified by the linear parameter.

Diztance Distance 0.8001
e W D S 7 AR Angle
: Move
13.2.6.Number of Grips L g L
R T
<> = =
In the Block Editor, select the lingar parameters, change Pl i SO T
the number of grips to “1” in the properties panel. _ Chain hctions_[fo

P Bl tnb e £ Grips|B v

Husber of Grips
v| Wumber of grips associated to
73 5 object

Save and exit the Block Editor, choose the Dynamic Block, you will
find that one grip has disappeared. In fact, after changing the number
of grips from “2” to “1”, the first thing that disappeared was the basic
grip of parameters, namely the first point when adding parameters.

Position-X 62.0178
' 4 Postion-Y 265695
13.2.7. Angle Offset Bstamce B Move
_—l i Distance multiplier |1
Angle offset 30
Open Block Editor, choose the Angle offset from 0°to 30°in = = ctirivame, |Move
Action type Move
the action property, save and exit the block editor e e
L —
Select the Dynamic Block and then move the right side grip. You will find it o
can only move in the direction of 30°as it is shown in the follow picture. The - —
direction of action can change according to the Angle Offset. ':/ _ _

13.2.8. Linear Stretch

During a mechanical design, we often need to change the position as well as the dimension of the keyway. In this section, we
will add Linear Tensile function for the keyway on the step shaft.
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Distance

1. Add linear parameter:

2. Add stretch action: Click the stretch action button on the action
panel, choose parameter according to prompt and define right
grip as key parameter point, as shown in below picture. The black
object is the operational object of the action, the broken line
frame is the stretch frame, objects intersect with stretch frame will
be stretched, objects which will be selected by the stretch frame
will move.

& Yerte
‘W Stretch Vartex-
Z, .

Distance

3. Test dynamic block: Exit from block editor, drag stretch grip to stretch

the keyway, as shown in the picture.

13.2.9. Parameter Value Set

For mechanical designs, we often need to stretch the keyway to a certain length. Now, let us see how to realize an accurate
stretch. Pick linear parameter in block editor, click entry frame which is on the right side of" distance type" on the Properties

Start-X 56.6813
Stretch Start-1 24.1734
End-X 57,4814

panel, a drop-down menu will pop up.

Therein, none is the default option, which means it
can stretch optionally. With the other two options,
you can define the maximum and minimum number
respectively.

End-Y 24.1734
& |Label offset |2.4279
Distance 0.8001
Angle

Base Location Start Point

Show Properties Yes

Chain Actions No

"Increment" means stretch increasingly, a Value set

appears as shown below after selecting increment. If you choose "list", a
Value set appears as shown in below picture, the dynamic block can

only be stretched according to the number in the list.

Click the text frame which is on the right side of the "distance
value list", one button with ellipsis on it will appear. Click this
button, a "Add distance" dialog box will be displayed. Add

three numbers “17.“1.5”.“2” in the dialogue box, as shown in
below picture.

Exit from block editor and stretch the right grip, you will see
several gray lines appearing on the right side of the keyway,

| [Mumber of Grips|1

Dist type Inarement
Dist increment O Dist type 1ist
Dist miniman 0 : 3
Dist walue list |0 8001
Dist maximun
Add Distance Value 3.3
Distances to add:
i
0.8000
1
15
2
Dist type list
bist vioe 110
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and the keyway can only be stretched to the gray line position, as shown in below picture. Obviously, by value list, you can
define certain numbers of the stretch, to realize an accurate stretch.

=t —-

13.2.10. Symmetrical Stretch

There is an easy way to realize the two-way stretch which is adding _
Left{(Stretch) Right (Stretch)

two actions of stretch. Though it can realize a two-way stretch, the

action of stretch is independent. The parameter needs some additional

setup to realize the two-way symmetrical stretch.

LinearParameter

RS

-First, add two stretch actions for parameter, and select the two grips
of the two parameters as the relevant point of each action.

-Second, in the misc, modify the base location from "Start Point" to "Mid Point", like shown in the picture below. Save and exit
the block editor.

For the convenience of watching the effect, we drew a vertical center line in the middle of : .
the keyway, and then stretched the grip to the left side of the keyway or the right side, as E* T T
shown in the picture below. As the grips are moving, the two-way symmetrical stretch is @

realized.

13.2.11. Distance Multiplier

Take the step shaft as an example, if we stretch the left part of the step shaft and the @

keyway still is at the center point of the smaller diameter shaft after stretching. Then, we
use the “Distance Multiplier” property of action to achieve the aim. {]L - 4= - —f—-—t

1. Add linear parameter and stretch action for step shaft: -Lpamt
Hide the right grip of the parameter point, the action stretch

box is as in the following picture, the bolded object is the
action operation object.
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2. Add Move Action for keyway: Select the left grip of the

Fowea
LinearParameter

linear parameter when moving, stretching the related
parameter points. Move the objects of action and select the
whole keyway, as in the following picture.

3. Modify distance multiplier of action; Select Move LinearParaneter 7 Strstch
Action and modify the default value from 1 to 0.5 in the ;';’ch.
property of the distance multiplier, save and exit the block ﬂ#

editor.

4 Test Dynamic Block; Stretch leftwards grip and with the grip moving leftwards,
the smaller diameter shaft will appear with a stretch effect, the keyway will also
move leftwards accordingly, meanwhile, the keyway is in the center of the

smaller diameter shaft of the step shaft all the time. Although Stretch and Move

have a common parameter, when the Distance Multiplier of Move is modified to
0.5, the displacement of Move can only stretch 0.5 times of the displacement.

13.2.12. Chain Action

ORI |

Angle offset 0

Action nams  Move

Action type
Selection set 6 Object

 w—

If you want to realize a symmetric stretch without changing the keyway center and the length of smaller diameter shaft changes

with the stretch at the same time, how can you realize that?

1. Add stretch for Step Shaft: Add stretch parameter and action for step
shaft as the following picture shows. There into, the bolded objects
indicate the operation object of action. Because the follow-up operation
will not stretch the step shaft by grips of this linear parameter, the grip’s
number of the linear parameter can be modified to “0”.

%St retch

W Streteh
£ LinearParameter

=]

LinearParamster

2. Add linear parameter for keyways: Set the base point
position of the line parameter as “Center” in order to - . ~»
realize the symmetric stretch function. g _

aaaaaa NTEN
End-X 57.4814
End-T 24.1734
Label offset |1.3798

Distance 0.8001

Show Properties Btart Foint

3.Add the stretch rightwards action for the keyway and realize chain action: Select the “Distance” linear parameter and modify
the chain action of prosperity from “NO” to “Yes” as the following picture shows:
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End-X 55.57T5

% Stretch

End-Y 24173

_EiHBﬂIParﬂmet er ‘ - ] Lf-bel offset  [2.252
= T oot fomi e
%Streﬂ* Right) %suam‘é [ ];“ type ;{one
l E E _ Dist maximum
RIS — - - 1 e Loeai
%Sueuh
Add the Stretch Leftwards action for keyway as the following picture shows. LimusParasster
H [ ” . Distance
Special Note: Do elect “Distance” for the linear parameter to stretch Bt P
leftwards the operation objects set. This is a necessary procedure of the
chain operation. T = -

4 Test Dynamic Block: After dragging the left grip, not only the keyway will
stretch bi-directionally and symmetrically but also the smaller diameter shaft of
the step shaft will stretch automatically. This is a chain action. The realization of ——
a chain action has two important procedures: First, modify the property value of
the parameter that need to happen as linkage and modify the property of “chain . P
action” from “NO” to “YES”. Second, elect the parameter of objects that are

elected to linkage action to set. E

13.2.13. Scale Action

Scale Action can be matched with the Linear Parameter, Polar and XY Parameter to achieve various Dynamic effects.

Linear Scale

1. Draw: Finish drawing an access hole in a model space and defing it as a block, as shown in the
following picture.

Start-¥ o
2. Add Linear Parameter: Enter into Block Editor to add a B =

Label offset -15. 0527

linear parameter. The start point of the Linear Parameter is
the center of the circle, and choose the number of grip as
“1”as shown in the following picture.

Distance 12
Angle

Dizt type Hone
Dist minimum a

Dist maximum

Base Location |Start Point

Show Properties|Tes

Chain Actions |Ho

A Humber of Grips|(§] v

Humber of Grips
“| Wunber of grips associated to

Fl % object
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3. Add Action; Click the Scale icon on the Action Panel, appoint
parameter for Action and box the whole access hole as Action Object,
as shown in the following picture.

4, Test Dynamic Block: Exit from Block Editor and insert the Dynamic block,
after pitching up the Dynamic Block, drag the triangle grip, the objects (nuts)
will scale with it.

Polar Scale

When we move the Scale Grip of the Access Hole on the left of circle center, namely move the

base point of the Linear Parameter to the left of the circle center, we will find that the block does i\ 2 }L@j’
. . . . \\.@A\\ A//@kﬁ’
not have a corresponding Scale, as shown in the following picture. R

A

The reason for this is that the Endpoint of the Linear Parameter cannot cross its base point, so
we change the Linear Parameter to be a Polar Parameter, we do not change any other
operations, as shown in the following picture.

Exit from Block Editor, Drag the grips of the Access hole Block again,
you can see, that after the change from Linear Parameter to Polar
Parameter, we can drag the grip to scale the dynamic block in any
direction.

13.2.14. Scale Character

In this section, we will explain some Scale characters using XY Parameter and Scale Action in a paired example.

1. Drawing graphics: Draw the graphics which need a dynamic block and define them as a block as below:

O
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2. Add XY Parameter: Entry Block Editor, add XY Parameter. Parameter adding is similar to Linear Parameter. Pick the first point
of the parameter from the left bottom corner of the rectangle as the base point, the second point from the top right corner and
change the Number of Grips to “1”. Then add Scale Action, as shown below.

%Scale
@ Y Distance

o
=

X Distance

3. Test the Dynamic Block: After exiting the Block Editor, drag the grip of the top right I _______________________________
corner of the rectangle, you can see the whole dynamic block is scaling as the grip is Q
moving. It is easy to find that both the circle and the rectangle scale by the base point A

of the XY Parameter.

5. Modify Action Base: Modify Base type: go back to Editor, select Scale Action and change the default “Dependent” to
“Independent”.

[Scale type  [UT Scale

‘B Scale
i Baze-f

s [pase-y
Y Distance ;

|Selection et |3 Object

Eae
o

X Distance

+

Scale type XY Seale

Specify new base: Single click the right input box of “Base-X" and -%ra;c &Eh@
“Base-Y”, you can manually input the coordinate value or you can Pl m .1
single click the small button with ellipsis dots on the right of the ST
input box and snap the base point, as shown: i %

X Distance
Specify the base point by crosshair and the circle center as base point. After ot
exiting Block Editor, scale the dynamic block. After modifying Base type and /
position, the scale center of the dynamic block changes from the XY Parameter
base point to the new specified base point (center of the circle).
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6. Scale Type: There is “Scale Type” in the Scale Action
Properties. The default value is “XY Scale”. If you choose
“XY Scale”, the dynamic block scales whenever the scale
grip moves to X axis or Y axis. If you choose “X Scale”, it

scales only when the grip of the scale moves to X axis. =

Same, when you choose “Y Scale”.

{é7Sca§ﬁ_%

Y Distance

X Distance

13.2.15. Rotation

In this section, we are going to use a rotation parameter and rotate action to add a dynamic rotate function to view index
symbols (English system) which are frequently used in architectural drawings.

1. Draw a drawing: Draw a view index symbol and define as a block, as shown in below picture. Please n
define view number and drawing number as attribute text, so as to revise whenever you want. w

2. Add rotation parameter: Pick the center of the circle as the first point of the parameter, system default it as the rotation point,
setangle type as "increment", and define its number as 15 degree, as shown below.

Center-X
Conter-Y
Conter-Z
Hei ght
Wi dth

W

UCS nene |
|Snap on L3
Grid on 13

Block nune THDE
Scale unifoaly Ko
(Kllow exploding Yes

Unit Willineter

3. Add rotate action: Click the rotation action
button on the action panel, match parameter,
object and position for the action and select the
whole index symbol as the object of the action.

4. Test dynamic block: Exit from block editor and insert the block, drag A{

rotation grip to reach the effect of rotation, as shown in below picture. 101

Rotation

13.2.16. Polar Stretch

We use the Polar Stretch function of Dynamic Blocks to draw the section symbol in this section.
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1. Draw, Mirror and Define as a Block: The follow drawing includes the attribute text which can be modified as you need. Then
mirror this drawing and define the mirrored object as a block.

Ja Al

2. Add action and parameter for the attribute text: Add Point
Parameter and Move Action for text and change the Chain
Action to “Yes” .It is ready for next step to create Chain
Action for Polar Stretch Action.

v
A Distance jE;PolarStretch

3. Add Polar Parameter and Action: Add Polar Parameter whose first point
should be the center of the section symbol. This point will be the rotation center
of the Polar Parameter. Follow the instructions below:

—E—=X
gition
Move

1. Pick the right grip of the Polar Parameter as an associated parameter point and specify the Stretch box (Fig. 3.1).

2. Select objects to stretch and the “position” Point Parameter together, which can accomplish that the text and section symbol
are moving together (Fig. 3.2).

3. Specify objects which rotate only for Polar Stretch Action (Fig 3.3).

4. Specify Action symbol location (Fig 3.4)

5. Repeat the above steps to add the same parameter and action order for the left part.

: Distance ) Distance
1 1 g" ek
— I it
é_/posi v é—/posit
_' = f!\iov - § Mowvs
Fig 3.1 Fig 3.2
i Distance , ' Distance
b L .—c: & e
éji)osﬁ ' éé_./\)osii
;[; - =1L ;}Hove
Fig 3.3 Fig 3.4
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It is better if you hide the grips which are not associated with the Polar Stretch Parameter as below:

Y
%PolarStretchl Bie e anEa] Fiy DSt EEe | PolarStretch

——— X

pomtlonlm osition
%Movel Move

4, Test Dynamic Block: Open the graphic which
needs to be dimensioned and insert the completed
dynamic block (Fig 4.1).

Drag the grip of the dynamic block, the section
symbol can be stretched outward and rotated .
around the center, and you finish the section | |
symbol mark (Fig 4.2). ‘ |

Fig 4.1 Fig 4.2

Before modification

13.2.17. Polar Stretch Action Characteristics -

& A
Modify the grips’ number of the polar parameter in the section symbol dynamic block Kodified
in the last example to display both of the two grips of the polar parameter. From the A I— w .I A

following picture we can see that the central grip is clearly different before and after.
Before modifying, the central point was actually the base point of the block, and this was the insert point. But after modifying,
the center point of block is the base point of the polar parameter.

Clicking central grip can move the grip to any direction. Meanwhile, the dark blue insert point of block will appear again, as
shown in the following picture. Obviously, the insert point is only covered by the base point of the polar parameter. The base
point of the polar parameter can move arbitrarily, but for the block it seems that no - oy

change is happening. But is it true? A l— o -.[ A

L A
In order to confirm if the block changes or not, we move the grips on AI— 2 //-1 A E> Ar = A
both terminals and we can find that the section symbol does not center ]

on the dark blue base point when changing but it takes the base point of ay A /-
the polar parameter as a rotate center, as shown in the following picture. Ar i -] A E‘>
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Enter block editor, move up the parameter and the other settings do not change.

) Distance

,
%Polarstretlchl Distancel % %Polarstretch

—fE—r ¥
posﬂ:wnlM ’ osition
%Movel Move

Exit block editor, move the right grip and you can see that rotate center moves up along with the parameter. From the examples
above it is difficult to understand that the polar parameter cannot move arbitrarily like the point parameter and linear parameter,
the reason is that the base point of the polar parameter s
specifies the rotate center of the object, once the parameter is = " T_ Néa
moved, the rotate center will move accordingly. That the rotate Ar A -iﬁ :> A

parameter cannot move arbitrarily has the same reason.

13.2.18. Array

For the Array function of Dynamic Block we need to use Array Action, we use Array Action to match with Linear Parameter, Polar
Parameter, XY Parameter to achieve various Arrays.

Linear Array

1. Draw: Draw a parts list and define it as a block.

o, Name Number | Materials Norm Note

2. Add Linear Parameter: After adding Array Action, we can drag the two grips of the Parameter to make a list array, but
obviously, we hope just to achieve an up array of the blank bar, not a down array, so to avoid a mistakes, we should hide the
grip under the Parameter, as in the following picture.

Lﬁé Array 1staa.kr)'llceei’hnraY

MNo. Name MNumber | Materials Norm Mote

i
fast =

=5} =

3. Add Array Action: During the add Array Action, the system will require to appoint space between columns. The space
between columns is the distance between the objects that the array created. Here, the line width is 7mm, for the line between
the lines a close up array can be chosen, we appoint that the space between the columns is 7mm.

Arr ayD{i stance

‘B Tanlebrray
{4

No. Name Number | Materials Norm Note _f
73 = X
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4, Test Dynamic Block: Insert Dynamic Block, drag the top right corner grip upwards, the line number of the part list will be
added automatically, as in the following picture.

No. Name Number | Materials Norm Note

=
XY Array ]
Compared with Linear Array, XY Array ) . |
has a vertical direction Array. [ e AU | |
Polar Array

We see a Dynamic Block example as follows, after
dragging grip, the effect will be as in the following
picture. You can see, not only can we stretch the fence,
but we can also rotate the direction casually, this is the
effect combining Polar Stretch with Polar Array.

Enter into Block Editor, Stretch, the ways of adding Array T [
Action as in the following picture, the bold object expresses
the relevance with the selected action. The Polar Parameter
determines the way of Array directly, the Polar Array will regard

the direction of the Polar Parameter as Array direction,
achieving Array functions in any direction. ﬁ-’xrrav Y i ﬁArra‘f

=g

%Stretch ? '?’Eimir.h
é_é *_Q 3

Distance Distance
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14.Share Date between Applications

14.1. .Net Framework Support

NET API enables you to manipulate the application and drawing files programmatically with libraries that are exposed and can
be accessed by many different programming languages such as VB.NET. C# and Managed C+ +.etc. Users are able to
automate tasks such as creating and modifying objects stored in the database of a drawing file or change the contents of a
customization file.

14.2. Cloud Storage

Collaborative capability between different fields like design, engineering, and project team work together efficiently thanks to
cloud storage supported in this version. With cloud storage, you can synchronize your drawing files and custom settings.

G n=~ 5% =

= v ZD Drafting M -
orma 00 g :
D ayo e anage po Cloud

5@ ® @

Cloud Download Upload Upload Current | Backup Restore
Settings Drawings Drawing Config Config

Drawing files synchronous

After register a cloud account, view and share data in the cloud is available. Users can upload or download drawings from cloud
or even create a category to implement drawing synchronous just using desktop and mobile device or tablet PC to operate.
Custom settings synchronous

There are several settings you can customize according to your need such as interface settings, usage habits, object definitions
(font, linetype, hatches and so on). The settings can be saved to local disk or cloud server, which is ease to recover drawing
settings when reinstall the software that can be shared to other members of your project team.

14.2.1.Cloud Settings

Within Options dialog box, under Cloud Storage Sync Settings tab you will see the follow options before connecting to a cloud
driver:

fGTomtore T —— [

Curert profile: <cUnnamed Prfle>> ) Curent drawing Drawing.dwg

[ Open and Save | Plat and Pubiish | User Preferences | Draw | Selection set [ Profiies | Cloud storage sync setings ||« |+

Select Cloud Driver: | Dropbox v [ uthoize |

Information
MName:
Used space: oM

Free space: oM

Drawing transmission settings

Specify download folder:
C:\Wsers\ovs\Documents\Gsta E]
[C] Automatically upload when I save

["] Not prompt when duplicate

[ ok ][ Cancel Apply Help
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Select Cloud: By now on you can select two cloud drivers which one of them is well known Dropbox.

Under Information Title

Name: It displays the user name according to cloud driver you selected.
Used Space: It displays the drawing size that will be uploaded to cloud.
Free Space: It displays the free space available from the cloud driver.

Under Drawing Transmission Settings Title

Specify Download: You can specify the path where the downloaded drawing will be stored.

Additionally there are two options which allows you to Automatically upload a drawing when you save it and Not prompt when
duplicate a drawing. You can check or not these options. These options play an important role when displaying prompts related
to cloud actions at the windows taskbar.

Authorize: This button will browse to the cloud driver selected, thus you can sign into then start upload or download drawings.
If you already have a dropbox account, by clicking the Authorize button, you can sign in and access to dropbox.

Optons

Curert e <cUmamed Pt & Corert Swer; Orowrg ! deg

Flo._| Onptay | Opar and Swwe | User Protarmncen | Comm | Setnction st | Potien | ol oo - 491 Raguest Authorzaton - Sgn =

Seact Gad O [Orsson 3 E g

avmar

e

Sign in to Dropbox to link with GstarCAD_TEST
Geedace: M

Freewace oM

oooooooooooooooo

GatarCAD TEST w. e
Apps + GstarCAD TEST. inside

Then click Allow button to keep signed up to your dropbox account.

After that, you have to go back to the Options dialog box and click Apply and Ok buttons to finish the authorization.

From now on you are able to download, upload or even upload your current drawing with modifications to be updated in the
cloud.

14.2.2. Upload drawings

To upload your drawing(s), just click the Upload Drawing button in the ribbon. And select the file(s) you want to upload.

fPRI=EE = o, -DTTITNE -

File Edit View Insert Format Tools Draw Text Dimension Modify Windo

Home Insert Annotation 3D Layout View Manage Export
D b
=y L) ) H =

Cloud Download Upload Upload Current | Backup Restore

Settings Drawings Drawing Config Config

f\-_-\' Upload Drawings (Upload Drawings) ‘

r=% Upload selected drawings to the
cloud
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Then a message will pop up at the windows taskbar telling you that the upload
files has been added to the task queue.

Right away, the Select Folder dialog box will pop. You can Create Folder to
storage you drawing. This reference folder will be created in the cloud directly.
Then press Ok button.

Select folder

- 7]
7 ARCCHITECTURAL DRAWINGS

Cox ) (omat ]|

At the windows taskbar will pop up a message telling you All tasks are finished, that means your drawing(s) was successfully

uploaded to dropbox.

14.2.3. Download Drawings

To download your drawing(s), just click the Download button in the ribbon.

G . = [=] 2 ] W51y Drafting M -

(=]

)= g ()

All tasks are finished.

File Edit View Inset Format Tools Draw Text Dimension Modify Windo

Home Insert Annotation 3D Layout View Manage

& ® P

Cloud Download Upload WUpload Current
Settings Drawings Drawing

Backup Restore
Config Config

Config

Export

$ Download (Download)
¥ Download the drawings in the

specified directery to local

The windows taskbar will prompt a message: The downloaded files has been added to the task queue.

Select files E N a )

Via Cloud
- [7[F> ARCCHITECTURAL DRAWINGS
B2 o | FRONT ELEVATION. dwo |

{71&3) FRONT ELEVATION.dwg

—
13:16

Within the Sefect Files dialog box you can check or uncheck the drawings you want to download. Then press Ok button to

download the file(s).
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Again the windows taskbar will prompt a message: All task are finished. That means the file(s) has been downloaded
successfully at the download path you previously setup.

14.2.4. Upload Current Drawing :
e 1]
. - . & @ @
If you are dOlng current modifications to a draWIng Cloud Download Upload Upload Current | Backup Restore |
| Settings Drawings Drawing Config Config [

that you have previously uploaded to cloud, it doesn’t  p——— T ——— T
matter... YOU can keep Up to date drawmg | 1 é;%; Upload Current Drawing (Upload Current Drawing)

modifications and override if you upload it to the
cloud.

Drawing transmission settings

o ) o . ) Spedify download folder:
After finish drawing modifications ,if you check the option Automatically upload a

drawing when you save on Drawing transmission settings, and then Save or either
press the Upload Current Drawing button in the ribbon to upload your modified [¥] Automatically upload when I save

F:\GSTARCAD\GSTARCAD CLC @

drawing to the cloud. [¥] Not prompt when duplicate

You will see the follow message at the task bar: The upload files has been

added to the task queue. Select folder __
o
“I~= ARCCHITECTURAL DRAWINGS

And the Select Folder dialog box will pop up. You can select the same
folder you uploaded your drawing, and finally press Ok button. Your drawing
will be successfully uploaded to keep it up to date.

Drawing transmission settings
After finish drawing modifications, if you uncheck the option Automatically Shenty doanlost folders
upload a drawing when you save or Not prompt when duplicate and then
press the Upload Current Drawing button in the ribbon to upload your
modified drawing to the cloud. ("] Automatically upload when I save

F:\GSTARCAD\GSTARCAD CLC E]

[ INot prompt when duplicate

You will see the follow message at the task bar: The upload files has
w3
been added to the task queue. : A COTTECTORAL DRATTINGS

And the Select Folder dialog box will pop up. You can select the
same folder you uploaded your drawing, and finally press Ok button.

File already exist

A\ File ARCCHITECTURAL
7" DRAWINGS\REAR ELEVATION.dwg
already exist, if overwrite it?

Cloud file time: 12/19/14 14:58:57
Local fie time: 12/19/14 15:40:15 |

IStk pecmet Cye J[ )
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Then you will get a message telling the drawing you want upload already exist in the cloud, and asking if you want to overwrite
it. You can click on Yes or No button according your choice.

14.2.5. Backup or Restore Configurations

You can backup drawing and program configuration by selecting the BackupConfig button on the ribbon.

Home Insert Annotation ] Layout View Manage Export Cloud l

O b b
= S =) HE =
Cloud Download Upload Upload Current | Backup Restore
Settings Drawings Drawing Config Config

Backup Config (Backup Config)

‘;" Backup the current config to the
cloud or local disk

There are several settings you can customize according to your need such as interface settings, usage habits, object definitions
(font, linetype, hatches and so on). The settings can be saved to local disk or cloud server, which is ease to recover when
reinstall the software that can be shared to other members of your project team.

r ™
(& configuration Backup and Restore ﬁ

Data location
(@ Backup the configuration to local disk
() Backup the configuration to doud driver

Configurations
Options Customize User Interface
Alias file{gcad. pap) Printer support file

Hatch pattern{*.pat) Tool palettes
Template file (*.dwt)
Fonts and shapes(*.shx) Line type(®.lin)

Font mapping file(gcad. fmp)

[ 0K ][ Cancel ]

L

You can also restore settings by clicking the Restore Config button on the ribbon. Select Yes button to check and save the
current configuration before restore it.

- -
Configuration Restare ﬁ

Current configuration will be overwrite We
recommend that you first save the current
configuration. Continue to restore the
configuration?
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14.3. Copylink Command

Using COPYLINK command, Users can copy the current drawing view to the Clipboard and then paste the contents of the
Clipboard into another document as a linked OLE object.
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15.Security

15.1.SECURITY

SECURITY command sets the system security monitoring level, and
display or delete the current trusted publisher certificate. Unnamed VBA e e e
project files can be loaded without warning.

15.2 Security Options in Save As

Security Level | Trusted Publishers

disabled.

"~ run. Unsigned macros are automatically disabled

_ Very High. Only macros installed in trusted locations wil be
() allowed to run. All ohter signed and unsigned macros are

-, High. Only signed macros from trusted sources will be allowed to

documents you open.

Low (not wded). You are not protected from potentially
= unsate macros. Use this setting only f you have vinus scanning
" software installed, or you have checked the safety of all

Ok Cancel

Users could add security options for the specified drawing file, those options will have effect when saving the drawing. Anyone

who wants to open the drawing file needs to input the correct password. Do remember the password, otherwise, the drawing

can't be recovered.

Savein B Desidop - 0draEr
= G Security Options - .
=5
Passwor rd | Digital Signature.
Password or phrase to open this drawing:
[‘j Encrypt drawing propeties
Curent encryption type:

Microsoft Base Cryptographic Provider v1.0

Advanced Options.

—_— —_

III
&

Options

Cenoms

-
(& Confirm Password

==

Reenter password to open this drawing:

Caution:  you lose or forget the password it cant be
recovered. t is suggested to keep a list of passwords and
the comesponding drawings name list in a safe place.
Drawing passwords are not case sensitive.

[ ok || Cancel

Enter password to open drawing:

C:\Users‘ovs'\DesktopDrawing 1.dwg

oK
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16.Innovative Features

16.1. Line Enhancement

ANGLE (A) option is added for line command, with this option you can get a fast way to draw a line without assistance of the
polar or a xline. You can directly input the angle valug refers to X axis as well as you can take other line as reference to input the
angle value and even you can input the angle value directly refers to previous line.

Practice example:

To draw the red line in Figure 1-1, the steps as
below:

1. Execute line command

2. Specify first point:

3. Specify next point or [Angle/Length/Undo]:a

4. Specify angle [Reference] <0>:35(Software will take the X axis as X Axis Forward Direction
Figure 1-1

reference)
5. Length of line: 500

To draw the red line in Figure 1-2, the steps as below:
1. Execute line command

2. Specify first point:

3. Specify next point or [Angle/Length/Undo]:a

4. Specify angle [Reference] <0>r

5. Select a line object: (Please select the reference ling)
6. Specify an angle: 38 7. Length of line: 500

To draw the red line in Figure 1-3, the steps as below:

1. Execute line command (to draw the line 1).

2. Specify first point:

3. Specify next point or [Angle/Length/Undo]: |

4. Specify length: 300

5. Specify next point or [Angle/Length/Undo] (to draw the line 2): a —
6. Specify angle [Reference/reference to Previous/Included angle] <0>: p(Here Figure 1-3
you can try reference to Previous option which will take the extension of the

previous line as reference)

7. Specify an angle: 127

8. Length of line: 500

9. Specify next point or [Angle/Length/Closed/Undo]:a (to draw the line 3)

10. Specify angle [Reference/reference to Previous/Included angle] <0>: 1 (Try Included angle option)
11. Specify an angle: 37

12. Length of line: 400
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16.2. Polyline Enhancement [ @ f G}

Polyline| Circle Arc

- -

The ANGLE (A) option in polyline command which its behavior is similar as the one in line _ ™) Palytine I
command is also added in Polyline. There are still three choices for angle option, you can either |
input angle value which takes X Axis as reference as well as you can input “reference to Previous” [T redangie

angle or “Included angle”. In CAD software, many objects are consisting of Polyline, for example:
rectangle, polygon and revision cloud, donut. Now these functions are classified under the
Polyline drop down list where you can access them quickly.

Rotated Rectangle

Polygon

Revision Cloud

© QO

Donut

16.3. Rectangle Enhancement

OBLIQUE(O) is a new added option to draw an rotate rectangle. The behavior of oblique option is similar as the behavior in ling
command. With oblique option, you can locate the angel of bottom line and the length to get a rotate rectangle, you can draw
an oblique rectangle which has specific angle with X axis and horizontal or has random angle refer to any line.

Practice example:

To draw the rotate rectangle in Figure 1-4, the steps as below:

1. Execute RECTANG command and input oblique option or click the rotate

rectangle icon in ribbon panel.

2. Specify first point:

3. Specify next point or [Angle]: a(Input Angle option) >

4. Specify angle [Reference] <0>:20 X Axis Forward Direction
5. Enter rectangle width: 800
6. Enter rectangle height: 350

Figure 1-4

To draw the rotate rectangle when there is a reference line in Figure 1-5, the steps as below:
1. Execute RECTANFG command and input oblique option or click the rotate
rectangle icon in ribbon panel.

2. Specify first point:

3. Specify next point or [Angle]a

4. Specify angle [Reference] <0>:r

5. Select a line object: (Select the reference line)

6. Specify an angle: 20

7. Enter rectangle width: 800 X Axis Forward Direction
8. Enter rectangle height: 350

Figure 1-5

16.4. Circle Enhancement

CONCENTRIC(C) option is new added in circle command, you can input radius several times to create many concentric circle
after specify the circle center, with this new option, you can get concentric circle in a simple way.
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Practice example:

To draw the concentric circle in Figure 1-6, the steps as below:

1. Execute circle command and input concentric option or click the
concentric icon in ribbon panel.

2. Specify center point for circle:

3. Specify the radius of circle or [Diameter] <400.0000>:100

4. Specify the radius of circle or [Diameter/Undo] <100.0000>:200
5. Specify the radius of circle or [Diameter/Undo] <200.0000>:300

16.5. Copy Enhancement

R300

Figure 1-6

There are three options: measure CE) , divide (1>, path (P) options are added in copy command, user can easily finish the
drawing without the assistance of other operations such as divided by segment, by distance, array, or layout bypath in previous

version.

1. measure CE) when users need to copy objects with same distance and same direction, this option will be very useful.

20

I

2. Divide (1) , you can copy many objects with same distance in a specified distance.

800

()

o)

266.67

(3
O e T

266.67

7
%

D

3. Path (P) After select the path option, you can select divide or measure option again to locate the count objects.
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16.6. Rotate Enhancement

Multiple copy (M) option is added in rotate command, with this option, you can either copy many objects with different rotate

angles, or you can draw circles array.

When rotate, you can select multiple copy option and input several angle values; the software will rotate and copy the object
according to the value you input. You can try copy and rotate 45, 90,135 degree refers to the original object at a time such as

the following figure.

Practice example:

Rotate and copy objects in Figure1-7, the steps as below:

1. Execute the Command: ROTATE

2. Select object:

3. Specify the base point: (Select the center of the concentric)

4. Specify rotation angle or [Copy/Multiple/Reference] <135>:m
5. Specify rotation angle or [Between/Fill]: 45

6. Specify rotation angle or [Exit/Undo]: 90

7. Specify rotation angle or [Exit/Undo]: 135

If the adjacent object angle is fixed, you can select “angle between object (B)
orfillangle C(F) option, then input the angle and the quantity, this option can
replace circle array.

Rotate and copy objects in Figure1-8, the steps as below:

1. Execute the command: ROTATE

2. Select object: (Select the center of the concentric)

3. Specify the base point:

4. Specify rotation angle or [Copy/Multiple/Reference] <30>:m
5. Specify rotation angle or [Between/Fill]: b

6. Specify rotation angle: 60

7. Specify total number of items: 4

Rotate and copy objects in Figure1-9, the steps as below:

1. Execute the command: ROTATE

2. Specify the base point: (Select the center of the concentric)

3. Specify rotation angle or [Copy/Multiple/Reference] <60>:m
4. Specify rotation angle or [Between/Fill]: f

5. Specify angle to fill<360>:

6. Specify total number of items: 1

Figure 1-9
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16.7. Magnifier

MAGNIFIER (a real alternative to change the habit of viewing details and drafting over the most complex drawing at glance).
This tool helps to view a specific area of your drawing as a magnifier with the capability of snap points without performing zoom
in/out on big drawings like map or survey and also is practical to use and customize. Save time on exploring small details of
your drawing or even drafting in a jungle of intersected objects easy and quickly.

1.- Before execute MAGNIFIER command, let’s explain its settings. At the status bar there is a magnifier icon, just right click
mouse and select the option > settings. ..

On
Off

Settings...

v Uselcon

e - BEESE

2.-In the Drafting Settings dialog box, under Magnifier tab, we will see several options. Let’s explain one by one.

r Y
G Drafting Settings g
| Snap and GRid | Polar Tracking | Obiect Snap | Dynamic input | Magrifier | Symmetr| « [
Enable Magnifier by scroll button
Magnifier Style Magnifier Shape
@ Region () Square
() Window @ Circle
Magnifier Factor:
6
]
Magnifier Size{Half-Width)
128 ,—i r
Fade Control:
30 ,_Di
) Lo ) )

Enable Magnifier by Scroll button: If you check this option you can enable/disable the magnifier command by clicking the
scroll wheel of the mouse. Also the shortcut key Ctrl+E is available to activate magnifier.
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Magnifier Style
Region: When activating the magnifier, it will magnify the spot you select from your drawing within the magnifier shape. The
cursor only can move in the magnifier shape. You can execute zoom, pan, and draw objects, etc to see the bigger and clearer

details.

Window: When activating the magnifier, it will not only magnify the part you select, but also magnify the whole drawing
according to the magnifier factor you set. With window style, the cursor can move in and out of the magnifier shape. The
operations, for example zoom or draw objects will not be restricted in the shape of magnifier.

Magnifier Shape

Square: If you choose square option, the magnifier will adopt a square shape.
Circle: If you choose circle option, the magnifier will adopt a circle shape.
Magnifier Size: You can adjust the magnifier shape size as you like.

Fade Control: You can adjust the fade effect out of the magnifier shape.

Magnifier Factor: You can adjust the zoom factor within the magnifier shape.

16.8. QR Code

e Creator Ié]-.
A QR code (quick response code) is a type of bar code that is used GI mf‘” -

to provide easy access to information through a mobile device like Bl - E

H
smart phone or tablet. Comparing with barcode, QR Code can %é?

.|i

storage more information and is widely applied in many fields, for
example; product anti-fake, advertising push, web links, data

[=]

. . e . . Already entered: 27/500 ear da
download, commodity transaction, Positioning/navigation, oo
2D Code Parameters

electronic documents, business card exchange, etc. Take advantage [ Tet ][ ok [ weee |
of QR Code to make text and block attributes from your drawing i Brortevet(Le) <]

|| Drawing Name || pate and Time .
scannable using any mobile phone or tablet with a camera. All you Name: - N
need is one of many available QR code reader applications for your tmage: [o]oeele | s mxm
device. Type QRCODE to execute the command. Copybarcode | | savermage | [_mert [ et |

Parameters of QR Code Creator as below:

Input: In input text area, you can input the text directly or you can pick text data from the drawing, also you can select the preset
data which can display automatically in the input text box.

Already entered:0/500: Displays the entered text number and the maximum Input text number.

Clear: Cleans all data displayed at input text area.

Pick Object: You can select three options to picking objects from your drawing.

Text: Picks text from drawing file, the text will display in input text box automatically after you picked up.

Block: Picks the attribute block from the drawing file, add the tag and value to the input text box. It is always used to pick the
information of the tab.

2D Code: Picks the QR Code from the drawing file to get the information of QR Code
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Preset Data: ~ You can preset data, when the data is needed just check the corresponding option. The information will
automatically added to the input text area.

Drawing Name: When check Drawing Name option, the drawing name will display in the input text area.

Date and Time: ~ When check Date and Time option, the current date and time will display in the input text area.

Parameters of Costumed Field as below:

Name>Add/Edit: ~ You can customize field that common used, when the field is needed, click the pull down list to find it out
and display it in input text box.

Customed field e
No: Input the field number. E——
Name: Input the field name. No Name Value Add
Value: Input the field value. Delete
Add: Add new custom field.
Delete: Delete custom field.
Image: Company logo or others marked pictures can
be added to QR Code. You can also browse pictures
from your computer, JPJG\BMP\PNG\TIF\TGA .etc
formats are supported.
Delete:  Delete the picture selected. et

QR Code Parameters: You can set QR Code image parameters before being inserted.

Version: Creates QR Code according to the data you input. Sets the QR Code version, the
version number will adaptively according to the increase of text.

Error Level: Error level for QR Code data generated.

Size: Set the width of QR Code. H (30%)\Q(25%)\M (15%)\L (7%): the compatibility of
correcting about 15% data error.

Code: QR Code system. Currently we support Code93.

Scale: Set the QR Code printing scale, behind the scale option is the scale list. You can
choose the scale needed, meanwhile, the scale list can remind user the QR Code generating
is related to the printing scale. Finally, it will generate as a block, the scale you set can be the

Error Level:| L (7%) -
Code: QRCode A

Scale: 1 1:1 -

Sive: P block scale to ensure the QR Code can be printed correctly in different printing scales.
SIesetald Error Level:| L (79%) v
imerawing Name [7] Date and Time Cade @

. 1 1ot H oge *
Copx Barcode: Copies an existing QR Code from your current ] .,
drang. Image: DDE‘T} Size: 65X 65
Save Image: Saves the QR Code as a picture, you can either
( Copy barcode | [ Save Image ] | Insert ] [ Exit |

use the picture to print or insert to other document or to CAD
drawing.

Insert:  Inserts the generated QR Code to the drawing as a block
Cancel:  Cancel the dialog box and save the current settings, when you open the dialog box next time, the setting you saved
last time will be displayed.
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16.9. Barcode

Barcode technology has been widely used in a variety of industries. In some design companies, barcode has also been used in
drawing management system, mainly used to corresponding paper documents and electronic drawing file, just by scanning the
bar code in the paper drawing to identify quickly the corresponding part in electronic drawing file.

[ (& Bar Code Creator @1
Bar Code Parameters Preview
Width: 30 =
Height: 10 =
CAD

Scale: 1 | |21 - Gstar

Size: 3 = Display Data  pata Input
Code: |Code?3 - ostarCAD| Seed
[ Pick I I Copy barcode J I Save Image J I Insert H Exit I

Parameters of Bar Code Creator as below:

Width:  Set the bar code printing width.

Height: ~ Set the bar code printing height.

Scale:  Set the barcode printing scale, behind the scale option is the scale list, you can choose the scale needed, meanwhile,
the scale list can remind user the bar code generating is relate to the printing scale. Finally, barcode will generate as a block,
the scale you set can be the block scale to ensure barcode can be printed correctly in different printing scales.

Display Data: ~ Control whether display the data under the bar code.

Size: It “Display data” option is checked means option is activated, you can set the data height.

Code: Bar code system. Currently we support Code93.

Preview: Displays the bar code image and the data input.

Data input box: You can directly input bar code data, also can click seed to generate barcode.

Seed: Generate barcode data by random algorithm. Click the "seed" button, the barcode data will generate randomly and
display directly to the data input box above.

Length:  Set the length of the bar code data. There are two ways: one is control the data length which manually input and
random generated. The other is control the data length that random generated, check the "seed" before activate this setting.
Pick:  Pick up text or bar code. If you pick the data, it will only obtain the data displayed, but if you pick the barcode, you will
get the information of barcode width, height and proportion and data

Save Image:  Save the barcode to BMP format picture, you can either use the picture to print or insert to other document or to
CAD drawing.

Insert:  Define the barcode generated as a block and take left bottom of the barcode as base point. You can insert the barcode
to the drawing file through the insertion point with the scale set before.

Cancel:  Cancel the dialog box and save the current settings, when you open the dialog box next time, the setting you saved
last time will display.
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16.10. Symmetric Draw

No matter it is AEC or MFG industry, there are many symmetric drawing shapes. The usual way to make a symmetric shape is to
draw the first half of the shape and then get another symmetric half by copy or mirror.

Folar Trackng | Otyect Snep | Dyname inout | Magntier | Symmetnc Draw

] Enabie Symeatoc Draw
Pk Symematrc foca
© Xhe ¥ s Custom ™

‘ ti Suppored Ctyect
‘ T

:W—H it

= Ray

Seect Al

Coxr

ey o[ ama Heo

In GstarCAD 2018, it is possible to directly draw symmetrical shapes with Symmetric Draw tool. When drawing the first half you
get another half automatically. The default symmetry axis is X-axis, but user can specify Y-axis or any line in the drawing as
symmetry axis reference.

Users can easily switch on/off this tool by clicking the Symmetric Draw button on the status bar. By the way, Symmetric Draw
tool supports all the drawing commands of GstarCAD.

/%, Model { Layoutl [ Layout2 / = Enable Symmetric Draw
9519273, -136.5146, 0.0000 S (1] N N O B R

Exploring Symmetric Draw Properties G DutingSettings =
H H . . [ Polar Tracking | Object Snap | Dynamic Input | Magnifier | Symmetric Draw | e

Right-Click the Symmetric Draw button at status bar and select Settings et S .

option. The Drafting Settings dialog box will pop up. Now let’s explore e —

the properties under Symmetric Drawing tab.

Supported Object

Enable Symmetric Draw: Enables the symmetric draw tool if is S

checked. i:e;o' 3“:

Pick Symmetric Axis: You can pick X, Y, or a custom axis to start Clhy  [lSene

working with. | | | |

Supported Objects: Symmetric draw tool supports ling, circle,

rectangle, polygon, ray, polyline, ellipse, arc, xline and spline objects e | =
Off

to be drawn as symmetrical shape. =]

Select All/ Erase All: You can select or unselect all supported objects ~— £4teves2 |71 usetcon

at once.
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Symmetric Axis Effect

X Axis option: The objects drawn will take the X
coordinate system as invisible axis line. The effect
of X Axis is mirroring the drawn objects up or down
according to X coordinate system origin location.

Y Axis option: The objects drawn will take the Y coordinate system as
invisible axis line. The effect of Y Axis is mirroring the drawn objects right
or left side according to Y coordinate system origin location. iy

Custom/Pick Axis option: The objects drawn will take the vector
orientation of a selected object as visible axis line. The effect of
Custom/Pick Axis is mirroring the drawn objects according to a
selected object vector orientation whether inclined, vertical or
horizontal.

Pick Symmetric Axis: At status bar, besides ¥ > {
Symmetric Draw button is located another button _< || & i
called Pick Symmetric Axis. The functionality of this

) e
%, Model / Layoutl [ Layout2 “fy Pick Symmetric Axis I

b.6743, 274.9903, 0.0000 Lol - BERSE A b

button is as same as Custom and Pick Axis options.

16.11.0utline Objects

OUTLINE command is another innovative

tool of GstarCAD. This tool allows extract f’a =T @ﬁi [, CHE N i 3 6
O - || Gl & - Eﬁme!. &

the outline shape of selected closed Arc B @;‘ O 03, — = e m:
objects in a window selection method. ;— C =1, ‘\(\
This outlined shape is in fact a polyline . IA | e = [ 0\\,
1B =
i L& o
object created on the current layer that Cradient mf O
you are working with.

a 7l
iEIR

For example, use this tool extract the Boundary j
outline shape of a floor plant house to : .@@ )
later calculate its total area or to outine 11 10

reference draw the roof of it. s [ - -

Remark: Other innovative features, such as Break Object, Block Break, Graphic Compare, Pline Boolean, Align tool, Arrange Tool,
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AutoXLSTable, CAD Table to Excel, Text Incremental Copy, Statistics Summation, Text on line, GstarCAD Tools, Drawing
Compare, Drawing Lock, Batch Purge, etc. Please refer to the express tool guide.

16.12. Area Table

4.5832 m2

The enclosed area and object can be marked number or area,
and the area table can be generated at the same time. The
area data can be exported to a text or table file. The valugs in
the table can be changed automatically when the number or . T o
area size is changed. ‘{‘ ik e L S
Steps to use Area Table

Click “Express Tools” > "Area Table” in turn.

Popup "Area Table" dialog box.

Click “Pick Point” or “Select Obj” to mark area.

If the you checked "Generate Table", you need to determine the table location or the table to be added.

Click the available point coordinate to go directly to the next process. Or select the available existing area table to enter
the next process.

6.  After the table is created or selected, the area can be updated automatically by “Pick Point” or “Select Obj”.

Arca - s P
T 35632 m2 -

Number

SR e

16.13. Automatically Layer

Predefines the association between object type

and the layer that should be drawn in a drawing. B | 7 A

System automatically switches the current layer T m{: _

while drawing the graph., ?nd draws the graph|'c to '7 ‘F‘J‘I | = S

the set layer. If the specified layer does not exist, 0 ' A | V7 =

the system will automatically create this layer 0= V. =/

based on the settings. JJ — =

About Automatically layer dialog box [
Autolayer list:
Display the command name and the corresponding automatic layer settings.
Create a layer setting:
Create a new layer settings including the command name and the corresponding layer settings.
Delete layer setting:
Delete one or more selected automatic layer settings.
Enable Autolayer:
After checking this check box, the software can automatically assign the layer based on the settings when drawing, if not
checked, it doesn’t work.
Save Settings:
Save your current settings to a text file.
Load Settings:
Read the settings file saved by the user and read the settings into the dialog box.

Clear Settings:
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Clear all current auto layer settings.
NOTE: the current settings only work for the currently edited drawing.
16.14. Attribute Increment

Attribute Increment can sort and increment the
attribute value of the attribute block of the same PR Aves

name according to the way the you set. The o - . : e
property value of the attribute block is modified | —

based on the sort value. For example, the attribute “ ~ <
value of the axis number is incremented by the A : ___— 2
way it is set. A i H:-- =8 Ebes
About Atiribute Increment dialog box

Auto Increa

All referenced properties of the selected block are automatically incremented, which is copied, inserted, deleted in the graph,
and the attribute number is automatically updated. When "ATTINC" is on, as long as the drawing is not closed, when copying,
inserting and deleting the block in the drawing, the property number can be updated automatically.

Increase the select:

Only the selected block is processed, and the selected block property is incremented by the order of creation.

Select a block:

Click “Select the block” button, and you can pick up a block from the graphics and acquire the name of the block. If there is no
attribute in the block you picked up, then prompt: The selected block has no attributes. And you need to pick up again.

Block:

Select a block in block list. If there is no attribute in the block you picked up, then prompt: The selected block has no attributes.
And you need to select again.

Select the attribute to increase:

Select the tags to increase. If the block only has one attribute, then the only attribute will be selected automatically. But if the
block has more than one attribute, then all the attributes will be displayed and you can select one or more attributes to increase.
Parameter:

Increment:

The attribute value of the selected block is increased by the increment value.

Add ration:

Add the same increment value to the increment number or letter of the attribute value in attribute block.

Increment Mode:

Here are 3 increment modes: Increase every number, Increase the last number and Increase the first number.

Default option is Increase the last number. If there are numbers in the end, these numbers increase as a whole. If you select
Increase the first number, and here are numbers in the first, they also increase as a whole. If you select Increase every number,
gach number in the attribute value is incremented.

Increment Number:

The default number is “1”, and you can modify it if needed.

Sort:

Set the sort of increment as the followings: Draw Order, Select Order, Left to Right, Up to Down and The Path of Curve. The
default sort is Draw Order, you can select other sorts.

If you select The Path of Curve, system will prompt you to select a curve. the curve can be a curve or a polyline which intersects
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with the selected block, and sort according to the order of the point which is closest to the insertion point of each attribute
block on the curve. If all the points are as the same point, then according to the distance between each insertion point of
attribute block and the curve to sort.

Negative Sequence:

Reverse the order above.

16.15. Viewport from Model

Creates a viewport on layout space by selecting objects in the
model space. And then calculate the viewport size according to the
set ratio and locate the viewport in the layout space. You can
quickly create and set a viewport of the graphics.

Steps to use Viewport from Model
1. In 2D Drafting space. Click “View” > “Layout Viewport” in turn.
2. Specify the first comer point and the diagonal point.
Extents: Obtain the value of the system variables of EXTMIN and EXTMAX in the model space. When EXTMIN and EXTMAX are
the same or wrong, the "Extents" option is not displayed.
Display: Plot the scope displayed in the Model space currently.
Limits: Obtain the value of the system variables of LIMMIN and LIMMAX  in the model space.
When an error scope is obtained, the viewport is not created and shows that "The scope for creating the viewport failed."
3. Please select the layout to create
After you select the scope, the system will prompts you to select the layout to create.
-If the command is executed in the Layout space, the viewport is created directly in the layout space of the command.
-If the command is executed in the Model space, the dialog box pops up for you to select the layout.
4. Specify the insertion point to viewport
-After setting the layout, automatically switch to the selected layout and specify the insertion point of the viewport.
-You can enter coordinates or click a point to set the location of the viewport in a graphical window.
-After setting the location, the computed viewport is generated at the specified location, and the display locked of the
viewport is on.

16.16. Free Scale

FREESCALE command allows you to scales an object or a group of objects without restrictions under three methods;
Non-Uniform, Rectangle and Free.

Non-uniform scale: The scale of X and Y axis can be input separately.

Rect Scale: You can scale a graphic to match a rectangle frame. The rectangle does not need to be drawn, just specify two
diagonal points.

Free Scale: You can move or copy and scale the graphics in a closed quadrilateral frame to another closed quadrilateral frame,
which can be used to generate the pattern of tilting or perspective distortion graphics.
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